Results 1 to 8 of 8
  1. #1
    Uranium Lounger CWBillow's Avatar
    Join Date
    Jul 2002
    Location
    Las Vegas, NV USA
    Posts
    6,371
    Thanks
    78
    Thanked 12 Times in 11 Posts

    Archiving not working in Outlook 2010

    I tried to archive my Inbox for anything prior to 7/1/11. It ran, but there's a whole lot of e-mail prior to that DAT that was left behind.

    What would cause this and is there a fix?

    Regards,
    Charles Billow
    -------------------------------------------------
    "Good judgment comes from experience, and experience - well, that comes from poor judgment."

    ~ A(lan) A(lexander) Milne (1882-1956)- "House at Pooh Corner"

  2. #2
    New Lounger
    Join Date
    Nov 2011
    Posts
    1
    Thanks
    0
    Thanked 1 Time in 1 Post

    Outlook 2010 archiving

    Quote Originally Posted by CWBillow View Post
    I tried to archive my Inbox for anything prior to 7/1/11. It ran, but there's a whole lot of e-mail prior to that DAT that was left behind.

    What would cause this and is there a fix?

    Regards,
    Charles Billow
    I experienced the same thing and discovered that the items that didn't archive had "importance" or "follow up" flags attached. Highlight the offending posts (shift/left clk), Rt Clk, then select "clear flag" and rerun archive. If you experience any additional problems, you can do the same operation then select, instead, "move | other folder" and select the folder within the archived folders to which you'd like to move/archive the posts - done!

    Hope this helps
    Fred

  3. The Following User Says Thank You to ffresh For This Useful Post:

    CWBillow (2011-11-10)

  4. #3
    Uranium Lounger CWBillow's Avatar
    Join Date
    Jul 2002
    Location
    Las Vegas, NV USA
    Posts
    6,371
    Thanks
    78
    Thanked 12 Times in 11 Posts
    FABULOUS. Than KS Freed!

    Chuck
    -------------------------------------------------
    "Good judgment comes from experience, and experience - well, that comes from poor judgment."

    ~ A(lan) A(lexander) Milne (1882-1956)- "House at Pooh Corner"

  5. #4
    2 Star Lounger
    Join Date
    Mar 2004
    Posts
    185
    Thanks
    37
    Thanked 1 Time in 1 Post
    I have the same problem - but the solution does not apply. I have the default auto archive setting at 1 year old, but may emails in many folders much older. Example older emails have no follow up or important flags set. Running the archive command with a date a year ago also does not work - whether the "include items with "Do not AutoArchive" checked" is set or not. Right clicking on the "Archives" folder in the Outlook "Folders" pane shows a Folder size of 85940 KB and the location to be C:\Users\emad\AppData\Local\Microsoft\Outlook\arch ive.pst. Putting that path into explorer shows an archive.pst file with todays date at 105,913 KB. When the archive command is run there is clear activity shown in the status bar.

    If this major problem is ever fixed, I would like to autoarchive from my main set of folders into the mirror set under "Archives" at (say) 1 year old, and then delete mails in the Archives set permanently when they were (say) two years old.

    Help appreciated

  6. #5
    Administrator
    Join Date
    Jun 2010
    Location
    Portugal
    Posts
    12,519
    Thanks
    152
    Thanked 1,398 Times in 1,221 Posts
    Sorry to ask, but how are you archiving? Are you choosing the option to archive all folders according to their auto-archive settings?
    What is the root folder in your case? Personal folders?

  7. #6
    2 Star Lounger
    Join Date
    Mar 2004
    Posts
    185
    Thanks
    37
    Thanked 1 Time in 1 Post
    OK, thanks for your questions, but a parallel search has produced the answer to my main problem. Apparently Outlook 2010 defaults to archiving based on last modified date not last received / sent date. That would be perhaps OK but apparently if just about any program fingers the file (anti virus, backup, ....) this is counted as 'modified'. There is a registry fix, as follows which is working for me.
    "Changing Archive tosent/receive date
    To change the Archivefeature to function on the sent/received date of an item instead of on themodified date, you must have the following updates installed;
    Outlook 2007: Therevised version of update KB2412171 (January 2011) or later.
    Outlook 2010: HotfixKB2516474 (April 2010) or later (like Service Pack 1)

    After applying theupdate or Hotfix, you can enable the option via the Registry;
    [There is something odd in the following keys - there should be no space in "\O utlook\" and there is not in my typed in version which is "\Outlook\" but a space shows up in the preview despite several retypes!]
    Key for Outlook 2007:
    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\O utlook\Preferences
    Key for Outlook 2010:
    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\O utlook\Preferences

    Value name:ArchiveIgnoreLastModifiedTime
    Value type: REG_DWORD
    Value: 1

    E-mail messages willnow be archived based on their Received date, Calendar items based on their scheduled date and Task items based on their Completed date. For more information about the new and old behavior for archiving see KB2500686 (Outlook2007) and KB2553550 (Outlook 2010)."

    The answers to your questions
    ruirb are yes and yes.

    Which still leaves my second question!

  8. The Following User Says Thank You to petermat For This Useful Post:

    Becowboy (2015-09-08)

  9. #7
    Administrator
    Join Date
    Jun 2010
    Location
    Portugal
    Posts
    12,519
    Thanks
    152
    Thanked 1,398 Times in 1,221 Posts
    As far as I can tell, you cannot have Outlook configured both to archive and delete, as the options are mutually exclusive. As these options apply to the default data file, I don't think you can even delete automatically emails that have been archived before.

    For me the problem would be simpler. I keep a .pst file per year. I archive every message to the previous year file and when a new year begins I create a new .pst. So for me, deleting older emails would simply be a matter of getting rid of older .pst files. Actually, as they do not affect my regular usage of Outlook, I don't even delete them. Using the paid version of Xobni allows me to index older pst files and I can keep everything without any troubles.

  10. The Following User Says Thank You to ruirib For This Useful Post:

    petermat (2012-08-15)

  11. #8
    New Lounger
    Join Date
    Sep 2015
    Posts
    1
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by petermat View Post
    OK, thanks for your questions, but a parallel search has produced the answer to my main problem. Apparently Outlook 2010 defaults to archiving based on last modified date not last received / sent date. That would be perhaps OK but apparently if just about any program fingers the file (anti virus, backup, ....) this is counted as 'modified'. There is a registry fix, as follows which is working for me.
    "Changing Archive tosent/receive date
    To change the Archivefeature to function on the sent/received date of an item instead of on themodified date, you must have the following updates installed;
    Outlook 2007: Therevised version of update KB2412171 (January 2011) or later.
    Outlook 2010: HotfixKB2516474 (April 2010) or later (like Service Pack 1)

    After applying theupdate or Hotfix, you can enable the option via the Registry;
    [There is something odd in the following keys - there should be no space in "\O utlook\" and there is not in my typed in version which is "\Outlook\" but a space shows up in the preview despite several retypes!]
    Key for Outlook 2007:
    HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\O utlook\Preferences
    Key for Outlook 2010:
    HKEY_CURRENT_USER\Software\Microsoft\Office\14.0\O utlook\Preferences

    Value name:ArchiveIgnoreLastModifiedTime
    Value type: REG_DWORD
    Value: 1

    E-mail messages willnow be archived based on their Received date, Calendar items based on their scheduled date and Task items based on their Completed date. For more information about the new and old behavior for archiving see KB2500686 (Outlook2007) and KB2553550 (Outlook 2010)."

    The answers to your questions
    ruirb are yes and yes.

    Which still leaves my second question!
    -- Had same issue found that hotfix was already installed. When checking REG no entry as described was available so created entry and this cleared up problem. I am using Outlook 2010 64bit.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •