Results 1 to 7 of 7
  1. #1
    Lounger
    Join Date
    Feb 2010
    Location
    Mentor, Ohio, USA
    Posts
    42
    Thanks
    7
    Thanked 1 Time in 1 Post

    Site Advisor causing Chrome to crash on Yahoo Mail

    A couple of days ago, Chrome (which I've been using for only about two weeks) started going to the "Snap" page whenever I'd open my Yahoo mailbox. Finally tried disabling Site Advisor, and that seems to have stopped the problem. It only happened on Yahoo Mail, and it happened every time. Just wondering whether anyone else is experiencing this.

  2. #2
    Gold Lounger Roderunner's Avatar
    Join Date
    Dec 2009
    Location
    Scotland.
    Posts
    3,462
    Thanks
    16
    Thanked 216 Times in 183 Posts
    What 'Site Advisor' are you using ? Try Web of Trust as a replacement. http://www.mywot.com/
    O wad some Power the giftie gie us, to see oursels as ithers see us!

  3. #3
    New Lounger
    Join Date
    Nov 2011
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Quote Originally Posted by Compulsive Editor View Post
    A couple of days ago, Chrome (which I've been using for only about two weeks) started going to the "Snap" page whenever I'd open my Yahoo mailbox. Finally tried disabling Site Advisor, and that seems to have stopped the problem. It only happened on Yahoo Mail, and it happened every time. Just wondering whether anyone else is experiencing this.
    Hello! I had the same problem, along with Chrome freezing and crashing afterwards. You solution seems to be working on my computer as well. Thank you for sharing the info!

  4. #4
    New Lounger
    Join Date
    Nov 2011
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

  5. #5
    3 Star Lounger
    Join Date
    Dec 2009
    Location
    Hartford, WI, USA
    Posts
    370
    Thanks
    153
    Thanked 62 Times in 37 Posts
    McAfee had Siteadvisor so screwed up for quite some time that I totally abandoned it.

    I reported about it to my customers in a July 2011 blog article.

    Even if Chrome has a fix, IMHO it is Siteadvisor! Too bad that McAfee ruined this little gem of software.

    Other than that I strongly feel that over time Siteadvisor has sort of "weakened" it's ratings. For years I always use "free screensavers" as my demo Google search and SA showed increasingly LESS red on the first page; struck me as kind'a odd. WOT is right back to about a similar number of reds with this Google search as SA originally was.
    Eike J Heinze
    What I am about
    SE Wisconsin

  6. #6
    3 Star Lounger
    Join Date
    Jul 2010
    Location
    Raleigh, NC
    Posts
    211
    Thanks
    11
    Thanked 20 Times in 17 Posts

    Arrow Go with WOT

    I concur with the others that your best strategy is to dump SiteAdvisor and to go with Web of Trust (WOT). SA hasn't really been a reliable source for several years now.

  7. #7
    Plutonium Lounger Medico's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    12,631
    Thanks
    161
    Thanked 936 Times in 856 Posts
    I also use WOT with no problems. Seems to work well with latest released version of Chrome and with IE 9 on my PC.
    BACKUP...BACKUP...BACKUP
    Have a Great Day! Ted


    Sony Vaio Laptop, 2.53 GHz Duo Core Intel CPU, 8 GB RAM, 320 GB HD
    Win 8 Pro (64 Bit), IE 10 (64 Bit)


    Complete PC Specs: By Speccy

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •