Results 1 to 2 of 2
  1. #1
    Star Lounger
    Join Date
    Sep 2006
    Location
    New York, New York, USA
    Posts
    76
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Word 2010: Automated SpellCheck Window Hidden in Windows 7

    Hi,

    I am automating Word's SpellCheck feature from a VB6 application. With most OSes (XP, 32-bit Win 7), the automated SpellCheck Window correctly displays on top of the calling application when it is invoked. However, when running on Windows 7 64-bit, using 32-bit Office, the SpellCheck window is displayed underneath the calling application.

    The only indication that the SpellCheck window was shown is a flashing Word icon in the taskbar. If I click on the calling application's window, I get the typical message that the application is not responding, with the options to click on "Switch To...", "Retry", "Cancel". Clicking "Switch To" works, and if I click on the flashing taskbar icon that also works.

    This seems to be a problem with the communication between 64-bit Win 7 and Word, possibly a z-order issue. I have tried forcing Word to be active and "on top", and also invoked a few different windowing APIs, to no avail.

    Has anyone encountered this issue, even with automating other Office applications?

  2. #2
    WS Lounge VIP
    Join Date
    Mar 2006
    Location
    Maryland, USA
    Posts
    690
    Thanks
    17
    Thanked 66 Times in 56 Posts
    I have had this happen, but wasn't much bothered by it because it launches when I click the taskbar icon. I understand why you would be though.

    Pam

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •