Results 1 to 12 of 12
  1. #1
    Lounger
    Join Date
    Feb 2001
    Location
    Toronto, Ontario, Canada
    Posts
    44
    Thanks
    0
    Thanked 0 Times in 0 Posts

    WinXP Pro - Windows Installer fails

    I just installed WinXP Pro over W2K. I get a message trying to uninstall or install anything on WinXP. The messages says I'm either running under SAFE mode or Windows Installer was installed incorrectly - contact technical support. (I have MS Office XP installed.) I see nothing in the MS Knowledge database yet, but since probably thousands installed over the weekend like me, I suspect there will be a lot of activity in Bill Gate's land this week. Thought I'd try here. (Putting another post in on a different problem, but if I can get this fixed, I can clean up most of my other gliches - so this one is my Number 1 problem today.) Any ideas would be appreciated. ... Michael

  2. #2
    Lounger
    Join Date
    Feb 2001
    Location
    Toronto, Ontario, Canada
    Posts
    44
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: WinXP Pro - Windows Installer fails

    Still no hits on a fix for this. There is no way to uninstall the Windows Installer (at least MS says no). I completely re-installed Windows XP Pro on top of WinXP Pro and the Windows Installer still doesn't work. Unless I get an answer, I suspect the last resort is a Clean install. I don't like that, and haven't done that for many releases. I have dozens up dozens of products that have hooks into the registry. Yecch. Oh well. Waiting... Michael

  3. #3
    ileacy
    Guest

    Re: WinXP Pro - Windows Installer fails

    Sorry. I just checked again but, like you, could find no specific answers.

    Upgrading from W2K to WXP Pro was one thing I tested. Fortunately in my case it worked fine.

    FWIW, I tested the upgrade route but planned to, and did, do a clean install. A lot of the older software I had did not survive the cut to the new system. My theory is to install the basics and then re-install other maybe applications when I have a real need for them. Amazing how much stuff never get's re-installed.

    Sort of like the IBM theory for report reduction. Continue to run the reports for a period, but, don't distribute them. If nobody notices they are missing then, stop running the reports.

  4. #4
    Lounger
    Join Date
    Feb 2001
    Location
    Toronto, Ontario, Canada
    Posts
    44
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: WinXP Pro - Windows Installer fails

    Well, time to do as you suggest. I've been carrying along a lot of old baggage from W95 days - time to clean up: W95 --> W98 --> W98 Service pack --> W98 2nd Edition --> W2K --> W2K SP1, and 2. The more I think about it, the more I'm convinced it's the best. I've got 70gig, but only about 8 or so on the 'C' drive. The other 60 gig is about 70% full so I've been reluctant. I've always installed everything where possible off the 'C' drive. We'll see. I'll update when I get back. Thanks ... Michael

  5. #5
    ileacy
    Guest

    Re: WinXP Pro - Windows Installer fails

    Something that will help is to have good backups. I use Partition Magic 7 and Drive Image 5.

    My upgrade OS application strategy is create a Drive Image of the partition to be upgraded (which by intention has very little data on it) to a backup area on a spare partition. I then back this up to my USB drive and to tape.

    If I have to roll back then I restore the DriveImage and am immediately back to where I was.

    Note you must use the latest releases of both packages to support WinXP formatted NTFS partitions.

  6. #6
    Lounger
    Join Date
    Feb 2001
    Location
    Toronto, Ontario, Canada
    Posts
    44
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: WinXP Pro - Windows Installer fails

    Thanks Ian. I too have PQ and DI and backups. However, I'm trying to move forward. I re-installed as a 'NEW Install' and the Windows Installer is now working. Gradually re-installing stuff. However my performance problem is back! See my post on SVCHOST.
    What was neat in this install is that XP did not format my 'C' drive - that was what I expected. Instead it only got rid of W2K (and not all of it) and left all my other directories intact. It may have messed up My Documents, etc. but I don't use them anyway. I keep my good stuff off the 'C' drive, and back that up separately. Even things like Documents & SettingsMichaelStartupPrograms was kept around which is neat. Allows me to go back and see what I had. (I used a different name for this install.) Anyway, over to upate my performance problem.

  7. #7
    Lounger
    Join Date
    Feb 2001
    Location
    Toronto, Ontario, Canada
    Posts
    44
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: WinXP Pro - Windows Installer fails

    AAAARRRRRGGGGHHHH! It's back! Did a FORMAT "C" drive, the whole schmeear! Darney darn! Now the Windows Installer won't work again! So my original two problem that I got doing an install over W2K are still here! Yecch! I've reported them both to Microsoft over 8 days ago - last Friday I got a note back saying they were busy and to check out the Knowledge Base. Duuuhhhh. Looks like I can't uninstall my other problem. Anyway, while I'm woking on my SVCHOST problem, anyone got a cure for my Window's Installer? ... Michael

  8. #8
    ileacy
    Guest

    Re: WinXP Pro - Windows Installer fails

    Mike:

    Try a Repair Install. It should fix your installer problems.

  9. #9
    ileacy
    Guest

    Re: WinXP Pro - Windows Installer fails

    PS: Your problems are starting to sound more like software incompatibilities. ie, everything works fine until you install some package.

    Identifying what that last change was should give you a good handle on the cause of the problem.

    PPS: What version of Netscape are you installing? I usually only use NS on Linux, but, will take a look at on my test system to see if I can reproduce the problem.

  10. #10
    Lounger
    Join Date
    Feb 2001
    Location
    Toronto, Ontario, Canada
    Posts
    44
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: WinXP Pro - Windows Installer fails

    Thanks Ian. I'll try to let Windows restore my Windows Installer the way you suggest if it happens again.
    I'm using a version of Netscape 4.78 that I downloaded a month or so ago from Netscape. I tried an older version of the file (still 4.78) in one of my scenarios but got the same thing. Anyway, I'm up now. See the SVCHOST forum for details. ... Michael

  11. #11
    ileacy
    Guest

    Re: WinXP Pro - Windows Installer fails

    Given the results with Connect, I see no need to test NetScape on XP (I am never planning to use it there anyway).

    Now NS6.2 on Linux should make it to my top 10 todo real soon.

    Have a better one.

  12. #12
    Lounger
    Join Date
    Feb 2001
    Location
    Toronto, Ontario, Canada
    Posts
    44
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: WinXP Pro - Windows Installer fails

    I'm running NS 4.78 now and it's ok. My previous plan was to go to NS 6.something until this other came up. However, I'm not entirely convinced that the Windows Installer problem has gone away. Fingers crossed.... (Oh, by the way somewhere in all this my Modem got lost. Tried a bypass to the Aventail Connect to go out through a modem and it wasn't there! Weird. It was there a few days ago. If this hangs around I'll start a new thread.) ... Thanks again ... Michael

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •