Results 1 to 2 of 2
  1. #1
    New Lounger
    Join Date
    May 2009
    Posts
    20
    Thanks
    4
    Thanked 0 Times in 0 Posts

    Exclamation Reversing number of Processors used at boot time.

    I made the change shown below years ago. I tried to make a change again, going from 4 processors to 2 processors at boot time. WRONG! What I managed to do is lose the use of 2 of the 4 processors!

    In msconfig Vista is set by default for 1 processor. That strikes me as being wrong if, like me, you have a Core 2 Dual processor. I have 2 processors and not 1. You can change this in msconfig so that Windows 7 sees how many processors you have [1,2,or 4] at startup. This will speed up booting your system.

    This is how I got all 4 processors back.

    Once the number of processors is set in MSCONFIG (BOOT, ADVANCED) from 1 to 4, you cannot go backwards, say to 2, because Windows Vista will then only use 2 processors, and NO OPTION IS PROVIDED TO GO BACK TO 4, only 2 will show in the MSCONFIG, BOOT, ADVANCED drop down menu and Vista will only use 2 of the 4 processors from then on. To correct, and get all 4 processors working again, first go to CONTROL PANEL, SYSTEM AND MAINTENANCE, ADVANCED, ENVIRONMENT VARIABLES. Edit number of processors to maximum number (4) and OK. Then go to MSCONFIG, BOOT, ADVANCED and remove the check in the box above number of processors, (graying it out) and restart Windows. Windows will now use all 4 processors on startup and after startup. Go back into MSCONFIG and check the box you unchecked previously, click on the drop down menu and you will see the option for 1-2-3-4. Edit to 4 and 4 will be the norm from now on. Once the number of processors is set in MSCONFIG (BOOT, ADVANCED) from 1 to 4, you cannot go backwards, say to 2, because Windows Vista will then only use 2 processors after boot up, and NO OPTION IS PROVIDED TO GO BACK TO 4, only 2 will show in the MSCONFIG, BOOT, ADVANCED drop down menu and Vista will only use 2 of the 4 processors from then on. To correct, and get all 4 processors working again, first go to CONTROL PANEL, SYSTEM AND MAINTENANCE, ADVANCED, ENVIRONMENT VARIABLES. Edit number of processors to maximum number (4) and OK. Then go to MSCONFIG, BOOT, ADVANCED and remove the check in the box above number of processors, graying it out, and restart Windows. Windows will now use all 4 processors on startup. Go into MSCONFIG and check the box you unchecked previously, click on the drop down menu and you will see the option for 1-2-3-4 processors. Edit to 4 and 4 will be the norm from now on. So, once making the change in paragraph 2, never try to go from maximum processors to less than maximum or that's what you'll be stuck with.

    Why did I try this change? I was attempting to see if limiting the boot processors from 4 to 2 would change the length of boot the boot up time, assuming that only Windows startup would be restricted to the 2 processors, but after boot up, only 2 processors were showing active. Live and learn!
    Last edited by dbm1rxb; 2011-12-15 at 07:59. Reason: Found an error.

  2. #2
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,577
    Thanks
    5
    Thanked 1,057 Times in 926 Posts
    Limiting the number of processors is there as a debug tool to help with multi-processor related issues. Unless there is a suspected hardware problem with a processor or you are trying to debug a multi-processor issue during program development there is no GOOD reason to modify the default setting.

    Joe

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •