Results 1 to 5 of 5
  1. #1
    5 Star Lounger
    Join Date
    Jan 2001
    Location
    Vancouver, Br. Columbia, Canada
    Posts
    632
    Thanks
    0
    Thanked 0 Times in 0 Posts

    How to delete mouse

    The mouse cursor on my Dell Inspiron notebook computer started going ballistic... it jumps all over the screen. With much difficulty, I can go into Device Manager and find there are three instances of the HID-compatible mouse driver. If I disable all but one of the mice (only one is physically connected), then it works properly. However, the "disable" does not survive a reboot -- all three mice reappear in the list after rebooting.

    How can I make it so the redundant mice disappear permanently?

    Thanks in advance.

    PS - I have used multiple mice on this computer. I suppose that explains why there are multiple entries. I think they are fighting each other to cause the jumpiness.
    --------------------------------------------------
    Jack MacDonald
    Vancouver, Canada

  2. #2
    5 Star Lounger
    Join Date
    Jan 2001
    Location
    Vancouver, Br. Columbia, Canada
    Posts
    632
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Further info. Using the keyboard and Device Manager, I can delete the HID-compiant mouse entries. The deletion survives a Windows logoff and logon. However, if I restart Windows, then the multiple HID-compliant mouse entries return, and the mouse jumps all over the screen.

    If I delete the mice again, and use Device Manager to "scan for hardware changes", then two instances of HID-compliant mouse reappear on the Device Manager list. This occurs WITHOUT an external mouse being connected to the computer. Only the touchpad is physically available to the computer.

    The computer is virtually unusable in this state. I sure could use some help. (Writing this from a different computer).
    --------------------------------------------------
    Jack MacDonald
    Vancouver, Canada

  3. #3
    5 Star Lounger chowur's Avatar
    Join Date
    Mar 2010
    Location
    Indiana
    Posts
    804
    Thanks
    0
    Thanked 54 Times in 51 Posts
    Disabling or Enabling the Touchpad Using the Hot Key:https://support.dell.com/support/top...=en&l=en&s=gen

    Problems cannot be solved by the same level of thinking that created them. -Albert Einsten

  4. #4
    3 Star Lounger jockmullin's Avatar
    Join Date
    Dec 2009
    Location
    St-Eustache,QC,Canada
    Posts
    239
    Thanks
    10
    Thanked 21 Times in 20 Posts
    Hi Jack

    As Chowur implies, the problem may be the touchpad rather than the mouse. I have an old Dell laptop where the mouse pointer went wonky after it warmed up awhile until I disabled the touchpad in the BIOS and then installed an external mouse.

    Also, have you tried disabling the ghost mice in device manager rather than deleting them? Possibly the OS won't try to re-enable them in that case.

    Jock

  5. #5
    5 Star Lounger
    Join Date
    Jan 2001
    Location
    Vancouver, Br. Columbia, Canada
    Posts
    632
    Thanks
    0
    Thanked 0 Times in 0 Posts
    chowur and Jock

    Older Inspiron computer that is not on the list at the URL listed. None of the keystrokes had any effect.
    Tried using Device Manager to disable the touchpad, but it only has "uninstall" option, and I am I bit nervous about doing that...
    Disabling the ghost mice had no effect when I tried several hours ago, now it seems to work. Go figure...


    Thanks for your input!

    Jack

    --------------------------------------------------
    Jack MacDonald
    Vancouver, Canada

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •