Results 1 to 6 of 6
  1. #1
    3 Star Lounger
    Join Date
    Dec 2009
    Location
    FL
    Posts
    330
    Thanks
    27
    Thanked 11 Times in 10 Posts

    Exclamation How to make links automatically be live links in Word 2003 & Win7

    Had a hard drive crash - had xp and Word 2003. Just installed Word 2003 and activated it on computer with Windows 7 Home. In the past I could type a link into a document and as soon as I hit Return it would automatically be live - I could do Control+Click and it would take me to the web page.

    How do I make that function again with Word 2003 in Windows 7 home? the only way I can find is to do Insert/Hyperlink after typing the link and highlighting it. But I want it to just automatically be live without the extra step.

    I have Norton Antivirus 2012 and cannot find anything in there which could be preventing it. I looked at Windows Firewall and added winword.exe to it as an allowable communication on a public network by navigating to the location of winword.exe. Still no live links (meaning they are blue and I can do control/click to get to a web page.

    This is very important to me because I have a document I use over and over which contains links that take me to websites which have the new information on them I need to update the document each month.

    Please - help!!!

    Kelliann

  2. #2
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    9,436
    Thanks
    372
    Thanked 1,457 Times in 1,326 Posts
    Killiann,

    I just tried this on my Win 7 SP-1 64Bit Laptop w/Office 2003 Pro and it worked. I just typed the url and pressed space, it immediately turned underlined & blue and a Ctrl+Click opened the website in FF my default browser. I'd look elsewhere or try reinstalling Word 2003.
    May the Forces of good computing be with you!

    RG

    PowerShell & VBA Rule!

    My Systems: Desktop Specs
    Laptop Specs

  3. #3
    3 Star Lounger
    Join Date
    Dec 2009
    Location
    FL
    Posts
    330
    Thanks
    27
    Thanked 11 Times in 10 Posts
    Retired Geek, thank you for your reply. I was trying that and it didn't work for me,

    I thought I needed to find something in Tools/Options that would fix it, but could not. Seems like when I click Help for a lot of things I get a box that says none is available but this time I did try clcking help out of sheer frustration and help appeared and I found the answer. Before the solution of just pushing space or return after a link is typed can work, you really do have to turn something on. This is what it says in Help and I tried it and now my links go live after typing and hitting return.

    Turn on or off automatic formatting of hyperlinks

    Microsoft Word can format Web and e-mail addresses as hyperlinks as you type,
    but you can turn off this feature if you want.

    1. On the Tools menu, click AutoCorrect Options, and then click the
      AutoFormat As You Type tab.
    2. Under Replace as you
      type, select or clear the Internet and network paths with
      hyperlinks check box.


      It seems the answer is in checking something ion AutoCorrect - who woulda guessed!!!???!!! I do hope this helps others somewhere along the line. There are many who are changing from XP and it's just too overwhelming to try and learn Windows 7 and cope with a new version of office at the same time when you need it for a work project that has a deadline.

      I wish Microsoft would stop trying to look like Apple. If I wanted Apple, I'd buy a durned Mac, for pete's sake.

      Regards
      Kelliann

  4. #4
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    9,436
    Thanks
    372
    Thanked 1,457 Times in 1,326 Posts
    Kelliann,

    Interesting, thanks for posting back. What I'm wondering is how your setting was unselected? The installation of MS Office Pro 2003 I was using is only about 3 weeks old as I had to set up my laptop to dual boot so I could test Access VBA programs in both 2010 & 2003 w/o worrying about interference if they were both on the same W7 installation. This is the 1st time I've used Word 2003 on that installation so it was in the default installation mode, e.g. no changed settings.
    May the Forces of good computing be with you!

    RG

    PowerShell & VBA Rule!

    My Systems: Desktop Specs
    Laptop Specs

  5. #5
    3 Star Lounger
    Join Date
    Dec 2009
    Location
    FL
    Posts
    330
    Thanks
    27
    Thanked 11 Times in 10 Posts
    Retired Geek, I don't know how the setting got changed. I don't believe I did it. This is MS Office for home and students 2003. Also, I have not added any service packs yet Trying to do that now. Maybe service packs fix the problem automatically.

  6. #6
    New Lounger
    Join Date
    Aug 2016
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    [QUOTE= In the past I could type a link into a document and as soon as I hit Return it would automatically be live.
    Still no live links (meaning they are blue and I can do control/click to get to a web page.

    [/QUOTE]

    You can also change all text-only URLs and email addresses in a document into live links in one click by using the Autoformat now button which you may need to add to your quick access toolbar. To add it to the toolbar, Click on the quick access toolbar drop down menu. click More commands. Choose commands from > "all commands" on drop down menu. Scroll down to Autoformat now Click on the right Add>> arrow to add it to the Quick Action toolbar. click OK

    Then open the document, click on the new button and immediately all relevant text items get converted into live URLs and email addresses - all in BLUE!
    Hope that helps
    Joga

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •