Results 1 to 14 of 14
  1. #1
    Lounger
    Join Date
    Mar 2011
    Posts
    25
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Annoying Windows 7 copying files that I want to move

    I have been trying to move some files from one drive to another. I highlight about 15 files and then drag to the other drive. My problem is after I start highlighting the file stupid Windows 7 will start copying them. I have to stop my highlighting, tell windows to stop copying and start high lighting again, only to have it start copying again. This is making it a very long process of trying to move these files. I went to stupid Geek or someplace and did what they said:
    HKEY/current/user/desktop then in the right column found DragWidth and DragHeight and changed the values to 20 from 4. Seems like it made things even
    worse. Can anyone help me fix this so it won't automatically copy without me telling it to?

  2. #2
    3 Star Lounger
    Join Date
    Dec 2009
    Location
    Skelmersdale, Lancashire, UK
    Posts
    252
    Thanks
    44
    Thanked 10 Times in 10 Posts
    Are you right clicking on the selected files then dragging them across, this will give you a context menu on which you can select move rather than copy.

    On the other hand, if they are successfully copied then just delete the originals - same result!

  3. #3
    New Lounger
    Join Date
    Jan 2012
    Location
    Harrogate N. Yorks England
    Posts
    12
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Why not CUT and PASTE?

  4. #4
    Plutonium Lounger Medico's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    12,631
    Thanks
    161
    Thanked 936 Times in 856 Posts
    Hold Ctrl key while highlighting individual files. When done highlighting all necessary files, drag them where you wish.

    Alternately if files are one after the other, hold Shift key, highlight first and last entry. All entries between will be highlighted. Then drag bunch.

    I hope this is what you are talking about, and helps.
    BACKUP...BACKUP...BACKUP
    Have a Great Day! Ted


    Sony Vaio Laptop, 2.53 GHz Duo Core Intel CPU, 8 GB RAM, 320 GB HD
    Win 8 Pro (64 Bit), IE 10 (64 Bit)


    Complete PC Specs: By Speccy

  5. #5
    Lounger
    Join Date
    Mar 2011
    Posts
    25
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Annoying Windows 7 copying files I want to move.

    Exactly what I have been doing. I hold the Ctrl key and high light all the files I want to move. But, while I am doing that Windows starts copying those files. I have to stop and click cancel, then go up to edit and click delete copying. Then I have to start all over. All I want to do is move the highlighted files. When I can move them I do it by right clicking and then click move. I don't want to move a bunch of copied files though. Just the original files. After I posted here, I tried
    it again and I managed to get about 30 files moved without Windows copying. I hope that meant that my changing the value was finally working.

  6. #6
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    S.F. Bay Area, California, USA
    Posts
    735
    Thanks
    15
    Thanked 80 Times in 78 Posts
    Gramps,

    Use the Control key to select discontiguous files to manipulate; use the Shift key to select contiguous files. AFTER the files are selected, use the mouse to drag them to the desired location. BEFORE you release the left mouse button, press and hold the Shift key to move the files, or the Control key to copy them.

    Zig
    Last edited by Zig; 2012-01-28 at 18:42.

  7. The Following User Says Thank You to Zig For This Useful Post:

    jshiii (2012-02-26)

  8. #7
    Plutonium Lounger Medico's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    12,631
    Thanks
    161
    Thanked 936 Times in 856 Posts
    No other ideas then, sorry.
    BACKUP...BACKUP...BACKUP
    Have a Great Day! Ted


    Sony Vaio Laptop, 2.53 GHz Duo Core Intel CPU, 8 GB RAM, 320 GB HD
    Win 8 Pro (64 Bit), IE 10 (64 Bit)


    Complete PC Specs: By Speccy

  9. #8
    Super Moderator
    Join Date
    Jun 2011
    Location
    New England
    Posts
    4,745
    Thanks
    171
    Thanked 648 Times in 571 Posts
    Quote Originally Posted by Gramps2005 View Post
    After I posted here, I tried it again and I managed to get about 30 files moved without Windows copying. I hope that meant that my changing the value was finally working.
    Yes, I think you have fixed it by changing DragWidth and DragHeight from 4 to 20:

    Fixing Annoyances: Stop Windows from Copying Files Accidentally When Ctrl-Click Selecting

    But you may also want to try switching on "Use check boxes to select items" at Tools, Folder Options, View, Advanced Settings so that you don't need to hold down Ctrl.

    Bruce

  10. #9
    Lounger
    Join Date
    Mar 2011
    Posts
    25
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Annoying Windows 7 copying files I want to move

    Yes, it worked. At first it seemed to be worse, then suddenly, well, I have all my files moved. No more copying while highlighting. Thanks everyone for your
    help. The DragWidth and DragHeight worked.

    I'll try the other things of using check boxes to select files, also.

  11. #10
    3 Star Lounger midnight's Avatar
    Join Date
    Dec 2010
    Location
    Almost Deep East Texas
    Posts
    352
    Thanks
    42
    Thanked 8 Times in 7 Posts
    This only seems to apply to XP and Vista.... so is the registry edit the only solution in Win7?

    Barbara

  12. #11
    Super Moderator
    Join Date
    Jun 2011
    Location
    New England
    Posts
    4,745
    Thanks
    171
    Thanked 648 Times in 571 Posts
    Quote Originally Posted by midnight View Post
    This only seems to apply to XP and Vista.... so is the registry edit the only solution in Win7?
    Yes: Is it possible to disable copying when Ctrl - Left Click (Applies To: Windows 7)

    Bruce

  13. The Following User Says Thank You to BruceR For This Useful Post:

    midnight (2012-01-30)

  14. #12
    3 Star Lounger
    Join Date
    Dec 2009
    Location
    New Brunswick, Canada
    Posts
    288
    Thanks
    46
    Thanked 5 Times in 5 Posts
    Quote Originally Posted by BruceR View Post
    Yes, I think you have fixed it by changing DragWidth and DragHeight from 4 to 20:

    Fixing Annoyances: Stop Windows from Copying Files Accidentally When Ctrl-Click Selecting

    But you may also want to try switching on "Use check boxes to select items" at Tools, Folder Options, View, Advanced Settings so that you don't need to hold down Ctrl.

    Bruce

    Thanks, that is so cool.

    The Check Boxes hint.

  15. #13
    Lounger
    Join Date
    Mar 2011
    Posts
    25
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Well the registry hack worked great after the first time I tried it. I also tried the check box thing and it just seems, hard to explain, a pain. Anything I would hover over would suddenly show a check box. So I went back in and unchecked it. If I start having trouble again I'll re check. Thanks all.

  16. #14
    Super Moderator
    Join Date
    Jun 2011
    Location
    New England
    Posts
    4,745
    Thanks
    171
    Thanked 648 Times in 571 Posts
    Quote Originally Posted by Gramps2005 View Post
    I also tried the check box thing and it just seems, hard to explain, a pain. Anything I would hover over would suddenly show a check box. So I went back in and unchecked it. If I start having trouble again I'll re check. Thanks all.
    It's not "normal" for anything to be selected just by hovering over it. I think at some time you must have opted to "Single-click to open an item (point to select)".

    You can change this back to the default setting from Computer or Windows Explorer, at Tools, Folder Options, General; then, under Click items as follows, select "Double-click to open an item (single-click to select)"

    I think this would probably explain your difficulty with drag and drop copying; it's selecting the destination (current folder, not where you want) as soon as you move the pointer.

    Bruce

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •