Results 1 to 5 of 5
  1. #1
    Star Lounger
    Join Date
    Dec 2009
    Posts
    74
    Thanks
    4
    Thanked 3 Times in 3 Posts

    Keep Windows From Rebooting After Update

    Win7 64. I leave my machine on 24/7. For some reason, I look at it in the AM and I'll be at a login screen. After I log in, there is a balloon saying that Windows had to reboot in order to complete updating.

    How do I stop this? I have certain programs/projects open and Windows should -not- be allowed to reboot (and possibly damage my documents.)

    TIA,

    ---JC

  2. #2
    Star Lounger
    Join Date
    Dec 2010
    Location
    Scotland
    Posts
    76
    Thanks
    0
    Thanked 2 Times in 2 Posts
    Windows Update doesn't always need to reboot but when it does it's to finish installation of the update. Some of these need to happen as windows starts up.

    I don't think you can stop it but if you choose to have it tell you when updates are available at least you will get the choice as to when to update.

  3. #3
    Plutonium Lounger Medico's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    12,631
    Thanks
    161
    Thanked 936 Times in 856 Posts
    See if the answer at MS Windows answers might help.
    BACKUP...BACKUP...BACKUP
    Have a Great Day! Ted


    Sony Vaio Laptop, 2.53 GHz Duo Core Intel CPU, 8 GB RAM, 320 GB HD
    Win 8 Pro (64 Bit), IE 10 (64 Bit)


    Complete PC Specs: By Speccy

  4. The Following User Says Thank You to Medico For This Useful Post:

    satrow (2012-02-07)

  5. #4
    3 Star Lounger
    Join Date
    Dec 2009
    Location
    FL
    Posts
    330
    Thanks
    27
    Thanked 11 Times in 10 Posts
    Go to Control Panel, Windows Updates, Change Settings, and then click the drop down arrow and pick check for updates but let me choose when to download and install them. This gives you the most control and still lets you know if any updates are available.

    Windows 7 did the same thing to me twice - I got up in the morning and found all my stuff I'd been working on was gone, Explorer was closed and so were all the 15 tabs I'd had open, my draft emails were gone.... grrrrrr! What nerve they have to set that as default so that the computer will just reboot and catch you by surprise.

    I knew there was a setting - I was using it on my xp computer. I just had to find it and change it to stop that behavior.

  6. #5
    Super Moderator satrow's Avatar
    Join Date
    Dec 2009
    Location
    Cardiff, UK
    Posts
    4,492
    Thanks
    284
    Thanked 577 Times in 480 Posts
    Quote Originally Posted by Ted Myers View Post
    See if the answer at MS Windows answers might help.
    The reply by Aberrance is my preferred fix - Registry edit required. I've used the same fix since W7 was still in public Beta #1.

    Always better to have MSFT/Windows Update notify before selecting and downloading, they don't always get everything right.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •