Results 1 to 7 of 7
  1. #1
    5 Star Lounger
    Join Date
    Mar 2001
    Location
    New York, NY
    Posts
    922
    Thanks
    2
    Thanked 12 Times in 11 Posts

    Do not check spelling

    We are using Word 2010. Much of the information in our letterhead -- staff's names, street addresses of offices -- are not in the Office dictionary. Those words therefore get the red squiggly underline as being misspelled. We have modified the styles (Letterhead Name, Office Address) under Language, and we have checked the box "Do not check spelling or grammar."

    But when our letter template runs, the names and addresses have the red squiggly underline. If I check the style attribute, "Do not check spelling or grammar" is correctly set.

    I'm wondering why this does not work. Might it be because there was no text in the style at the time this attribute was set?

    The alternative seems to be to define the letterhead as a range, and apply SpellingChecked = True to the range.
    Last edited by richardbarrett; 2012-02-05 at 14:11.

  2. #2
    Silver Lounger Charles Kenyon's Avatar
    Join Date
    Jan 2001
    Location
    Sun Prairie, Wisconsin, Wisconsin, USA
    Posts
    2,048
    Thanks
    124
    Thanked 119 Times in 116 Posts
    This is character level formatting.
    Click on one of the names that gives the red line. Press Shift-F1 to reveal formatting. Your text may have an exception to your style (possibly copied and pasted from eleswhere?)

    Note, you letterhead should be in the page 1 header, not in the body of your document.
    Charles Kyle Kenyon
    Madison, Wisconsin

  3. #3
    5 Star Lounger
    Join Date
    Mar 2011
    Posts
    820
    Thanks
    16
    Thanked 62 Times in 57 Posts
    You might like to check the article posted HERE.

  4. #4
    5 Star Lounger
    Join Date
    Mar 2001
    Location
    New York, NY
    Posts
    922
    Thanks
    2
    Thanked 12 Times in 11 Posts
    Charles,

    Character-level formatting seems to be common for Do not check spelling/grammer (formerly known as No Proofing). It's often applied to a section or a couple foreign language sentences here and there. I'm not sure that the style-based attribute would always be the right solution. I agree that it's probably ideal, jut not always feasible.

    Our letterhead is, of course, in the first page header. That's the range to which I would apply Do not check spelling/grammar.

  5. #5
    Silver Lounger Charles Kenyon's Avatar
    Join Date
    Jan 2001
    Location
    Sun Prairie, Wisconsin, Wisconsin, USA
    Posts
    2,048
    Thanks
    124
    Thanked 119 Times in 116 Posts
    Richard,

    Are you using a macro to build your letterhead for some reason?

    If you are, store the letterhead text in an AutoText entry and insert that using your macro. That way you'll have the formatting already applied.

    I do my letterhead using a basic template that contains the header as well as other features.
    Charles Kyle Kenyon
    Madison, Wisconsin

  6. #6
    Super Moderator
    Join Date
    Dec 2000
    Location
    New York, NY
    Posts
    2,970
    Thanks
    3
    Thanked 29 Times in 27 Posts
    Charles: If you work for a firm with offices in multiple locations, then it would be common to use a macro to populate the letterhead with the office-specific info, at the time the letter is created.

    Richard: If you've got bookmarks at each of the locations where each of the pieces of letterhead data is going to get inserted, could you try putting placeholder text (formatted to not check spelling) inside each bookmark? - Maybe that would help the setting stick when the actual data is inserted.

    Gary

  7. #7
    Silver Lounger Charles Kenyon's Avatar
    Join Date
    Jan 2001
    Location
    Sun Prairie, Wisconsin, Wisconsin, USA
    Posts
    2,048
    Thanks
    124
    Thanked 119 Times in 116 Posts
    Gary,

    The way I did the multiple-office thing was to have an office global template that contained office-specific data as AutoText for each office. The base template still called in the AutoText entries using AT fields. That template was created and distributed from the central office. Different strokes for different folks!

    I tried to avoid distributing macros to the extent possible. AutoText in global templates and AT fields are not blocked by macro security.
    Charles Kyle Kenyon
    Madison, Wisconsin

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •