Results 1 to 11 of 11
  1. #1
    3 Star Lounger rcbjr2's Avatar
    Join Date
    Jan 2001
    Location
    Matthews, NC
    Posts
    279
    Thanks
    6
    Thanked 1 Time in 1 Post

    Transfer Word 2007 .QAT file to Word 2010

    I read somewhere, maybe in the Word help, that I can transfer my Word 2007 .QAT file to Word 2010. I believe the process is supposed to be as simple as copying the 2007 file over the 2010. However, when I try this, not of my .QAT settings appear in Word 2010. I made a lot of changes to the 2007 QAT so I would prefer not to have to recreate them. Is there some trick to getting this to work properly?

    Thx.

    -Rich

  2. #2
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,571
    Thanks
    5
    Thanked 1,056 Times in 925 Posts
    See if Migrating Excel 2007 QAT files to Office 2010 helps. It appears that you must change the file extentsion for .qat to .officeui.

    Joe

  3. The Following User Says Thank You to JoeP517 For This Useful Post:

    PamCaswell (2012-02-18)

  4. #3
    3 Star Lounger rcbjr2's Avatar
    Join Date
    Jan 2001
    Location
    Matthews, NC
    Posts
    279
    Thanks
    6
    Thanked 1 Time in 1 Post
    I tried renaming it .officeui (as suggested in the other thread). Does it make a difference that Word 2007 is on a Windows XP laptop and I'm running Word 2010 on a Windows 7 laptop? I wouldn't think so, but one never knows.

  5. #4
    5 Star Lounger kmurdock's Avatar
    Join Date
    Feb 2003
    Location
    Pacific Grove, California, USA
    Posts
    716
    Thanks
    10
    Thanked 34 Times in 28 Posts
    Try changing a couple of lines of code at the top of the file itself. The QAT file is an xml file; you can open it with Notepad (be sure to turn on Word Wrap). I've formatted the code below with line breaks which won't have any effect on the file if you save the file with them. They'll disappear the next time you adjust the QAT within the program.

    My 2010 QAT file has the following references:

    Code:
    <mso:customUI xmlns:x1="http://schemas.microsoft.com/office/2009/07/customui/macro"
                  xmlns:msox="http://schemas.microsoft.com/office/2006/01/customui/special"
                  xmlns:mso="http://schemas.microsoft.com/office/2009/07/customui">
    I have a macro reference on my 2010 QAT, which explains the first bolded line; it doesn't exist in my 2007 QAT file where there is no macro reference. When I opened the 2007 QAT file, I only had the second and third lines, and the third line had 2006/01 in place of the 2009/07 reference.

    Does this help?
    Kim

  6. #5
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,571
    Thanks
    5
    Thanked 1,056 Times in 925 Posts
    Also, you must be aware of the differences in the default locations between the two OSes.

    Joe

  7. #6
    3 Star Lounger rcbjr2's Avatar
    Join Date
    Jan 2001
    Location
    Matthews, NC
    Posts
    279
    Thanks
    6
    Thanked 1 Time in 1 Post
    Kim,

    Thanks. I will try modifying the references to see what happens.

    -Rich

  8. #7
    3 Star Lounger rcbjr2's Avatar
    Join Date
    Jan 2001
    Location
    Matthews, NC
    Posts
    279
    Thanks
    6
    Thanked 1 Time in 1 Post
    Kim,

    BTW, I tried your suggestion, but it didn't work for me. Not sure why. Probably operator error. ;-)

    In any event, I think I'm just going to recreate my office QAT settings by hand at home.

    Thx.

  9. #8
    5 Star Lounger kmurdock's Avatar
    Join Date
    Feb 2003
    Location
    Pacific Grove, California, USA
    Posts
    716
    Thanks
    10
    Thanked 34 Times in 28 Posts
    I'm sorry the instructions didn't work. I just tried turning my .qat file into a .officeUI file to make sure I hadn't lead you astray.

    I opened the Word.qat file in Notepad, then also opened my current Word.officeUI file in another Notepad window.

    I copied the schema references from the current file over the references in the Word.qat. Saved. Then renamed the file to Word.officeUI and opened Word -- it displayed the revised qat file.

    One thing that's absolutely necessary when you're working with these xml files, is to get capitalization correct (although it doesn't seem to matter in these schema reference lines) and make sure you don't disturb any of the other coding. This can be a challenge since when you first open the file it's one or two big long lines of code. Even after you turn on word wrap, the bits are all strung together.

    On the other hand, creating your QAT from scratch is a fine solution, too.

    Best, Kim

  10. The Following User Says Thank You to kmurdock For This Useful Post:

    rcbjr2 (2012-02-18)

  11. #9
    3 Star Lounger rcbjr2's Avatar
    Join Date
    Jan 2001
    Location
    Matthews, NC
    Posts
    279
    Thanks
    6
    Thanked 1 Time in 1 Post
    Hmm, maybe I didn't completely understand your first set of instructions, so I might try again by opening both files and replacing the schema. I didn't quite catch the nuance of that I had to move the schema from the one to the other. Thanks for the additional instructions!

    -Rich

  12. #10
    3 Star Lounger rcbjr2's Avatar
    Join Date
    Jan 2001
    Location
    Matthews, NC
    Posts
    279
    Thanks
    6
    Thanked 1 Time in 1 Post
    Well, if all else fails, read the directions! ;-) This worked great! Thanks a lot. Now I don't have to spend an hour recreating the QAT by hand.

    -Rich.

  13. #11
    3 Star Lounger rcbjr2's Avatar
    Join Date
    Jan 2001
    Location
    Matthews, NC
    Posts
    279
    Thanks
    6
    Thanked 1 Time in 1 Post
    On caveat, though, and this might be related to the reply about different locations: my links to macros on the QAT and separators did not come across. However, 90% of what I had on the bar worked, so I'm happy. I just have to add a few separators and a few macro links and I'm ready to go.

    Thx.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •