Results 1 to 7 of 7
  1. #1
    New Lounger
    Join Date
    Apr 2011
    Posts
    8
    Thanks
    1
    Thanked 1 Time in 1 Post

    Wake on Lan not working (Solved)

    Several years ago, I built an HTPC using a Gigabyte GA-MA78GM-US2H motherboard with Windows 7 Ultimate 64. Later, I wanted to upgrade the network access to gigabit, so I replaced the mb's nic with an Intel PRO/1000 GT PCI adapter. The HTPC uses Windows Media Center for recording and viewing off the air TV, saving the recordings on a hard drive. Occasionally, I like to access the recordings on the HTPC using Media Center (also Win7 Ultimate 64) on a different PC in another room. This worked fine as long as the HTPC was up and running, but since it was sometimes asleep when I'm trying to use the other PC, I set up Wake on Lan to wake up the HTPC from the other PC, specifically using the magic packet method. This worked well with the PRO/1000 GT adapter, but I recently replaced it with an Intel EXPI9301CTBLK PCI Express card, which gave me a significant increase in speed versus the PRO/1000 GT. However, the Wake on Lan will no longer work, and, believe me, I've tried every possible combination of Intel configuration option, BIOS setting, Windows 7 power management setting, etc. I believe the bottom line is the Intel EXPI9301CTBLK is powering down whenever the HTPC is put to sleep, while the older PCI card wasn't. But I don't know how to get the PCI Express card to stay on. There is a bios setting for PME which is supposed to allow the computer to wake from the PCI and PCI Express bus, but this has been on from day one. Not sure what else to try, except upgrading the mb bios, but the newer bios version descriptions don't say anything about wol/PCI Express/power options. All responses appreciated - thanks in advance for any help.
    Last edited by jt01; 2012-02-28 at 20:31. Reason: Solved problem

  2. #2
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    Milwaukee, WI
    Posts
    737
    Thanks
    23
    Thanked 64 Times in 52 Posts
    My first inclination would be to download the latest driver from the manufacturer. Its strictly software driven and since its not integrated into the board the BIOS would not help you on this one.

    Next, and it sounds like you may have already tried the following, but here goes:
    1) In the NIC properties, go the Configure Button, then Power Managment. Make sure the option to "Allow the computer to turn off this device..." is unchecked.
    2) Check the boxes to "Allow this device to wake the computer" and "Allow only a magic packet to wake this computer".
    Chuck

  3. The Following User Says Thank You to Doc Brown For This Useful Post:

    jt01 (2012-02-28)

  4. #3
    New Lounger
    Join Date
    Apr 2011
    Posts
    8
    Thanks
    1
    Thanked 1 Time in 1 Post
    i have the Intel driver dated 10/13/2011 - version 11.14.48.0. Will check Intel's website for a newer one. The Power Management tab has 4 different options for Wake on Lan methods- all are checked. Each option has an explanation and there are also general explanations - one of the general explanations says "This port does not support Power Saver Options". I think this would relate to the power options you mention above. Regardless - no cigar.

  5. #4
    New Lounger
    Join Date
    Apr 2011
    Posts
    8
    Thanks
    1
    Thanked 1 Time in 1 Post
    Downloaded and installed the latest Intel software for this card - it was dated 1/20/12, but did not change the driver version or the Oct. 2011 date. Further investigation of the option explanations leads me to believe that turning on the Wake on Lan options in the driver configuration will keep the power going to the card. I tried waking it up from another machine to no effect, but one option explanation did give me an idea. As mentioned in the previous post, "This port does not support Power Saver options" - this may be referring to the motherboard slot the card is currently in. I could try putting it in another PCIE slot, although another slot could be perilously close to the video card. Will try moving the nic this weekend if a solution is not found, could also try the bios update if all else fails. Also have some more info that may be meaningful - the network cable to the HTPC is hooked to a nearby switch, meaning when the network card has power, the switch port will light up. It does not when the HTPC is asleep, indicating that power is not going to the nic. Other PC's on which I have successfully implemented WOL will light up when off or asleep, but I don't know what to do with this one to get the light to stay on. Thanks again for the help - hope you have other ideas.

  6. #5
    New Lounger
    Join Date
    Apr 2011
    Posts
    8
    Thanks
    1
    Thanked 1 Time in 1 Post
    Greetings all,

    I am pleased to report I have discovered the solution to this problem. First I installed the latest BIOS - no cigar. Then I tried moving the network card to a different slot. I had the network card in a PCIEx1 slot, which didn't seem to allow it to stay powered up when the computer was asleep. Changing it into a PCIEx16 slot caused it to stay on when the computer is asleep, and, therefore, the magic packet started working. My comment above about being too close to a video card did not prove to be a problem, considering there isn't any video card in the computer (using onboard), so I am now good to go. Thanks once again to Doc Brown for the help - I'm very glad to get this going after several months of effort.

  7. #6
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    Milwaukee, WI
    Posts
    737
    Thanks
    23
    Thanked 64 Times in 52 Posts
    You're welcome! Glad you found the solution, and thanks for reporting back what you found. I hadn't even thought of that.

    And welcome to the lounge!
    Chuck

  8. #7
    New Lounger
    Join Date
    Apr 2011
    Posts
    8
    Thanks
    1
    Thanked 1 Time in 1 Post
    Thank you for the welcome, but my euphoria at finding the above solution was premature. I recently bought a new UPS and the combination of the UPS software and USB connection to the UPS apparently convinced the PC it was running on battery power. Now even unplugging the USB connection and uninstalling the software will not restore power to the Intel card when the computer is asleep. I've tried moving it back and forth between the PCIEx16 and PCIEx1 slots, and toggling every power setting I can think of, but the card will not stay powered and, consequently, will not wake up the computer. No good deed goes unpunished - if you have any further ideas I'd like to hear them. Thanks again.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •