My brothers started home schooling this year using Buckeye Online School for Success (BOSS) which uses the AMVONET system. For some reason when on this website (boss.amvonet.com) Windows computers will randomly shutdown and lock themselves (that user only). This has affected their school given laptops (Win 7), and our two desktops (Win 7 and XP). It seems to primarily affect the Win 7 computers (my mom says she had to fix it twice in 10 minutes). It's also affected both Firefox and IE. My current solution for this is a password reset key on the Win 7 machine and Offline NT Registry Editor (which was mentioned in a Windows Secrets Newsletter a while back). Originally I just had the Editor but opted to make a password reset key on the Win 7 machine. Using the Registry Editor I've found that just clearing the password won't work but clearing and unlocking does (not sure if I could just unlock it or not, haven't tried that). The Password reset disk works as it should. I've done virus scans before but haven't found anything, I'm currently running another one since I used password reset instead of the Registry Editor but I don't expect it to make a difference. We only have this problem when accessing this particular site but for the kid's to do school they have to use the site so we're kind of screwed until they fix it or at least till the end of the year (we've also had a lot of other technical problems with them so we're planning to switch to Adela which we've heard is a lot better from most people).

Any idea's or similar experiences?

I'm personally thinking it's a bug that's triggering some sort of anti-hacking defense.

Oh, and all the computers have different security programs, their school (provided laptops) use MSE, the XP machine has Comodo and Malwarebyte's free (I just do regular scans with it), and the Win 7 desktop has Online Armor and Avira AntiVir.

Also we've moved houses and subsequently internet providers throughout this process, though we weren't using our desktops for their schooling before their laptops suffered these symptoms on both our old COX internet and our new Time Warner Internet.