Results 1 to 11 of 11
  1. #1
    Bronze Lounger
    Join Date
    Jan 2010
    Location
    Birkirkara, Malta
    Posts
    1,467
    Thanks
    205
    Thanked 15 Times in 14 Posts

    Keyboard Problem

    Since I changed my OS from the 32 to 64 bit version of Win 7 Pro I have a problem with my Trust keyboard. I now have difficulty with the placing of quotation marks. When I click the shift and quote marks key before the opening of the quoted words the quote marks do not appear until after I type the next character. When I try to insert the closing quotes they often do not appear in the right place. Also, if I type, for example the letter a in brackets it automatically changes to an emoticon.

    I tried changing the keyboard from US-International to United Kingdom, but it made no difference.

    Help would be greatly appreciated.

    Thanks and regards,
    Roy

  2. #2
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,580
    Thanks
    5
    Thanked 1,057 Times in 926 Posts
    Is there a 64-bit driver available for the keyboard?

    Joe

  3. #3
    Super Moderator
    Join Date
    Jun 2011
    Location
    New England
    Posts
    4,748
    Thanks
    171
    Thanked 649 Times in 572 Posts
    In what program? I can't imagine that (a) changes to an emoticon in Notepad, does it?

    Bruce

  4. #4
    Bronze Lounger
    Join Date
    Jan 2010
    Location
    Birkirkara, Malta
    Posts
    1,467
    Thanks
    205
    Thanked 15 Times in 14 Posts
    Thanks for the replies.

    Joe, as far as I could tell from the Trust website they don't have one. Do you have a link to any other website where I might find a suitable 64 bit driver?

    Bruce, (a) changed to an emoticon when I typed it in an email message using WLM 2011, which never happened when I had the 32 bit version of Win 7 Pro. Any idea as to how I can stop this happening?

    Further advice would be appreciated.

    Thanks and regards, Roy

  5. #5
    Super Moderator
    Join Date
    Jun 2011
    Location
    New England
    Posts
    4,748
    Thanks
    171
    Thanked 649 Times in 572 Posts
    Quote Originally Posted by royw View Post
    Bruce, (a) changed to an emoticon when I typed it in an email message using WLM 2011, which never happened when I had the 32 bit version of Win 7 Pro. Any idea as to how I can stop this happening?
    Top left drop-down menu in WLM 2011, then Options, Compose tab, under Emoticons heading; uncheck "Convert special key strokes to emoticons".

    Bruce

  6. The Following User Says Thank You to BruceR For This Useful Post:

    royw (2012-02-24)

  7. #6
    Bronze Lounger
    Join Date
    Jan 2010
    Location
    Birkirkara, Malta
    Posts
    1,467
    Thanks
    205
    Thanked 15 Times in 14 Posts
    Thanks a lot Bruce. That solved the emoticon problem, but I still have the quotation marks problem. Do you, or does anyone else, have any cure for that?

    Please advise.

    Thanks and regards, Roy

  8. #7
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,580
    Thanks
    5
    Thanked 1,057 Times in 926 Posts
    If Trust does not supply a driver then Windows will use a basic keyboard driver. That may not work well if the keyboard has an special cpabilities. What is your keyboard model number?

    Joe

  9. #8
    Super Moderator
    Join Date
    Jun 2011
    Location
    New England
    Posts
    4,748
    Thanks
    171
    Thanked 649 Times in 572 Posts
    Quote Originally Posted by royw View Post
    Thanks a lot Bruce. That solved the emoticon problem, but I still have the quotation marks problem. Do you, or does anyone else, have any cure for that?

    Please advise.

    Thanks and regards, Roy
    Does the quotation marks oddity happen in all programs or just some particular word processing program? Do quote marks do something strange in Notepad too?

    Bruce

  10. #9
    Bronze Lounger
    Join Date
    Jan 2010
    Location
    Birkirkara, Malta
    Posts
    1,467
    Thanks
    205
    Thanked 15 Times in 14 Posts
    Joe, Trust told me that the keyboard should work properly with the Windows driver.(It did before I changed from 32 to 64 bit). The keyboard is a Trust KB-1400 Slimline Keyboard, item no 14230. It doesn't nave any special functions.

    Bruce, it happens in Notepad.I haven't tried other programs yet.

    Please advise further.

    Thanks and regards, Roy

  11. #10
    Plutonium Lounger Medico's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    12,631
    Thanks
    161
    Thanked 936 Times in 856 Posts
    Roy, This is an old keyboard and is no longer available according to Trust.com. It was first produced during Win 98. I guess my best suggestion would be to look at a new keyboard, sorry.
    BACKUP...BACKUP...BACKUP
    Have a Great Day! Ted


    Sony Vaio Laptop, 2.53 GHz Duo Core Intel CPU, 8 GB RAM, 320 GB HD
    Win 8 Pro (64 Bit), IE 10 (64 Bit)


    Complete PC Specs: By Speccy

  12. #11
    Bronze Lounger
    Join Date
    Jan 2010
    Location
    Birkirkara, Malta
    Posts
    1,467
    Thanks
    205
    Thanked 15 Times in 14 Posts
    The keyboard options in Control Panel weren't set up correctly. I changed them to the following:

    Region and Language, Format is English (United States), default input language is English (United States)-US, and under Installed Services, below English (United States), under Keyboard, US is shown and nothing else.

    That solved the problem. Persistence pays!

    Regards, Roy

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •