Results 1 to 11 of 11
  1. #1
    New Lounger
    Join Date
    Jul 2011
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Cannot remove indent in Heading2

    I have a Word 2007 template that I have been using for several months. A couple of days ago I noticed the Heading2 in a couple of the docs was indented. It should be flush right. I changed the the para style, saved the file, reopened it, and the indent was back. I reattached the template file, applied the correct heading, saved the file, reopened the file and the indent was back. I modified the para style, choose the option for all docs created from this template, saved and reopened again and the indent was back. Somewhere in there, I also created a new file from the template and copied the text into it. Same story. I can make the para look right until I close and reopen it. The Heading1 and Heading3 are correct.

    Can someone please give me a hint on how to correct this?

    Thanks in advance
    Sally

  2. #2
    WS Lounge VIP
    Join Date
    Mar 2006
    Location
    Maryland, USA
    Posts
    690
    Thanks
    17
    Thanked 66 Times in 56 Posts
    Can you post a sanitized version of the doicument with the problem?

  3. #3
    New Lounger
    Join Date
    Jul 2011
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Here's a sample.

    Heading2.docx

  4. #4
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    9,434
    Thanks
    372
    Thanked 1,457 Times in 1,326 Posts
    Sally,

    The paragraph format for Heading 2 has a .25 left indent. When this is removed the level 2 headings revert to the left margin. I've saved and reopened the document and they remain on the left margin.
    LeftIndentHdr2.JPG
    Note: I'm working in 2010 but should be the same in 2007.
    May the Forces of good computing be with you!

    RG

    PowerShell & VBA Rule!

    My Systems: Desktop Specs
    Laptop Specs

  5. #5
    WS Lounge VIP
    Join Date
    Mar 2006
    Location
    Maryland, USA
    Posts
    690
    Thanks
    17
    Thanked 66 Times in 56 Posts
    After fixing the indent in the Heading 2 paragraph style, this is its description in the modify style dialog:

    Heading 2 indent fixed in ppg style
    Font: (Default) HelveticaNeueLT Std, Bold, Indent:
    Left: 0"
    Hanging: 0.3", Space
    Before: 12 pt
    After: 3 pt, Keep with next, Level 2
    Tab stops: 0.5", Left + 0.55", List tab, Outline numbered + Level: 2 + Numbering Style: 1, 2, 3, … + Start at: 1 + Alignment: Left + Aligned at: 0.25" + Tab after: 0.55" + Indent at: 0.55", Style: Linked, Quick Style
    Based on: Normal
    Following style: Normal

    Note that the indents for the paragraph style and for the numbering level disagree. Whichever one was applied last will determine the indent. When the paragraph style is applied, the indent is 0; when the numbering is reapplied, for example, when the number is restarted, the indent is 0.25. Your description of the problem doesn't quite jibe with what I describe, but the settings should be fixed and fixing them may end the problem.

    So, either make these settings agree or set indents and tabs (on the left side of the ppg) in the numbering only. To fix the numbering: Place the cursor in the first heading 1 in your document. Click the Multilevel list icon and then Define new multilevel list. Set the number alignment, aligned at, and text indent for all levels.

    If you still have problems, please post back.

    Pam

  6. #6
    New Lounger
    Join Date
    Jul 2011
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    That didn't help, Pam. I defined the new multilevel list. All the Heading2 paras moved to the left as I want but, again, when I save, close, and reopen the .25indent is back.

    Sally

  7. #7
    WS Lounge VIP
    Join Date
    Mar 2006
    Location
    Maryland, USA
    Posts
    690
    Thanks
    17
    Thanked 66 Times in 56 Posts
    The other issue is that there are unlinked style in the document, which you need to delete. Press Ctrl+F and click Format > Style to see and note the style names ending in Char. I only saw 5. Three of them are your heading styles. Close the Find replace dialog. Press Alt+F11 to open the macro immediate window. Copy the following macro command and paste it into the immediate window.

    ActiveDocument.Styles("PutStyleNameHere").Delete

    In the command, type the char style name between the quotes (replacing what's there) and press enter. The heading styles will throw an error message that says essentially that it can't delete a heading style--nevertheless it does delete the char style. If you have typed the styles names correctly, all should be removed from the Find dialog styles list.

    Before you close and save, check that the settings in the modify pararaph dialog for heading 2 to be sure that the paragraph and number level settings are the same.

    Pam

  8. #8
    Super Moderator
    Join Date
    Jan 2001
    Location
    Melbourne, Victoria, Australia
    Posts
    3,852
    Thanks
    4
    Thanked 259 Times in 239 Posts
    The reason that the style changes when you close and reopen the file is that the attached template is set to refresh the styles when the document is opened.

    To resolve that problem, either:
    1. Turn off the setting in Developer>Document Template>Automatically Update Document Styles
    or
    2. Modify the style in the template so it imports the preferred settings.
    Andrew Lockton, Chrysalis Design, Melbourne Australia

  9. #9
    New Lounger
    Join Date
    Jul 2011
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Pam, I'll give that a shot and post back the results. Do you know how those 'char' styles got there? Andrew, I've have tried to make these corrections to the template.

  10. #10
    New Lounger
    Join Date
    Jul 2011
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Woohoo! I think that did it, but I used both suggestions. After running the macro, I saved the file as a new template. Closed and reopened it with no problem then saved it as a document file. Again closing and opening worked, of course. Now, my thought is to save this new file over the previous template, which should correct the template file. Right? However, I still need to do this macro on each file that was messed up, right? I opened another of the files and the list of Char styles is different from the list I just corrected.

    I'm really curious as to what caused these styles.

  11. #11
    WS Lounge VIP
    Join Date
    Mar 2006
    Location
    Maryland, USA
    Posts
    690
    Thanks
    17
    Thanked 66 Times in 56 Posts
    Good catch, Andrew. I forgot to look there.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •