Results 1 to 4 of 4
  1. #1
    New Lounger
    Join Date
    Nov 2001
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Auto-formatting of Hyperlinks (Word 2000)

    Word 2000
    I am currently editing the normal.dot to use as our standard company template. I have encountered a problem with the Hyperlink style. In the standard normal.dot the Hyperlink style is Arial, in my normal.dot I want the Hyperlink style to be Century Gothic.
    When I create a new document and change some text to the Hyperlink style it is Century Gothic which is fine. However if I type in something that Word thinks is a link (e.g. www.about.com) it auto-formats it to the Hyperlink style, this is fine except it is Arial! It is not using my normal.dot.
    I think this is a bug in Word 2000 but does anyone now where it is getting this alternative Hyperlink style from and how I can stop it doing this and force it to use my Hyperlink style?
    Does Word have a back-up normal.dot somewhere?
    What would cause me to have two normal.dots in the 'Look In' combo box on Tools > Options > Auto Correct > Auto Text?
    Thanks
    Helen

  2. #2
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Auto-formatting of Hyperlinks (Word 2000)

    Hi Helen:

    As an observation, it would be better to create a corporate template, complete with your styles etc.,

    When you type www.something.com, Word autoformats it as a hyperlink. Hyperlink (a character style) is defined by Word to be based on the font of the underlying paragraph style.

    1. Did you change the Hyperlink style to define a particular font or just apply direct formatting? You can check this by going to Format/Style & choosing the hyperlink style.

    2. Are you sure the attached template is normal.dot? You can check this in Tools/Templates & Add-ins & seeing the attached template.

    3. Finally, I assume you mean Tools/Autocorrect.../AutoText (no options). If so, & 2 normal.dots show up there, this could be causing a problem. Do this: click the taskbar & press F3. Search for normal.dot & tell us how many you have & where they are stored.

  3. #3
    New Lounger
    Join Date
    Nov 2001
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Auto-formatting of Hyperlinks (Word 2000)

    Hi Phil

    Thanks for that.

    My Hyperlink style is Default Paragraph Font + Font: Century Gothic, 10pt, underline, Font: Colour blue.

    My default paragrah style is Times New Roman, 10.

    When I type in a link and it is auto formatted it is Arial 12!!!! Also when I do this and put my cursor in the hyperlink and look at the style is says 'Hyperlink'.

    However when I highlight a word or normal text and select style 'Hyperlink' it is Centruy Gothic.

    I searched for normal.dot and I only have one and it is definately the one I created. I chopped a load of styles out of it so there are only about 8 left. The funny thing is that when I go to Format > Style there is a combo box on the left labelled 'list' if I select 'all styles' it shows all the styles usually in a standard normal.dot. How can it do that - I deleted most of them? Word must store default styles somewhere else.

    I have attached my normal.dot if that helps - although it is actually a normal.doc because Woody's won't let me attach a .dot file.

    Thanks a million
    Attached Files Attached Files

  4. #4
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Auto-formatting of Hyperlinks (Word 2000)

    Hi Helen:

    I've examined your normal.doc/dot. Both changing text to hyperlink style (by selecting it & then changing it) or when Word formats a link automatically result in the SAME character style for the link. You can see this by typing in a link (even a phoney one) like www.phoney.com. After you do this & press the spacebar, press the left arrow key a couple of times...you'll see that the style box say's it's formatted as Century Gothic 10 point, not Arial.

    Try this also. Turn on "show paragraph mark" on the standard toolbar. Type www.phoney.com & press <enter>. On the next line, type www.phoney.com; then hold the shift key down & press Home to select the text. Go to the style box & apply the hyperlink style.

    If you examine closely, you'll see that the font is identical. However, the second line that you manually formatted with the hyperlink character style has a <font color=blue>blue</font color=blue> paragraph mark.

    When I opened your normal.doc, it opened with Body Text. Although it defined it having Century Gothic, 10 point, my style box read Arial. If that is happening on yours, then when you apply the hyperlink character style to text, it applies it to the paragraph mark also, so it reads Century Gothic. When Word formats the style automatically, it doesn't apply the style to the paragraph mark.

    I notice that in looking under Tools/Options/Compatibility/Font Substitutions, I see that Arial is substituted for Century Gothic. I do not have Century Gothic on my machine & the document doesn't have the font embedded. I don't know what you actually have. Regardless of what the style box says, you should check to make sure that you have the font installed.

    Hope this helps.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •