Results 1 to 7 of 7
  1. #1
    2 Star Lounger
    Join Date
    Mar 2001
    Location
    Br. Columbia, Canada
    Posts
    109
    Thanks
    1
    Thanked 0 Times in 0 Posts

    how to find physical location of USB ports?

    On it's return from 'hospital' I re-attached all my 'stuff' to one of many usb ports on my Win7 Pro pc.

    I now find myself with a problem with a couple of programs. Both located in C:\Program Files (x86). Before hospitalization, any files I created were saved to my external drive on USB-HDD (I: ).
    Now I'm finding that the location is USB-HDD (E: ) and my programs are unable to access the data.

    Is there any way to find the physical location of usb ports on this Win 7 pro pc?

    Any suggestions/comments will be much appreciated.

  2. #2
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    Slough, Berkshire UK
    Posts
    924
    Thanks
    55
    Thanked 52 Times in 50 Posts
    you could go to "Control Panel>administrative tools >computer management>disk management" and change the drive letter (E: ) back to (I: )

    Windows does have a habit of assigning different drive letters if connected to different ports.
    Last edited by curiousclive; 2012-03-04 at 17:58.
    Clive

    All typing errors are my own work and subject to patents pending. Except errors by the spell checker. And that has its own patients.

  3. #3
    2 Star Lounger
    Join Date
    Mar 2001
    Location
    Br. Columbia, Canada
    Posts
    109
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Thanx. I have no idea where to find disk manager, can you advise. I have looked at Device manager but the listing there does not tell me the named/number A-Z of them. I think I need to find the physical location of I: somehow.

  4. #4
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    Slough, Berkshire UK
    Posts
    924
    Thanks
    55
    Thanked 52 Times in 50 Posts
    Quote Originally Posted by bbcirly View Post
    Thanx. I have no idea where to find disk manager, can you advise. I have looked at Device manager but the listing there does not tell me the named/number A-Z of them. I think I need to find the physical location of I: somehow.
    "Control Panel>administrative tools >computer management>storage>disk management". Right click the "E:" drive and choose "change drive letters and paths". Select the letter I: from the drop down list.

    There will be no I: as windows has renamed it E:. Until you change it back yourself.

    It isn't the ports that are assigned drive letters it is the drive itself.

    Or you could change your programs to look for the E: drive instead
    Last edited by curiousclive; 2012-03-04 at 18:10.
    Clive

    All typing errors are my own work and subject to patents pending. Except errors by the spell checker. And that has its own patients.

  5. #5
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    Slough, Berkshire UK
    Posts
    924
    Thanks
    55
    Thanked 52 Times in 50 Posts
    @bbcirly

    Did you manage to resolve your problem?
    Last edited by curiousclive; 2012-03-05 at 10:24.
    Clive

    All typing errors are my own work and subject to patents pending. Except errors by the spell checker. And that has its own patients.

  6. #6
    2 Star Lounger
    Join Date
    Mar 2001
    Location
    Br. Columbia, Canada
    Posts
    109
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Thanx Clive for the directions to Disk management. I admit to being very hopeful until I got to the drop down list. There was NO I:!
    I think I am now resigned to opening all the files on the USB-HDD to save as... A particularly onerous task. So NO this is not solved.
    Appreciate your assistance here very much.
    Thanx again.

  7. #7
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    Slough, Berkshire UK
    Posts
    924
    Thanks
    55
    Thanked 52 Times in 50 Posts
    Quote Originally Posted by bbcirly View Post
    Thanx Clive for the directions to Disk management. I admit to being very hopeful until I got to the drop down list. There was NO I:!
    I think I am now resigned to opening all the files on the USB-HDD to save as... A particularly onerous task. So NO this is not solved.
    Appreciate your assistance here very much.
    Thanx again.
    As I said there will be no I: drive listed If there is then something else has been allocated the letter (maybe a card reader or memory stick which isn't plugged in but the comp will reserve the letter for it. You could plug in any memory sticks you have used before and see if any of them have the letter I: as the drive letter.) and should show in disk management and can be changed to a different letter then change the E: drive to I:.) but there should be an E: drive which is the drive you want. you need to assign the new drive letter to this drive by selecting via right click on the drive labelled E; and choosing "change drive letters and paths" once the box opens use the drop down list to choose I: to reassign the drive letter I: to that drive. If there is no I; as a choice it means something else (maybe a card reader has been given that number look further down in disk management to see if anything else is list with that letter)
    Failing that you can change the settings in the appropriate programs to use the E: drive instead of the I: drive)
    Hope that is clear if not post again and I will try to help further.
    Last edited by curiousclive; 2012-03-06 at 16:48.
    Clive

    All typing errors are my own work and subject to patents pending. Except errors by the spell checker. And that has its own patients.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •