Results 1 to 6 of 6
  1. #1
    New Lounger
    Join Date
    Mar 2012
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts

    MS Word 2003 - New Pasting Problem

    A few weeks ago I noticed a problem pasting content which has been copied from webpages into MS Word 2003 when using my main desktop PC running Win XP Pro SP3. Previous to then, copying and pasting webpages or parts of webpages into MS Word always preserved the source formatting -- now all I get is plain text.

    Not having another full featured word processing program, I haven't tried to paste web content to another target. However I have tried copying rich web content from two separate browsers (Firefox and IE) to an MS Word document , and I still get the same result either way-- plain text. Since I was uncertain about how to differentiate between a malfunctioning Windows clipboard vs. MS Word itself, I decided to test two laptops I own and see how they function when trying this same operation. Both did the EXACT same thing -- rich web content pastes as just plain text. I had never previously tried copying/pasting webpages via these laptops, so for all I know they have always worked this way, but this pasting resulting in plain text is absolutely new for the main desktop PC. Maybe some recent MS update has done this? Maybe I accidentally bumped some setting someplace? Can someone help?!

  2. #2
    Super Moderator
    Join Date
    Jun 2002
    Location
    Mt Macedon, Victoria, Australia
    Posts
    3,993
    Thanks
    1
    Thanked 45 Times in 44 Posts
    I don't have access to 2003 at the moment, but in 2007 (and 2010) there is an option that controls this:

    PasteDefault.gif
    Regards
    John



  3. #3
    New Lounger
    Join Date
    Mar 2012
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    This paste options dialog ought to get the laptops working the way I want. I just found the screen -- it's under Options, Advanced. Thanks for this tip!

    I just checked Word 2003 and didn't find a similar options screen. I'll look further, but it may not exist.

    Further explanation..... Previously I used regular Copy and Paste to copy webpage content. Recently I instead tried Paste Special and noticed that it only offered two options, both forms of straight text. I believe that it used to also offer a third option, HTML. A friend who uses Word 2003 tells me that he sees the Paste Special HTML option, while I do not. Maybe this is part of my problem with copying webpage formatting? If so, I have no idea how to fix it (nor how it happened in the first place).

    A possible second aspect of the above is that when I use Paste Special, the little paste options icon does NOT appear onscreen. My friend reports that it should.

    To sum up, I can successfully copy and paste individual photos, so I am not limited just to text. However I cannot copy rich content such as anything with multiple fonts, bold text, etc. The HTML aspect may or may not be part of the same problem. And last, whatever is going on, as far as I know it began a few weeks ago.

  4. #4
    New Lounger
    Join Date
    Mar 2012
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I figured out the problem. I decided to try starting Firefox 11 in Safe Mode and, lo and behold, cutting and pasting instantly returned to working as it should with webpages. Then after disabling the many Firefox extensions one by one, the cause turned out to be Skype and their "Skype Click to call" plugin. The cut/paste problem definitely follows this single plugin -- with it disabled, cut/paste ALWAYS works no matter what; with it enabled, cut/paste always fails, no matter what.

    Good. And since the Skype installer modifies both Firefox as well as IE, presumably this explains why cutting from both browsers gave the same bad results when pasting in MS Word. There have been previous instances where this plug-in has had compatibility troubles, but what the thing has to do copying and pasting is beyond me. Strange! Regardless, since I am using the latest version of the Skype add-on, now I must wait until Skype fixes whatever is going on.

    Thanks for the help attempts!

  5. #5
    New Lounger
    Join Date
    Apr 2012
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Hi,

    I had the same problem. When I tried copy-paste a table from IE or other browser into Word, the formatting was lost!
    I tried different approaches to fix this: I played with settings, re-installed Word and Outlook, and finaly I found this helpfull information.
    Sure enough when I removed the plugin (Skype Click to Call) from Add/Remove Programs, copy-paste from Web started working perfect again.

    Thank you very, very much J-D-H : )

    Vale4ka

  6. #6
    New Lounger
    Join Date
    Mar 2012
    Posts
    5
    Thanks
    0
    Thanked 0 Times in 0 Posts
    You are every welcome!

    For quite awhile there seemed to be no fix for this copy/paste problem -- it sure gave me quite a headache. Given this most recent problem as well as previous examples of bad software design by Skype on their Click-to-call plugin, I suspect I may never want to have it installed again. The benefits are frequently just not worth the hassles, IMHO anyway.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •