Results 1 to 11 of 11
  1. #1
    ril
    Guest

    Cursor problems in Word

    I am working on a fairly large document (100 pages or so) in Word 2000, and I just added an image consisting of a bunch (about 10) of AutoShapes. They are grouped together and anchored to the last line of a paragraph.

    Since I did this, my cursor disappears whenever I type more text into the document (and reappears when I'm done typing).

    It's like the extra burden of dealing with the drawing layer is causing a great deal of extra processing to go on with each keystroke, preventing the cursor from getting properly updated.

    I'm running a 350mhz processor, with 64mb of RAM, so although it's not a powerhouse, I have plenty of speed. No other apps are running at the same time.

    Have others seen this behavior? Any solutions?

    Am I better off moving the autoshapes into a Drawing object that has an implied frame (thus allowing them to be 'inline' with the text instead of on a separate layer)?

  2. #2
    Super Moderator
    Join Date
    Dec 2000
    Location
    New York, NY
    Posts
    2,970
    Thanks
    3
    Thanked 29 Times in 27 Posts

    Re: Cursor problems in Word

    Will it work better if you do your typing in Normal view?

  3. #3
    ril
    Guest

    Re: Cursor problems in Word

    I can check, but I really don't like working in Normal view.

  4. #4
    Platinum Lounger
    Join Date
    Dec 2000
    Location
    Queanbeyan, New South Wales, Australia
    Posts
    3,730
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Cursor problems in Word

    Maybe you could try keeping Print Layout view but under Tools, Options, View, select "Picture Placeholders"
    Subway Belconnen- home of the Signboard to make you smile. Get (almost) daily updates- follow SubwayBelconnen on Twitter.

  5. #5
    ril
    Guest

    Re: Cursor problems in Word

    Hmmm... I can try that too... but I really need to be able to see the images.

    I have a hunch of what may be happening. And this is just a hunch. As soon as I add any AutoShapes to the document, Word 2000 has to create and manage an image layer for the entire document. Without any AutoShapes, there is no image layer to deal with. It's the added work of maintaining that image layer that is causing the cursor to not appear quickly as it should.

    Well, that's just a hunch... not based on anything except years of experience with MS software.

    Feel free to tell me it's a good guess or complete hogwash.[img]/w3timages/icons/oink.gif[/img]

  6. #6
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Cursor problems in Word

    Hi ril:
    I'd say it's a good guess, especially if Gary & Geoff's suggestions work. It could also be a graphics driver problem. At work, on our network, things get so slow that I can type several words before they even appear. Is it any better if you reboot & then do nothing but open this document?

    Something you might try. Copy a few pages at a time into a new document--it won't take that long. And leave out the last paragraph mark (don't copy it). Does that make any difference?

  7. #7
    Plutonium Lounger Leif's Avatar
    Join Date
    Dec 2000
    Location
    U.K.
    Posts
    14,010
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Cursor problems in Word

    I can remember for long ago seeing an option somewhere that enabled turning off the cursor when you typed - presumably to keep the screen clearer.
    Can't see it anywhere in my options - it may have been an old mouse set-up issue. (I may also have been using an add-on called Flywheel at the time.)
    Do you have anything in your mouse settings that may be applicable?

  8. #8
    ril
    Guest

    Re: Cursor problems in Word

    That's funny you mention that, Leif. I remember that option too, and I was searching for it recently. But no, it's not enabled (ran Wordpad to check). Also, I think it was just for the pointer, not the cursor. By 'pointer' I mean the thing that moves when you move the mouse. By 'cursor' I mean the flashing vertical bar that moves as you type text.

    Maybe that feature was something from an older version of Windows that we both remember :-)

  9. #9
    ril
    Guest

    Re: Cursor problems in Word

    Thanks, Phil.

    I tried the reboot approach, but no different.

    It could always be a graphics driver problem, but it only manifests after I insert AutoShapes, so my guess is it's more of a Word problem.

    I'm not on any networks, so that's not it either.

    I can try the copy page method, or just deleting the image and it's paragraph marker to see if that helps.

    But I really want to be able to include images (autoshapes, etc.) in my larger documents.

    I could just get used to the 'cursor lag', but so far I haven't!

    I'll also try making it as part of an inline image, and see how that goes.

  10. #10
    Uranium Lounger
    Join Date
    Dec 2000
    Location
    Los Angeles Area, California, USA
    Posts
    7,453
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Re: Cursor problems in Word

    Hi Robert:

    If you want to email the document (or a portion of it) to me, I'll take a look. You can make a copy & type some gibberish if the document contains sensitive material. You can zip it or not, it's up to you--I have DSL.

  11. #11
    ril
    Guest

    Re: Cursor problems in Word

    Thanks for the offer... actually, you can probably repoduce it real quick by:

    1) Writing a couple short paragraphs, and then copy and paste them to fill up a hundred pages.
    2) After the last paragraph, add a few autoshapes... throw in a 3D rectangle, a 3D star, and a few 2D arrows.
    3) Group the autoshapes together
    4) Anchor the autoshapes to the last line of the last paragraph
    5) Format the autoshape group to have text appear above and below it ('top and bottom', as I believe Word 2000 calls it on the advanced Formatting Options dialog)
    6) Try typing in (not cut and paste) a paragraph after the autoshape group

    That's it... at that point I get the cursor problem I descibed earlier.

    If you try it, let us know what type of machine you have (O/S, CPU speed, and RAM amount), as that could make a difference.

    Thanks for all your help!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •