Page 1 of 2 12 LastLast
Results 1 to 15 of 22
  1. #1
    2 Star Lounger amflores's Avatar
    Join Date
    Dec 2009
    Location
    Rio de Janeiro, Brazil
    Posts
    147
    Thanks
    14
    Thanked 0 Times in 0 Posts

    When I use my external drive, the system takes too long to shut down

    Why my system(Win7 32bits Home Premium) takes sooooo long to shutdown when my Seagate external drive (500 Gb - half full) is hooked to my laptop?

    Is it because indexing is on, which includes the external drive? I don't think so.

    Any help is welcome.

    Regards,
    Flores
    Both me and my Windows edition speak brazilian portuguese.

  2. Subscribe to our Windows Secrets Newsletter - It's Free!

    Get our unique weekly Newsletter with tips and techniques, how to's and critical updates on Windows 7, Windows 8, Windows XP, Firefox, Internet Explorer, Google, etc. Join our 480,000 subscribers!

    Excel 2013: The Missing Manual

    + Get this BONUS — free!

    Get the most of Excel! Learn about new features, basics of creating a new spreadsheet and using the infamous Ribbon in the first chapter of Excel 2013: The Missing Manual - Subscribe and download Chapter 1 for free!

  3. #2
    Super Moderator BATcher's Avatar
    Join Date
    Feb 2008
    Location
    A cultural area in SW England
    Posts
    2,821
    Thanks
    19
    Thanked 108 Times in 102 Posts
    Have you tried disconnecting the external drive using the "Safely Remove Hardware and Eject Media" icon at the bottom right of the taskbar before trying to shut down?
    BATcher

    If it wasn't for the weather, Great Britain would be a silent nation.

  4. #3
    2 Star Lounger amflores's Avatar
    Join Date
    Dec 2009
    Location
    Rio de Janeiro, Brazil
    Posts
    147
    Thanks
    14
    Thanked 0 Times in 0 Posts
    .......Have you tried disconnecting the external drive using the "Safely Remove Hardware and Eject Media" icon at the bottom right of the taskbar before trying to shut down?
    Hello BATcher,

    Sure, but I am not allowed to disconnect the ED because a msg tells me that it is being used at the moment.
    Is there a way to know which program(s) is(are) using the drive?
    Could it be the indexing service?

    Thanks for your help.

    Flores
    Both me and my Windows edition speak brazilian portuguese.

  5. #4
    3 Star Lounger
    Join Date
    Apr 2010
    Posts
    225
    Thanks
    6
    Thanked 8 Times in 8 Posts
    You can turn off indexing for the drive or any other drives or folders in your system by going to Control panel/Performance information and then to Indexing options on the left. My guess is that it is not this, but you could shut it off for the drive and see.

    My other suggestion is to go to Services and see if any services are enabled for any programs that might reside on the external HD. You can get to services from Contoal panel/Admin tools or type services.msc into the run box. If you find any there, try disabling them one at a time to see if this makes a difference.

    Otherwise my suggestion would have been the same as BATchers.

  6. #5
    2 Star Lounger amflores's Avatar
    Join Date
    Dec 2009
    Location
    Rio de Janeiro, Brazil
    Posts
    147
    Thanks
    14
    Thanked 0 Times in 0 Posts
    Hello Idb,

    I will start by switching off indexing only for the external drive, where I only store data, and no programs, and see what happens.
    Will let you know the results.

    Thanks for your help.

    Flores
    Both me and my Windows edition speak brazilian portuguese.

  7. #6
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    Slough, Berkshire UK
    Posts
    916
    Thanks
    51
    Thanked 52 Times in 50 Posts
    You could try going into the bios and see if there is a way to set the external drive as hot swappable. (Not all bios have this option so may not help). But if it has then you will be able to eject the drive from taskbar easily or even disconnect it.
    You could also try my computer and right clicking the external drive and choose properties, find the hard drive in the hardware tab list and select properties again, click the policies tab and check only the top box is ticked as it may be flushing its data when closing down unnecessarily. It is also possible to untick the top box also but then have a small risk of losing data if you remove drive when still reading/writing to it.
    Clive

    All typing errors are my own work and subject to patents pending. Except errors by the spell checker. And that has its own patients.

  8. #7
    2 Star Lounger
    Join Date
    Mar 2012
    Location
    NY state
    Posts
    144
    Thanks
    9
    Thanked 13 Times in 12 Posts
    You can also try logging off then back on. I have to do that with one of my WD externals to be able to disconnect it without full shutdown. I think the problem is with GoodSync. AV and auto backup software can be a problem too.
    Joe

  9. #8
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    Slough, Berkshire UK
    Posts
    916
    Thanks
    51
    Thanked 52 Times in 50 Posts
    Quote Originally Posted by amflores View Post
    Hello Idb,

    I will start by switching off indexing only for the external drive, where I only store data, and no programs, and see what happens.
    Will let you know the results.

    Thanks for your help.

    Flores
    Do you have automatic data / file backups running in background? If so it will wait till completed the backups everytime you shut down.
    Last edited by curiousclive; 2012-03-29 at 10:02.
    Clive

    All typing errors are my own work and subject to patents pending. Except errors by the spell checker. And that has its own patients.

  10. #9
    2 Star Lounger amflores's Avatar
    Join Date
    Dec 2009
    Location
    Rio de Janeiro, Brazil
    Posts
    147
    Thanks
    14
    Thanked 0 Times in 0 Posts
    .....You could try going into the bios and see if there is a way ..... You could also try my computer and right clicking the external drive .......It is also possible to untick
    Hello Clive,

    Unfortunately, my BIOS has no such capability.
    I tried both options in the policies tab (the top option was already ticked) but still I can't disconnect the external drive using the "Safely Remove Hardware and Eject Media" because "it is being used at the moment".

    Thanks for your help.

    Flores
    Both me and my Windows edition speak brazilian portuguese.

  11. #10
    2 Star Lounger amflores's Avatar
    Join Date
    Dec 2009
    Location
    Rio de Janeiro, Brazil
    Posts
    147
    Thanks
    14
    Thanked 0 Times in 0 Posts
    ........You can turn off indexing for the drive .......My other suggestion is to go to Services and see if any services are enabled for any programs that might reside on the external HD.
    Hello Idb,

    Indexing was disabled for the external drive which I use only to store data. I have no programs running from it.
    Switchin off the drive using the "Safely Remove Hardware and Eject Media" is not possible because "it is being used at the moment".

    Regards,
    Flores
    Both me and my Windows edition speak brazilian portuguese.

  12. #11
    2 Star Lounger amflores's Avatar
    Join Date
    Dec 2009
    Location
    Rio de Janeiro, Brazil
    Posts
    147
    Thanks
    14
    Thanked 0 Times in 0 Posts
    =......You can also try logging off then back on........ I think the problem is with GoodSync. AV and auto backup software can be a problem too.
    Hello Joe,

    I will try disabling the AV and see if it works.

    Thanks,
    Flores
    Both me and my Windows edition speak brazilian portuguese.

  13. #12
    2 Star Lounger
    Join Date
    Jun 2010
    Location
    sydney
    Posts
    135
    Thanks
    14
    Thanked 13 Times in 11 Posts
    Quote Originally Posted by amflores View Post
    Why my system(Win7 32bits Home Premium) takes sooooo long to shutdown when my Seagate external drive (500 Gb - half full) is hooked to my laptop?

    Is it because indexing is on, which includes the external drive? I don't think so.

    Any help is welcome.

    Regards,
    Flores
    Its almost certain to be an application that has a file open & locked - not the indexing service, thats an old chestnut that a squirrel forgot to bury
    The drive's gone to sleep but the app is still holding the lock.
    Windows wants the lock to be released.
    But for some reason Windows takes a long time to wake up a drive when this happens during a shutdown.

    Try opening some folders and a file on the drive
    If you have to wait a while then you know the drives gone to sleep - it shouldn't be a verrry looong wait
    Then do the shutdown

    Try to get into the habit of closing down application programs before you do a shutdown, including the ones in the 'notification area'.
    Probably not AV's and Firewalls, but especially things like continious backup apps as mentioned above, and gadgets like Locate32 & Listary

    You could maybe write a script that forces the drive to 'wake up', and get it to execute at shutdown ==>> http://www.trishtech.com/win7/run_a_..._windows_7.php

    NW2's

  14. #13
    2 Star Lounger
    Join Date
    Jun 2010
    Location
    sydney
    Posts
    135
    Thanks
    14
    Thanked 13 Times in 11 Posts

  15. #14
    2 Star Lounger amflores's Avatar
    Join Date
    Dec 2009
    Location
    Rio de Janeiro, Brazil
    Posts
    147
    Thanks
    14
    Thanked 0 Times in 0 Posts
    Hi NW2's,

    Sorry for not replying to your msgs sooner, but I was away from home during the wkend.
    I will try this app and will let you know.
    OK?

    Thanks,
    Flores
    Both me and my Windows edition speak brazilian portuguese.

  16. #15
    Lounger bcoop's Avatar
    Join Date
    Jan 2011
    Posts
    26
    Thanks
    8
    Thanked 0 Times in 0 Posts
    Fixing my slow entry into my computer I came across a Windows tool for just this annoyance
    go to start -> help and support
    type in "slow start"
    a list comes up that links to various option. I used #7 which told me what was slowing me down. It worked well, and I could stop going through my task manager and walk the dog. Hope it works for you too.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •