Results 1 to 8 of 8
  1. #1
    2 Star Lounger
    Join Date
    Mar 2002
    Location
    Waltham, MA, USA
    Posts
    159
    Thanks
    0
    Thanked 1 Time in 1 Post

    How to manage hyperlinks in Contents, cross-references, citations?

    I'm working in Word 2010. In my document, hyperlinks to external locations (Web pages) display with hyperlink coloring. Hyperlinks to locations inside the same file -- listings in the table of contents automatically generated from headers; citations of items in the bibliography; cross-references to captions -- do not appear with the distinctive coloring that would identify them as clickable links, either in the document in docx format or if I save it as a PDF. That makes the hyperlinking rather useless. How can I make the colors appear? Thanks.

  2. Get our unique weekly Newsletter with tips and techniques, how to's and critical updates on Windows 7, Windows 8, Windows XP, Firefox, Internet Explorer, Google, etc. Join our 480,000 subscribers!

    Excel 2013: The Missing Manual

    + Get this BONUS — free!

    Get the most of Excel! Learn about new features, basics of creating a new spreadsheet and using the infamous Ribbon in the first chapter of Excel 2013: The Missing Manual - Subscribe and download Chapter 1 for free!

  3. #2
    2 Star Lounger
    Join Date
    Mar 2002
    Location
    Waltham, MA, USA
    Posts
    159
    Thanks
    0
    Thanked 1 Time in 1 Post
    And now I have a couple of cross-references to items in the bibliography which turned up as Error, reference not found, while other such cross- references are still active. "Reference" does not appear in the list of types of items available for cross-referencing. What is this?

  4. #3
    2 Star Lounger
    Join Date
    Mar 2002
    Location
    Waltham, MA, USA
    Posts
    159
    Thanks
    0
    Thanked 1 Time in 1 Post
    After closing and re-opening the file, the citations that threw errors now work, but still hyperlinked cross-references dont' show in color, and citations to the bibliography don't hyperlink at all. I don't see a checkbox for "insert as hyperlink" when I go to insert a citation.

  5. #4
    2 Star Lounger
    Join Date
    Mar 2002
    Location
    Waltham, MA, USA
    Posts
    159
    Thanks
    0
    Thanked 1 Time in 1 Post
    Additional observations: I created the bibliography from the list of sources applet in Word. There are two kinds of items which might be linked. One is the "retrieved from" item when the source is on the Internet. Web addresses are linked automatically in the body of a document, but not in the list of references. The other is the title of a book or the like, which is not inherently a hyperlink but which could be linked to an author's Web site, a retailer or the like. In any of the hidden hyperlinks, I could manually change the font color and ad an underline, but that won't enable the change to "followed hyperlink" color after clicking onthe lin. Any thoughts about this? If I select a different style for the references, might that resolve the problem? Or do I have to save the file as PDF and insert hyperlinks manually, or something like that? If I save as a Web page, the table of contents appears in hyperlink colors but the cross references do not. What a pain!
    Last edited by jsallen; 2012-04-28 at 08:36.

  6. #5
    Super Moderator
    Join Date
    Jan 2001
    Location
    Melbourne, Victoria, Australia
    Posts
    3,524
    Thanks
    3
    Thanked 144 Times in 137 Posts
    The look of a hyperlink is normally governed by a character style called 'Hyperlink'. It is sometimes applied automatically to text when a hyperlink is created. It is not normally applied automatically to cross refs but there is no reason why it can't be added manually.
    Andrew Lockton, Chrysalis Design, Melbourne Australia

  7. #6
    2 Star Lounger
    Join Date
    Mar 2002
    Location
    Waltham, MA, USA
    Posts
    159
    Thanks
    0
    Thanked 1 Time in 1 Post
    Thanks. I found the style "hyperlink" in the Manage Styles dialog box. The "Import/export" dialog that is accessible from a button in that dialog box indicates that "hyperlink" is in the style set for my document *but* it does not appear in the drop-down pane showing styles which I can insert into the document. So, how do I get it there so I can apply it to the non hyperlink-formatted hyperlinks?
    Last edited by jsallen; 2012-04-30 at 21:34.

  8. #7
    Super Moderator
    Join Date
    Jan 2001
    Location
    Melbourne, Victoria, Australia
    Posts
    3,524
    Thanks
    3
    Thanked 144 Times in 137 Posts
    There is a very large number of styles in every Word document but many are hidden by default. To set your style to show:

    Open the Styles Pane (Ctrl-Alt-Shift-S)
    Click on the Manage Styles button at the bottom of this Pane. This button has a pencil sitting over two capital As.
    Go to the Recommend Tab of the Manage Styles dialog
    Set the Sort Order to 'Alphabetical' and select the style in the list
    Click the Show button and then click OK
    Andrew Lockton, Chrysalis Design, Melbourne Australia

  9. #8
    2 Star Lounger
    Join Date
    Mar 2002
    Location
    Waltham, MA, USA
    Posts
    159
    Thanks
    0
    Thanked 1 Time in 1 Post
    Well, I tried what Andrew suggested but it still doesn't quite solve the problem. Word handles coloring differently in hyperlinks which it generates using internal functions (no coloring, and attempting to apply the hyperlink style to them doesn't work) and hyperlinks generated by the user (the style is applied automatically). Management of hyperlinks is inconsistent when I save the file in other formats. When I save to filtered or unfiltered html, presto, they all appear in color. (Filtered html is preferable in most cases for browser compatibility and because it makes smaller files -- in my case, a file with many photos, 4 MB instead of 18 MB total). When I save as PDF using Acrobat 9 (not with the Acrobat bar in Word 10 -- that isn't available with Acrobat 9), the formatting is essentially as in the Word document but the "back" button in my browser dumps me out of the PDF file instead of returning me to the location of an internal link. I'm not sure whether that is a peculiarity of Word, of Acrobat 9, of of the combination. I am saving in html for Web display despite the loss of page formatting, so readers will have full use of their browsers' navigation tools.

    So, I have solved my problem after a fashion, after stumbling over a few obstacles. Additional advice, suggestions and potential solutions are welcome.
    Last edited by jsallen; 2012-05-02 at 06:59.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •