Results 1 to 7 of 7
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Location
    London, UK
    Posts
    9
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Microsoft Installer problems

    I have tried to install several items of software (eg. drivers/ Seagate GoFlex External HD) but keep getting an error message that Microsoft Installer was not properly installed. I can't find any real help for this. I am running Vista Business SP2 (32-bit)

  2. #2
    Super Moderator jwitalka's Avatar
    Join Date
    Dec 2009
    Location
    Minnesota
    Posts
    6,794
    Thanks
    117
    Thanked 799 Times in 720 Posts

  3. The Following User Says Thank You to jwitalka For This Useful Post:

    CLee (2012-04-28)

  4. #3
    Gold Lounger
    Join Date
    Oct 2007
    Location
    Johnson City, Tennessee, USA
    Posts
    3,202
    Thanks
    37
    Thanked 215 Times in 202 Posts
    Quote Originally Posted by CLee View Post
    I have tried to install several items of software (eg. drivers/ Seagate GoFlex External HD) but keep getting an error message that Microsoft Installer was not properly installed.
    CLee,
    Hello.. A few questions ...
    1. When you get that message do you also get the "Re Install useing correct settings"?

    2. After you get the message does the "Drive" show up in Disk Manager or Windows Explorer?

    3. Which "GoFlex" do you have?

    4. Do you have "Plug and Play" enabled? (In BIOS)

    Regards Fred
    PlainFred

    None are so hopelessly enslaved as those who falsely believe they are free (J. W. Von Goethe)

  5. #4
    New Lounger
    Join Date
    Dec 2009
    Location
    London, UK
    Posts
    9
    Thanks
    1
    Thanked 0 Times in 0 Posts
    In fact, I tried this but it still didn't help; neither did the Command Prompt ' HKLM\SOFTWARE\Microsoft\SQMClient\Windows\Disabled Sessions /va /f ', even though it said 'operation completed successfully' each of the 5 times I tried it.
    I failed even to
    download the Microsoft Fixit Center.
    Some updates I can download (eg. CCleaner - though I suspect it doesn't use MSI) but I failed with eg. Evernote and Java updates, as well as the WAN driver I mentioned earlier.
    I haven't tried the Seagate External HD recently, though I failed many times some time ago.

  6. #5
    Administrator
    Join Date
    Jun 2010
    Location
    Portugal
    Posts
    12,519
    Thanks
    152
    Thanked 1,398 Times in 1,221 Posts
    Are you running the latest version of the installer? http://www.microsoft.com/en-us/downl...s.aspx?id=8483

  7. #6
    New Lounger
    Join Date
    Dec 2009
    Location
    London, UK
    Posts
    9
    Thanks
    1
    Thanked 0 Times in 0 Posts
    I downloaded the version ' Windows6.0-KB942288-v2-x86.msu ' from this site - I am running Vista Business SP2 (32-bit) - but was told that 'the update does not apply to your system' by the Windows Update Standalone Installer. None of the other versions seemed appropriate. I seem to remember having the same problem before.

  8. #7
    Administrator
    Join Date
    Jun 2010
    Location
    Portugal
    Posts
    12,519
    Thanks
    152
    Thanked 1,398 Times in 1,221 Posts
    I thought that might be the case, but decided to check, anyway.

    Have you tried running sfc / scannow?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •