Results 1 to 6 of 6
  1. #1
    5 Star Lounger
    Join Date
    Dec 2000
    Location
    Calgary, Alberta, Canada
    Posts
    818
    Thanks
    6
    Thanked 1 Time in 1 Post

    Question Word 2010 - Spell Checking, not checking?? - puzzle.

    I need some help to try and solve this problem. I was typing a memo this afternoon and noticed that the Spell Checker was not working. It didn't pick up spelling mistakes, even ones that I deliberately made to test it out. I went into my Word Bible and the Help function to see if I could discover what the problem might be. As far as I could tell, all the appropriate boxes were checked and all the relevant functionality was invoked and I could not figure out why this was not working. Soooo...I am hoping someone here will have some insight into other things I should check to see if I can figure out why this is not working. Any thoughts, ideas or insight that anyone would care to share will be greatly appreciated. Thanks.

    Ron M

  2. #2
    Star Lounger
    Join Date
    Feb 2011
    Location
    Washington, DC
    Posts
    98
    Thanks
    8
    Thanked 6 Times in 6 Posts
    Have you checked to make sure the language for your text is not set to ignore spell check?

    Select all your text, and use the Set Language option (I don't know where it is in 2010, but it is one of the buttons on the right hand side of the Proofing tab in 2007). Clear the Do not check spelling or grammar checkbox and click OK.

    - Jessica

  3. #3
    Silver Lounger Charles Kenyon's Avatar
    Join Date
    Jan 2001
    Location
    Sun Prairie, Wisconsin, Wisconsin, USA
    Posts
    2,048
    Thanks
    124
    Thanked 119 Times in 116 Posts
    For more on the spell checker, see Mastering the Spelling Checker. Jessica's guess is my guess, too. I guess for diagnosing the problem I would just check one word that you know is misspelled that is not being flagged. If that is the problem, though, then you have to go through the extra step to select everything and reset it to check spelling.
    Charles Kyle Kenyon
    Madison, Wisconsin

  4. #4
    5 Star Lounger kmurdock's Avatar
    Join Date
    Feb 2003
    Location
    Pacific Grove, California, USA
    Posts
    716
    Thanks
    10
    Thanked 34 Times in 28 Posts
    You can also tell a style to not check spelling. Open the modify style dialog, click the format button, then Language...

    If somehow the Normal style was set to not check spelling, then any styles based on Normal would also inherit it.

    Not the most likely scenario, but certainly one of the sneakiest to diagnose...

    Best, Kim

  5. #5
    5 Star Lounger
    Join Date
    Dec 2000
    Location
    Calgary, Alberta, Canada
    Posts
    818
    Thanks
    6
    Thanked 1 Time in 1 Post
    Jessica, Charles and Kim, thank you for your replies. I have checked a lot of the areas that you have suggested and everything seems to be as it should be. One thing I did do and that was remove the Normal format from the Quick Style List and that seemed to work - go figure? - so I hope I haven't changed something else as yet unknown.

    Ron M

  6. #6
    Silver Lounger Charles Kenyon's Avatar
    Join Date
    Jan 2001
    Location
    Sun Prairie, Wisconsin, Wisconsin, USA
    Posts
    2,048
    Thanks
    124
    Thanked 119 Times in 116 Posts
    I'm glad you've got it working. I can think of no reason why removing normal (or any other) style from the Quick Style list would change the spell checking.

    If this pops up again, a key method of checking the spelling language settings is to select a word that you know is misspelled but which is not flagged. Check the proofing language settings with that word selected.
    (edit)


    Try clicking on a misspelled word and pressing Shift+F1. You should see something like this:

    2010RevealFormattingLanguage.png

    Under Font formatting does it say : Language: Do not check spelling or grammar?

    The screenshot above is from a computer with only one language installed, with spelling and grammar installed and active. This is a character(font)-level formatting in Word.
    Last edited by Charles Kenyon; 2016-03-20 at 13:12. Reason: Add information about Reveal Formatting Pane
    Charles Kyle Kenyon
    Madison, Wisconsin

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •