Results 1 to 2 of 2
  1. #1
    New Lounger
    Join Date
    Nov 2002
    Location
    Christchurch, New Zealand
    Posts
    14
    Thanks
    2
    Thanked 0 Times in 0 Posts

    Canon Scangear missing from TWAIN list in Irfanview + Paint.net but not MS

    Hi Loungers

    Iíve been tearing my hair out on this one!

    Baseline stuff. Win7 64 bit, fully patched, running on a Tosh Satellite A500. Iíve got a couple of Canon Scanners, one a Lide 600F and the other in a multi function printer - though this is probably a read herring. Iíve been using Irfanview, and Paint.net and MS Office Imaging as TWAIN Ďcontrollersí.

    Canon make (IMHO) a really great scanner / TWAIN interface, called ďScangearĒ (see https://www.google.com/search?q=Scan...HqWWiQfOkLDUCA) that is way better than the WIA http://en.wikipedia.org/wiki/Windows_Image_Acquisition interface. I (nearly) canít live without Scangear.

    When a scanner is installed, there are often TWO versions listed in the TWAIN source list - the native version, and the WIA version.

    My problem is that Irfanview + Paint.net (mostly) cannot see the native version of my scanners, only the WIA version which means I canít get at my beloved Scangear scanner interface only the paltry WIA on. The infuriating bit is that sometimes, Irfanview and Paint.net CAN see the native TWAIN source meaning I can then access Scangear.

    The odd thing is that MS Office Imaging is always able to see the native (non-WIA) version of the scanner.

    Iíve done all the usual stuff, uninstalled and installed the scanner drivers and associated programs (Canon Toolbox). Iíve uninstalled and reinstalled Irfanview and also rolled it back the first 4.x version and then through to the current versions 4.33. Iíve looked for the exe for Scangear, but it don't exist, the Scangear program lives in some DLL kind of ghost in the c:windows/twain_32 folder (I think as I canít find its source as even Sysinternals process monitor says Scangearís process is the scanner program that called it, e.g., Irfanview or Paint.net etc.

    The problem with MS Doc imaging is that it wants to save everything in TIFFís and Iím after the flexibility of Irfanview and Paint.net to save files in other formats.

    Does anyone have any idea why MS Doc imaging always sees the non WIA version of my scanners and why Irfanview and paint.net only see it once in a blue moon (no its not the moon causing the problem ;-)

    Cheers

    Merf

  2. #2
    New Lounger
    Join Date
    Nov 2002
    Location
    Christchurch, New Zealand
    Posts
    14
    Thanks
    2
    Thanked 0 Times in 0 Posts
    After a few suggestions on the Irfanview forums…

    https://irfanview-forum.de/showthrea...not-MS-Imaging

    I think I have a (kind of) solution

    I tried disabling WIA, but that did nothing in IV but it stuffed up Paint.Net and the Office imaging system (no surprise with the latter as its MS prog talking to MS prog, and the former requires MS .NET so…)

    I then tried running Irfanview (IV) as an administrator, and, there was the non-WIA version of the scanner. However, getting Scangear to run has still been a mission…

    there has been a huge amount of HDD churn while IV was trying to load Scangear, and various other problems - I ended up killing various processes in task manager, completely uninstalling the scanner software, doing a registry clean (Ccleaner and JV16 power tools), rebooting, reinstalling yada yada yada. Things do at least now appear to of settled down.

    However, when I now run IV as a ‘normal’ user - only the WIA version of the scanner appears. When I run as admin, voila, both versions of the scanner are there.

    Funnily (not the ha-ha kind) Paint.Net still can’t see the non-WIA version even as an admin.

    And, there is the ugly old UAC prompt now every time I want to run IV.

    So it appears that deep in the windows TWAIN and WIA systems live a lot of bugs. Who would of guessed?

    Hope that helps someone else

    Cheers

    Merf

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •