Results 1 to 10 of 10
  1. #1
    3 Star Lounger
    Join Date
    Dec 2009
    Location
    FL
    Posts
    330
    Thanks
    27
    Thanked 11 Times in 10 Posts

    Question Insert-typeover function driving me nuts

    I don't know if this issue is due to something about my computer, or Windows 7 keyboard shortcuts, or MS Word.

    But as I type, and try to insert letters into a sentence, every so often the insert letters function stops working and instead the new letters begin typing over the old ones. This could happen every few minutes or every half hour .... I can't tie it to any particular key or key combination. I am so used to it now that I don't pay attention to whether it's happening when I type an email (Windows Live 2011) or just when typing a Word (2003) document.

    I am using a 4 month old HP Pavilion laptop, DV 7 series.

    It has the number keypad on the right and the number 0 key is also the Insert key which is a major pain in the butt. I didn't want a keypad but am stuck with it because I wanted the 17 inch screen. I want an Insert key that has no other function but Insert. However, that can't be helped at this point. Had I known how annoying the useless keypad with dual functions would be, I'd have gotten a smaller screen.

    Regardless, I don't think the dual function 0/Insert key has anything to do with this problem. (I just wanted to complain about it <g>).

    The "insert letters" turns itself off when I am nowhere near the 0 key.

    I don't know how to find out what the problem is or what the Windows keyboard shortcuts are - if I could get a list of them that might help me figure this out. In the 20 years that I've owned computers I have never seen anything like this happen - the "insert" key has always controlled whether or not letters could be inserted or you'd get a "typeover." If I saw letters typing over, pressing the "insert" key would make them stop doing that. It still does, but, I can't figure out what is causing it to switch over to "typeover" mode when I am not even near any number keys at all!

    My Word "options" are set to "insert" rather than to "allow typeovers" - I just checked it to be positive of that.

    I have *three* HP laptops sitting here, all in daily use, and this one that I am typing on, which I got in January, is the only one that does this obnoxious trick.

    Does anyone have any ideas?

  2. #2
    4 Star Lounger
    Join Date
    May 2012
    Posts
    404
    Thanks
    0
    Thanked 49 Times in 39 Posts
    Press the FN key to turn the function on and off.

    This page might help too: HP D7 series keyboard shortcuts
    Last edited by Xircal; 2012-05-25 at 13:45. Reason: added more info

  3. #3
    3 Star Lounger
    Join Date
    Dec 2009
    Location
    FL
    Posts
    330
    Thanks
    27
    Thanked 11 Times in 10 Posts
    Xircal-
    Thank you. I appreciate the link to the keyboard. I didn't find anything on it that should cause the problem I have. I know the FN key turns the Insert on and off, but, my problem is, the insert turns off unexpectedly while I am typing and when I am no where near the insert key.

  4. #4
    4 Star Lounger
    Join Date
    May 2012
    Posts
    404
    Thanks
    0
    Thanked 49 Times in 39 Posts
    Quote Originally Posted by kelliann1 View Post
    Xircal-
    Thank you. I appreciate the link to the keyboard. I didn't find anything on it that should cause the problem I have. I know the FN key turns the Insert on and off, but, my problem is, the insert turns off unexpectedly while I am typing and when I am no where near the insert key.
    In that particular case then, it's most likely due to a faulty keyboard then. Since the machine is only four months old, it should stilll be under warranty still, so I'd advise you to give HP's helpdesk a call and get them to replace it.

    Here's the link to that model with support options in the left hand menu: HP Pavilion DV7

  5. #5
    3 Star Lounger
    Join Date
    Dec 2009
    Location
    FL
    Posts
    330
    Thanks
    27
    Thanked 11 Times in 10 Posts
    Xircal - thank you for the link .... I'll see what HP has to say.

    Kelliann

  6. #6
    3 Star Lounger
    Join Date
    Dec 2009
    Location
    FL
    Posts
    330
    Thanks
    27
    Thanked 11 Times in 10 Posts
    I've been working a lot of hours so no chance to call HP but, I believe this problem is mostly or only (not sure) apparent when using Word 2003 so am wondering if this is a glitch between Word 2003 and Windows 7. Any thoughts on that, anyone?

  7. #7
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,580
    Thanks
    5
    Thanked 1,058 Times in 927 Posts
    In searching around on this issue I did see several threads related to Word 2003 mysteriously changing the insert behavior but no real solution.

    Joe

  8. #8
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    Slough, Berkshire UK
    Posts
    924
    Thanks
    55
    Thanked 52 Times in 50 Posts
    In word 2003 tools/options/edit tab/ see if 'click and type' is selected. This should allow you to click where you want to put a word and insert it without overwriting any other words.
    Also if you don't like the numpad you can turn it off and also set in bios to start with it turned off.
    Clive

    All typing errors are my own work and subject to patents pending. Except errors by the spell checker. And that has its own patients.

  9. #9
    3 Star Lounger
    Join Date
    Dec 2009
    Location
    FL
    Posts
    330
    Thanks
    27
    Thanked 11 Times in 10 Posts
    Curious Clive -
    Yes, Click and Type is enabled. I keep the Numbers Pad turned off, but the on/of key is awkwardly placed adjacent to the backspace key so I do hit it by mistake sometimes. HP has stupidly changed the function keys, too, so that when you hit an F1 or F3 or whatever, if you don't also have their Function key pressed the key will lighten or darken your screen or whatever. They made it the opposite of what it used to be, mistakenly assuming that nobody used the Fkeys anymore. I use them frequently. I really object to their messing with the keyboard the way they did.

    i will definitely go to the BIOS and turn off that numpad for when I reboot - thanks for that tip - I didn't know you could do that.

  10. #10
    3 Star Lounger
    Join Date
    Dec 2009
    Location
    FL
    Posts
    330
    Thanks
    27
    Thanked 11 Times in 10 Posts
    Joe, thank you for doing that search!!!! I just couldn't figure out what to search for that would turn up exactly what I was looking for. At least now I know it's Word 2003 doing this. And it did NOT do it with XP, either. So must be a Word 2003/Win7 glitch. When Word 2007 came out I bought it and tried it and did not like the "new" ribbon so went back to 2003. I write for a living and having a program that I can use without thinking about HOW to use it is essential.

    Quote Originally Posted by JoeP517 View Post
    In searching around on this issue I did see several threads related to Word 2003 mysteriously changing the insert behavior but no real solution.

    Joe

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •