Ran into this while I was fixing some driver and hardware related problems (was a *fun* weekend).

In Windows XP if you encounter a BSOD it automatically shuts the computer down, no warning, nothing.

If you don't like the fact that it does this you can do the following to prevent it:

Start | Control Panel | System | Advanced | Startup & Recovery | Settings

Uncheck System Failure | Automatically Restart

Apply the change.

Keep in mind if you do encounter a BSOD it will still force you shut down, the only difference is you will see the error and possibly have clue how to fix. (most often in XP if you have BSOD it will be driver related).