Page 1 of 2 12 LastLast
Results 1 to 15 of 23
  1. #1
    New Lounger
    Join Date
    May 2012
    Posts
    17
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Win 7 Slow to Reconnect to Wi-Fi Network after Awaking from Sleep Mode

    I thought that Sleep Mode was intended to allow users to get back to work quickly when the computer "awakes". It takes 53 seconds after awaking from sleep mode before my Win 7 Ultimate 64 bit high powered computer reconnects to my wireless home network. The wireless router is only 5 feet away and the signal srength is nearly 100%. The computer is set to automatically reconnect. This same slow behavior was shown by Vista on an earlier computer using this network. My android tablet on the same wireless network reconnects on awaking from sleep mode in about one second! Can anyone tell me why Win 7 is so slow to reconnect, and/or how to get around this problem?

  2. #2
    4 Star Lounger
    Join Date
    May 2012
    Posts
    404
    Thanks
    0
    Thanked 49 Times in 39 Posts
    Do you have a Homegroup configured in the Network & Sharing center? If so, remove the connection to it. You should see an immediate improvement.

  3. #3
    New Lounger
    Join Date
    May 2012
    Posts
    17
    Thanks
    1
    Thanked 0 Times in 0 Posts
    The same 50+ seconds is required to reconnect the computer to the wireless network without a home group as was the case with a home group.

    -axkramer

  4. #4
    4 Star Lounger
    Join Date
    May 2012
    Posts
    404
    Thanks
    0
    Thanked 49 Times in 39 Posts
    Sorry to hear that.

    Try doing a cold boot i.e. shutdown the system completely. If it's PC, remove the power cord from the back of the machine as well.

    Wait a full two minutes before you power on again. This will flush the system memory.

    Have you checked the manufacturer's site for a network driver update?

  5. #5
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,584
    Thanks
    5
    Thanked 1,059 Times in 928 Posts
    Do you have access to network devices in Windows 7? If those devices are not available it can take a long time for Windows to initialize a network as it is waiting for a timeout period to expire.

    Joe

  6. #6
    New Lounger
    Join Date
    May 2012
    Posts
    17
    Thanks
    1
    Thanked 0 Times in 0 Posts
    The computer is the only device on the network. I agree that the behavior suggests Windows is waiting for a timeout, but there is no apparent need to wait. This same behavior occurred with a previous computer and Vista, so it is not a recent thing. It is a "problem" that occurs only when returning from sleep mode. The network drivers are up-to-date except for any firmware in the wireless router itself. The router is a D-link product that works great and the tablet does not have any wait problem with the router.

    -Ax Kramer

  7. #7
    4 Star Lounger
    Join Date
    May 2012
    Posts
    404
    Thanks
    0
    Thanked 49 Times in 39 Posts
    Could you check the Performance logs in Event Viewer. There's a similar problem with illustrations to your own here: Windows 7 resumes from sleep slowly

  8. #8
    New Lounger
    Join Date
    May 2012
    Posts
    17
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Thanks to all for suggestions; unfortunately nothing has solved the problem yet. The computer recovers from sleep mode aqnd is ready to use in 5 or so seconds, after I enter the password. It is only the connection to the wireless router/network that is taking so much time.

    -Ax Kramer

  9. #9
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,584
    Thanks
    5
    Thanked 1,059 Times in 928 Posts
    Have you checked the power settings for your wireless connection?

    Joe

  10. #10
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    Slough, Berkshire UK
    Posts
    924
    Thanks
    55
    Thanked 52 Times in 50 Posts
    Joe's suggestion I suspect is closest. Check wireless adapter power setting are not set to allow computer to turn off device.
    Clive

    All typing errors are my own work and subject to patents pending. Except errors by the spell checker. And that has its own patients.

  11. #11
    4 Star Lounger
    Join Date
    May 2012
    Posts
    404
    Thanks
    0
    Thanked 49 Times in 39 Posts
    It looks like Microsoft is aware of the problem, but seems to be concentrating on Windows 8 to improve connection times rather fixing problems with it in the current version: Windows 8 to Have Greatly Improved Wi-Fi Connection Times

  12. #12
    4 Star Lounger
    Join Date
    May 2012
    Posts
    404
    Thanks
    0
    Thanked 49 Times in 39 Posts
    Quote Originally Posted by curiousclive View Post
    Joe's suggestion I suspect is closest. Check wireless adapter power setting are not set to allow computer to turn off device.
    Leaving power enabled to the NIC is likely to drain the battery.

  13. #13
    5 Star Lounger
    Join Date
    Dec 2009
    Location
    Slough, Berkshire UK
    Posts
    924
    Thanks
    55
    Thanked 52 Times in 50 Posts
    Quote Originally Posted by Xircal View Post
    Leaving power enabled to the NIC is likely to drain the battery.
    But may resolve his problem so has to make a choice.
    Clive

    All typing errors are my own work and subject to patents pending. Except errors by the spell checker. And that has its own patients.

  14. #14
    New Lounger
    Join Date
    May 2012
    Posts
    17
    Thanks
    1
    Thanked 0 Times in 0 Posts
    No batteries! My computer is a desktop HP Pavalion and is electrically "live" the entire time but in sleep mode. Other "portable" devices (tablet, etc.), reconnect to this network within a second or so when awakened from sleep mode. My computer also is ready to use within a second or so after awaking from sleep mode, other than for wireless network connection. My earlier statement of 5 seconds or so was off by about 4! Immediately clicking on the notification tray icon and then cliking connect on my network of those listed
    as soon as the computer returns from its nap does not speed up the reconnection at all.

    -axkramer

  15. #15
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    23,584
    Thanks
    5
    Thanked 1,059 Times in 928 Posts
    Have you checked the power settings for the NIC?

    Joe

  16. The Following User Says Thank You to JoeP517 For This Useful Post:

    axkramer (2012-06-01)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •