Results 1 to 4 of 4
  1. #1
    Lounger
    Join Date
    Dec 2009
    Location
    Vancouver, BC, Canada
    Posts
    37
    Thanks
    3
    Thanked 0 Times in 0 Posts

    Missing Firefox icons

    Maybe this belongs in the Firefox forum, but it feels like a Windows problem to me.

    This happened to me in Windows XP (Home) and now it's happening in Windows 7 (Home Premium).

    All Firefox-related icons are plain white paper icons instead of the Firefox logo.
    They used to be the Firefox logo, then one day they all changed.
    If I change associations to Chrome, it shows the Chrome logo. If I change to Internet Explorer, it shows the IE logo. But change back to Firefox and it's back to the plain white paper icon.

    I tried this Clear Icon Cache tool http://www.pretentiousname.com/miscs...ClearIconCache and I got the message that the icon cahce had been cleared, but the Firefox icons remained plain white paper.

    Previously, on Windows XP, this happened, and one day the Firefox icons actually returned and hung around for a couple weeks before disappearing again. I believe it was after updating Firefox.

    Of course I update Firefox whenever it tells me to ... something like every other week. So I don't understand why it doesn't fix whatever is broken. Which makes me think it's a Windows thing that's broken.

    Soooo ... any idea how to fix it?

    Thanks!

  2. #2
    4 Star Lounger
    Join Date
    May 2012
    Posts
    404
    Thanks
    0
    Thanked 49 Times in 39 Posts
    Are you talking about the desktop shortcut?

    If so, delete the existing one, then do the following:

    1. Open Windows Explorer and navigate to "C:\Program Files\Mozilla Firefox\firefox.exe"
    2. Right click firefox.exe and choose "Send To", then "Desktop (create shortcut)"

    That should result in a shortcut with the Firefox logo.

    If that fails to fix the problem, follow instructions on this site instead: http://www.waveofweb.com/windows/fix...-in-windows-7/

  3. #3
    Lounger
    Join Date
    Apr 2010
    Location
    Alabama
    Posts
    44
    Thanks
    1
    Thanked 2 Times in 2 Posts
    I had the same problem a while back. Click below to see how I solved it.

    http://windowssecrets.com/forums/sho...l=1#post786513

  4. The Following User Says Thank You to Steve1951 For This Useful Post:

    StickBoy (2012-06-30)

  5. #4
    Lounger
    Join Date
    Dec 2009
    Location
    Vancouver, BC, Canada
    Posts
    37
    Thanks
    3
    Thanked 0 Times in 0 Posts
    That did the trick! Thanks so much.
    Must bookmark this page so I know what to do next time it happens....

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •