Results 1 to 4 of 4
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Location
    CT, SA
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Facebook display changed to text in Firefox

    Hi

    I was asked to look at an XP SP3 patched system where the display of the Facebook page had changed to text in Firefox 3 6 17 with no menus visible to logout etc. Firewall is the windows default with Microsoft Security Essentials.

    I then logged onto my test rig similar to above but with Firefox 4 0 1 and logged into F/B using my own profile and the display was normal. Firewall is Comodo with Avast 6.

    Next up was the problem profile which displayed as text. Then my own profile, which had also now changed to text.

    After searching the net, I uninstalled Java, Flash and disabled "NoScript" on the test rig without success. Then tried IE8 on both profiles which worked perfectly on both systems.

    Uninstalled Firefox 4 0 1 and reinstalled 3 6 17 on the test rig without any success.

    Next up was to create a new windows user account and both IE8 and Firefox display Facebook correctly.

    Firefox addons are: Adblock plus, Betterprivacy, NoScript, FlashBlock, Ghostery.

    Then created a new Firefox profile and this does work.

    Although I now have a work-around solution, I would still like to know what's up in XP or Firefox and how to fix?

    Thanks.

  2. Subscribe to our Windows Secrets Newsletter - It's Free!

    Get our unique weekly Newsletter with tips and techniques, how to's and critical updates on Windows 7, Windows 8, Windows XP, Firefox, Internet Explorer, Google, etc. Join our 480,000 subscribers!

    Excel 2013: The Missing Manual

    + Get this BONUS — free!

    Get the most of Excel! Learn about new features, basics of creating a new spreadsheet and using the infamous Ribbon in the first chapter of Excel 2013: The Missing Manual - Subscribe and download Chapter 1 for free!

  3. #2
    Super Moderator jscher2000's Avatar
    Join Date
    Feb 2001
    Location
    Silicon Valley, USA
    Posts
    23,112
    Thanks
    5
    Thanked 93 Times in 89 Posts
    For NoScript, check for new domains. Facebook uses facebook.com, fbcdn.com, facebook.net and perhaps others for various content.

    Firefox is sensitive to character encoding differences between the main page and the linked in pages (e.g., CSS, JS). It may fail to load those pages in some cases if the encoding doesn't match. If you see that something works one day, fails the next, and works the third, it could be something like that. In particular, FB may have made a change that is inconsistent with cached files. A new profile has no cache. If you haven't already emptied the cache on the other profiles, give that a try. It also may be useful to delete the cookies associated with the various FB domains.

  4. #3
    New Lounger
    Join Date
    Dec 2009
    Location
    CT, SA
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks for that.

    I have little knowledge of F/B as I only look to see photos my son posts from abroad and have not done any further experimentation today.

    I did do all you have advised re: clearing cache / cookies / history before posting.

    My suspicion now points to javascript and I still have to check the PC where this originally happened.

    It's a low priority, but interesting.

    Thanks.

  5. #4
    New Lounger
    Join Date
    Jul 2012
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    make sure time and date are correctly set

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •