Results 1 to 5 of 5
  1. #1
    New Lounger
    Join Date
    Jul 2012
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Hard disks appear in "safely remove hardware and eject media" on taskbar

    I built a computer using an Intel INTEL-DP35DP motherboard with a Core 2 Duo CPU and two hard disks. I did a new install of Windows 7 on the computer. Everything works fine except for one disturbing glitch.

    When I have a USB thumb drive attached and am done with it, I click on the Taskbar Icon to "safely remove hardware and eject media" and not only does the thumb drive appear, but so do the two installed hard disks. This happens every time I click that icon, even when no thumb drive is attached. The two hard drives also appear in Devices and Printers in the Control panel, as does the DVD drive, which is not normal.

    Can anyone help me fix this problem? I am afraid I will someday "remove" a hard disk by accident.

    Thank you,

    Don

  2. #2
    3 Star Lounger
    Join Date
    Dec 2009
    Location
    New Brunswick, Canada
    Posts
    290
    Thanks
    46
    Thanked 5 Times in 5 Posts
    You have to do something in the BIOS to make the hard drives not show in the safely remove dialog. These would be SATA hard Drives. I had to do this on my ASUS P8P67 MB. I think there was a hot swap setting that you could disable. your BIOS may be different.

    There may also be a Registry tweak to remove them. do a google search on "remove sata drives from safely remove hardware notification'.
    Last edited by High Sierra; 2012-07-27 at 10:08.
    George

  3. #3
    Super Moderator CLiNT's Avatar
    Join Date
    Dec 2009
    Location
    California & Arizona
    Posts
    6,121
    Thanks
    160
    Thanked 609 Times in 557 Posts
    One other simple thing to take a look at too...
    Untitled.jpg
    In Device Manager, take a closer look at the disks in question and ensure they are checked off
    for "Better Performance", as opposed to quick removal.

    "Better performance" should be a default setting, but...

  4. #4
    Lounger
    Join Date
    Feb 2010
    Location
    Florida, Usa
    Posts
    26
    Thanks
    0
    Thanked 4 Times in 1 Post
    Quote Originally Posted by CLiNT View Post
    One other simple thing to take a look at too...
    Untitled.jpg
    In Device Manager, take a closer look at the disks in question and ensure they are checked off
    for "Better Performance", as opposed to quick removal.

    "Better performance" should be a default setting, but...
    Wouldn't that be doing the opposite of what the OP was wanting. He doesn't want the disks to show in the "safely remove hardware"
    Last edited by aloarjr810; 2012-07-27 at 17:16.

  5. #5
    New Lounger
    Join Date
    Jul 2012
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Problem Solved

    I took High Sierra's advice and googled "remove sata drives from safely remove hardware notification" and found the following instructions for a registry change which fixed the problem:

    http://www.overclock.net/t/974023/fi...emove-hardware

    Problem solved.

    Thanks for the help.

    Don

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •