Page 1 of 2 12 LastLast
Results 1 to 15 of 21
  • Thread Tools
  1. Star Lounger
    Join Date
    Jul 2012
    Posts
    58
    Thanks
    10
    Thanked 0 Times in 0 Posts

    Windows 8 wi-fi problem on university wireless network

    Hi,

    I'm hoping the Windows 8 experts here can help.

    I can connect at 10 different wi-fi hotspots in the city using Windows 8, but cannot connect to my uni wireless. I took it to 4 different techs here and they couldn't do it. And they've tried with other people's W8 systems without luck. The last guy was in a hurry, and he said he needs to find this:

    Network authentication method - peap - mschapv2

    Does this make sense? He said they had trouble with the latest Apple Lion system because this was missing because Apple thought no one used it and he hopes that MS don't delete it too. Does that make sense? The techs here had to write 13 lines of code to get it working in Lion.

    Cheers,
    Martin Gifford.

  2. Subscribe to our Windows Secrets Newsletter - It's Free!

    Get our unique weekly Newsletter with tips and techniques, how to's and critical updates on Windows 7, Windows 8, Windows XP, Firefox, Internet Explorer, Google, etc. Join our 480,000 subscribers!

    Excel 2013: The Missing Manual

    + Get this BONUS — free!

    Get the most of Excel! Learn about new features, basics of creating a new spreadsheet and using the infamous Ribbon in the first chapter of Excel 2013: The Missing Manual - Subscribe and download Chapter 1 for free!

  3. Plutonium Lounger Medico's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    12,625
    Thanks
    161
    Thanked 928 Times in 851 Posts
    Many university IT depts. do not allow connection to their network in certain instances. My wife works in the IT department at a medium sized university. Since Win 8 is still in beta, it is not allowed to connect to their servers. I am not sure how they prevent it, but they do. Their IT dept. must fully vette new S/W before it is allowed, including released S/W. This practice has tightened up even further over the last year. Martin, perhaps this is part of your problem.
    BACKUP...BACKUP...BACKUP
    Have a Great Day! Ted


    Sony Vaio Laptop, 2.53 GHz Duo Core Intel CPU, 8 GB RAM, 320 GB HD
    Win 8 Pro (64 Bit), IE 10 (64 Bit)


    Complete PC Specs: By Speccy

  4. Lounge VIP
    Join Date
    Apr 2011
    Location
    Scotland
    Posts
    1,168
    Thanks
    44
    Thanked 132 Times in 113 Posts
    Based on the comment from the last university tech guy, this problem appears to be a network authentication rather than a wireless connection issue.

    If it were the university policy not to allow connection to Windows 8, then the four university techs asked to assist would know this and would have stated as such.

    Much more likely is that the Windows 8 wireless network configuration on the machine is not configured to use the correct network authentication required by the university servers (as opposed to wireless keys/passwords between client and wireless modem) : the tech guy saying he had to find peap mschapv2 tells it's own story - he knows exactly what he is looking for, but he can't find the client configuration in Windows 8.

    Martin, point the university techs to this Technet article. My Windows 8 Release Preview installations do not use wireless network connections to an Active Directory installation {perhaps that's something I should explore?}, so I can't confirm if there are sufficient similarities in the Win7 config and Win8 config to be useful, but it should give them a toe hold to find what they are looking for.
    In God we trust; all others must bring data.

    - William Edwards Deming. 1900 - 1993

  5. Lounger
    Join Date
    Jun 2012
    Posts
    48
    Thanks
    3
    Thanked 3 Times in 3 Posts
    HI Martin,

    Quote Originally Posted by Martin Gifford View Post
    said he needs to find this: ... ... Network authentication method - peap - mschapv2

    Does this make sense?
    Certainly not an expert in Windows 8, but for what it's worth, I think Tinto Tech's response is spot on the money here.

    Your Uni has wisely chosen to use a strong WiFi authentication method and Windows 8 isn't providing the required credentials to establish a connection, or hasn't been correctly configured to do so. This could be a bug in the operating system due to it still being in its infancy, or a lack of knowledge on how to correctly configure Windows 8 by the Tech's who are helping you.

    Tinto's link is a good one I'd be browsing through.. you may also like to look here;

    http://technet.microsoft.com/en-us/ms772425 - Original link mangled - Search here with Bing using a term like "Windows 8 Wifi" Lots of hits to browse through.

    Good luck with this and do let us know what the problem turned out to be once you've nutted it out.

    Note: Public Wifi hot spots generally allow you to connect without any authentication required. Or an Open WEP configuration without a password required to connect, hence I suspect your ability to connect in the city without any issues.

    Cheers...
    Last edited by Drewski; 2012-07-30 at 06:27. Reason: Fixd original search link provided that got mangled

  6. Super Moderator
    Join Date
    Jun 2011
    Location
    New England
    Posts
    2,399
    Thanks
    73
    Thanked 299 Times in 273 Posts
    PEAPv0/EAP-MSCHAPv2 is the technical term for what people most commonly refer to as "PEAP". Whenever the word PEAP is used, it almost always refers to this form of PEAP since most people have no idea there are so many flavors of PEAP. ... PEAPv0/EAP-MSCHAPv2 enjoys universal support and is known as the PEAP standard.
    Understanding the updated WPA and WPA2 standards

    It appears to me that PEAP should be selectable in Windows 8; this question/solution is about a wired connection, but I think the other steps may be relevant:

    Why Windows 8 CP don't connect to internet (802.1x)

    Bruce

  7. Star Lounger
    Join Date
    Jul 2012
    Posts
    58
    Thanks
    10
    Thanked 0 Times in 0 Posts
    Thanks for the replies.

    I think I found the solution:

    The problem was caused when I left the "Start this connection automatically" box ticked when setting up the network in Control Panel for the first time. After that, I was caught in a loop that wouldn't let me get to the security tab when using the Control Panel exclusively. The solution is to:

    1. Right-click the network in the Notification Area list and select "Properties" to change the security settings, or select "Forget this network" to start all over again.

    2. Untick "Start this connection automatically" when in the "Manually connect to a wireless network" screen in Control Panel.

    I'll check this out when I get to uni.

  8. Star Lounger
    Join Date
    Jul 2012
    Posts
    58
    Thanks
    10
    Thanked 0 Times in 0 Posts
    I'm at uni, and the solution above works only after successful connection to that network. Prior to connection, right-clicking the network has no effect. So I'm stuck.

    The problem was caused by the "Start this connection automatically" check box being ticked by default - leaving it ticked results in forcibly bypassing the option to manually set up the security options, and there is no option in Control Panel to delete a network once it is setup, and right-clicking on a network in the Notification Area network list has no effect until there is a successful connection.

    MS needs to add options in Control Panel to "Delete" or "Forget" the network and an option for "Properties" or "Security Settings", and make the wording of "Start this connection automatically" less ambiguous.

    So now there seems to be no way for me to delete or forget this network, and no way to get to Properties to adjust Security Settings. I'll keep scouring the net for solutions.

  9. Lounger
    Join Date
    Jun 2012
    Posts
    48
    Thanks
    3
    Thanked 3 Times in 3 Posts
    Quote Originally Posted by Martin Gifford View Post
    The problem was caused by the "Start this connection automatically" check box being ticked by default - leaving it ticked results in forcibly bypassing the option to manually set up the security options, and there is no option in Control Panel to delete a network once it is setup, and right-clicking on a network in the Notification Area network list has no effect until there is a successful connection.

    MS needs to add options in Control Panel to "Delete" or "Forget" the network and an option for "Properties" or "Security Settings", and make the wording of "Start this connection automatically" less ambiguous.

    So now there seems to be no way for me to delete or forget this network, and no way to get to Properties to adjust Security Settings. I'll keep scouring the net for solutions.
    Thanks for the update Martin.

    I only have Windows 8 in a Virtual Machine with no WiFi card installed at the moment, so I can't test this out myself, but I think I may have found a solution that "should" work for you..

    From a post found on this page.. http://haiteq.com/2011/09/14/connect...-in-windows-8/

    This was driving me crazy today, there is no “manage wireless networks” in Windows 8, not sure why. So once you set up a network you are not able to alter it unless it is broadcasting near you and you set it up with the right security. Well I found a fix, if you go to device manager and uninstall your wireless network card and then reinstall it (should only take about 20 seconds) it will reset your network profiles, allowing you to recreate one that may be setup incorrectly. Hope this helps.

    Not an ideal solution, but the logic behind the idea appears sound.. note you will likely need to re-connect your Windows 8 setup to all the other hot spots around the city that you have already configured, as the above step will likely clear the lot.

    If all else fails, and you don't mind having to re-connect to all of your existing WiFi connections, maybe give the above a try and see how you go.

    Good luck.

    Andy

  10. Star Lounger
    Join Date
    Jul 2012
    Posts
    58
    Thanks
    10
    Thanked 0 Times in 0 Posts
    Thanks Drewski/Andy,

    Yep, I just found that too and it worked! Note that some people said that didn't work for them, which seems strange. I uninstalled the wireless network card, then turned the computer completely off and left it off for a while. When I rebooted, I checked Control Panel and the Wireless network card was installed. Then I put the first screen of network details in and made sure the ""Start this connection automatically" check box was not ticked. Now I can access the security screen.

    The problem might also have been that I put the wrong details into the first screen because I got them off my mobile phone info - IOW, I wrongly used 802.x instead of WPA2-enterprise.

    Anyway, now I've got to get the correct security details and put them in. Then I think W8 should work on the Uni network.

    Cheers!

  11. Lounger
    Join Date
    Jun 2012
    Posts
    48
    Thanks
    3
    Thanked 3 Times in 3 Posts
    Quote Originally Posted by Martin Gifford View Post
    Anyway, now I've got to get the correct security details and put them in. Then I think W8 should work on the Uni network.
    Good to hear the workaround worked for you. Providing you can now establish a correctly authenticated connection to your Uni's WiFi network, then the only thing that should stop you from connecing to the facilities of your Uni's LAN may be restrictions on which operating systems are being allowed to connect and talk to their server(s) .. if they have no such restrictions in place, then you shouldn't have any issues accessing the resources.

    Do let us know how you get on with the final step.. As I think Ted rightly pointed out, Universities can be quite strict with security as a rule and I'm curious to know if they've just decided to white list Windows 8 to talk to their servers when it hasn't even officially been released yet.

    Cheers..
    Last edited by Drewski; 2012-07-31 at 00:15. Reason: Fix a typo

  12. Star Lounger
    Join Date
    Jul 2012
    Posts
    58
    Thanks
    10
    Thanked 0 Times in 0 Posts
    I tried lots of different settings and the uni techs did too. They phoned up the top guy and he said there's no deliberate restriction on Win 8. He reckons it's about the uni's complex network settings and the Win 8 wireless adapter driver. Some tweak needs to be done with the uni's system. He suggested trying the Win 7 driver. I did that, but it totally stops the wireless adapter from working in Win 8 - I switch airplane off but the wifi doesn't switch on even though the adapter light is on. So case closed. I hope they get it working quickly when Win 8 is officially released.

  13. Lounger
    Join Date
    Jun 2012
    Posts
    48
    Thanks
    3
    Thanked 3 Times in 3 Posts
    Quote Originally Posted by Martin Gifford View Post
    Some tweak needs to be done with the uni's system.
    Thanks for the honest update Martin. To me, the "top guy's" suggestion above translates to the Uni having to ease off on their security to accommodate a haphazard implementation of the Authentication protocols your University is using. They would be fools to do that in my opinion. The whole problem smells of a buggy Wi-Fi implementation in Windows 8, especially given that you seem to indicate Windows 7 machines have no issues and being told to try a Windows 7 driver for your Wi-Fi adapter..

    Laughable when I recall reading (in several places) all the praise being sung about how much better Windows 8 drivers are.

    So case closed. I hope they get it working quickly when Win 8 is officially released.
    If you mean the Uni, then good luck with that. If you meant Microsoft getting it working in Win 8, you might be in for a bit of a wait. According to Woody Leonhard in the latest edition of Windows Secrets I just glanced at, the final version of Windows 8 is already finished. The thing hasn't even hit store shelves and already it clearly needs work to just be able to successfully authenticate to a Wireless Hot Spot at a University.

    To be fair, as I've mentioned in other posts, any radically changed software package (especially an operating system) is bound to be riddled with bugs in it's initial release. Sadly, history has shown this to be particular true when it comes to Microsoft products.

    Best of luck with it mate.. Hope you can get it sorted soon.

    Andy

  14. Super Moderator
    Join Date
    Jun 2011
    Location
    New England
    Posts
    2,399
    Thanks
    73
    Thanked 299 Times in 273 Posts
    You were able to select PEAP on the Security tab?

    And User Authentication under Advanced Settings?

    Bruce
    Last edited by BruceR; 2012-08-01 at 20:42.

  15. Star Lounger
    Join Date
    Jul 2012
    Posts
    58
    Thanks
    10
    Thanked 0 Times in 0 Posts
    Drewski/Andy,

    The main problem I foresee is the Wireless is designed for tablets, phones, and the desktop/laptop. With tablets and phones, you want airplane mode. I like the airplane mode in theory for the desktop/laptop, but it can get a little fiddly between "Is my adapter working when the light's on/off and when the airplane mode is on/off." I guess with desktops/laptops that are designed for W8, the wireless adapter light switch will automatically match the airplane mode setting, but for computers that are upgrading, it's a bit fiddly - in RP anyway.

    BruceR,

    Yep, I got through to PEAP and User Authentication in Advanced Settings. The uni needs PEAP, so I kept that, but maybe I could experiment a bit more with User Authentication since the wording of that has changed in the drop-down menu.

  16. New Lounger
    Join Date
    Nov 2012
    Posts
    3
    Thanks
    0
    Thanked 1 Time in 1 Post

    I have a fix

    I HAVE A FIX!!!

    After countless hours with my IT department at my Uni, countless hours of remote control with the boys at MS, no one had a fix. Then I found an interesting article that talked about compatibility of some routers software with current Windows 8 software.

    Article Link here ----> http://support.microsoft.com/kb/2749073

    Since our Unis are unlikely to update the software for the network, downgrade your drivers to windows 7 drivers. If you upgrade from windows 8 this should be really easy (just rollback the driver). If not it's still possible by downloading a driver that works (they are out there). I am running a 2010 mbp with Windows 8 on bootcamp and I was able to find a Windows 7 driver that worked. If I can find that, you can find yours, I guarantee it. After you have that driver, restart, get your network config in and connect. Unfortunately I have to log in everytime my computer turns on or awakes from sleep, but hey it's a connection, right?

    Link to here to help other people.

  17. The Following User Says Thank You to aeppacher For This Useful Post:

    BruceR (2012-11-06)

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •