Results 1 to 3 of 3
  1. #1
    3 Star Lounger
    Join Date
    Feb 2009
    Posts
    308
    Thanks
    0
    Thanked 1 Time in 1 Post

    Word 2010: Table of Contents updates but List of Figures and Tables don't

    Hey folks,

    I'm editing a document for work (which unfortunately I cannot upload). The Table of Contents, List of Figures, and List of Tables entries all use the same heading style, which is Hyperlink.

    The problem I am encountering is that neither the List of Figures not eh List of Tables are displaying all the figures and tables in the doucmeutn. There are 5 figures in the doc, but the List only displays the first two; there are two tables in the doc but the List of Tables only displays the second. I have made sure all the formatting is consistent (figures are Figure, and their captions arr Figure Caption style; tables are Table, and their captions are Table Caption style). I even deleted the current captions and redid them. I also Ctrl+A the entire doc, then pressed F9>Update Table of Contents>Update Entire Table.

    I think part of the problem is that the List of Figures and List of Tables aren't seen by Word as being a proper ToC. For instance, there is no Update Field>Update Page Numbers Only/Update Entire Table option when I right click on the hyperlink field in either List of Figures or List of Tables. But that still doesn't explain why all the tables and figures won't appear in the List of ____. The tables and figures were already in the document, though they might have been added after the List of ___ sections were created. I deleted them and tried again, but no luck.

    I'm puzzled as to why these List of ___ sections refuse to recognize the

    One other question- if I try to assign a hyperlink to the images or captions within the report, and choose Place in This Document, none of the Figure or Table captions appears inthe Select a place in this document: drop down tree. If I try to assign them via References>Cross-Reference, then for some reason only Figure 1 appears in the Cross-refernce dialog box when I choose Figure for Reference Type, even though both Figure 1 and 2 (but not 3-5) appear under List of Figures.

    As you can tell, I'm confused. Thanks in advace for some suggestions.

  2. #2
    Super Moderator
    Join Date
    Jan 2001
    Location
    Melbourne, Victoria, Australia
    Posts
    3,852
    Thanks
    4
    Thanked 259 Times in 239 Posts
    Two things to check:
    1. Are you placing any captions inside floating text boxes/frames? I think this presents problems for a List of Figures.
    2. What field code is used to build the List of Figures? - Select the entire List and press Shift-F9 to toggle the field code. This will tell us whether you are using the SEQ field in the caption or the style to gather the info required.
    Andrew Lockton, Chrysalis Design, Melbourne Australia

  3. #3
    3 Star Lounger
    Join Date
    Feb 2009
    Posts
    308
    Thanks
    0
    Thanked 1 Time in 1 Post
    Figured it out. Because tracked changes were on and all changes hadn’t been accepted, I think this "ghost text"marked for deletion (which included figures and captions) might have been messing Word’s ability to update the List of Figures and Tables properly. I pressed Ctrl+A and accepted all changes, then Ctrl+A and F9 to update all.

    The takeaway here seems to be that Word gets tripped up by ghost text (text deleted or rather marked for deletion, but not fully purged from the doc) as far as List ToC are concerned.

    Has anyone else encountered this?

  4. The Following User Says Thank You to ben000 For This Useful Post:

    xxtntxx (2013-10-28)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •