Results 1 to 5 of 5
  1. #1
    Star Lounger
    Join Date
    Mar 2002
    Location
    San Jose, California, USA
    Posts
    77
    Thanks
    4
    Thanked 0 Times in 0 Posts

    Word format change affects whole document

    I am using Office 2010 on Windows 7 on my compnay laptop.

    When I'm editing a document and I make a formatting change (Change words to bold or italic for example) the formatting change initially affects the whole document. If I subsequently perform an "undo" (CTRL-Z) the document reverts to the previous formatting, leaving my selection formatted as I wish.

    While this does not destroy other formatting in the document it is very annoying to have to do the DO-Undo reoutine every time.

    Any thoughts?

    Keith

  2. Subscribe to our Windows Secrets Newsletter - It's Free!

    Get our unique weekly Newsletter with tips and techniques, how to's and critical updates on Windows 7, Windows 8, Windows XP, Firefox, Internet Explorer, Google, etc. Join our 480,000 subscribers!

    Excel 2013: The Missing Manual

    + Get this BONUS — free!

    Get the most of Excel! Learn about new features, basics of creating a new spreadsheet and using the infamous Ribbon in the first chapter of Excel 2013: The Missing Manual - Subscribe and download Chapter 1 for free!

  3. #2
    Super Moderator
    Join Date
    Jan 2001
    Location
    Melbourne, Victoria, Australia
    Posts
    3,499
    Thanks
    3
    Thanked 139 Times in 132 Posts
    The paragraph style on the text you are changing has a setting called "Automatically Update".

    I have noticed that in Word 2010 this setting no longer appears in the Modify Style dialog for the Normal style. If this is the style used in your document then we will probably need to use VBA to turn this setting off for that particular style.
    Andrew Lockton, Chrysalis Design, Melbourne Australia

  4. #3
    3 Star Lounger
    Join Date
    Apr 2012
    Posts
    237
    Thanks
    3
    Thanked 24 Times in 24 Posts
    Hi Andrew,
    Actually, you can get at it in Word 2010. From the Home Tab expand the Styles category (click small arrow in bottom right corner of the Styles area).
    From there, the "in-use" format should be highlighted. Right click on the format (or select the drop down arrow for it, and chooose "Modify". Uncheck the "automatically update" box. Note that not all styles have the automatically update box.

  5. #4
    5 Star Lounger
    Join Date
    Mar 2001
    Location
    New York, NY
    Posts
    856
    Thanks
    0
    Thanked 9 Times in 8 Posts
    It looks like Normal style, as Andrew observed, does not have Automatically Update. Character styles, plus Normal style (and perhaps others), do not have Automatically Update.

  6. #5
    Super Moderator
    Join Date
    Jan 2001
    Location
    Melbourne, Victoria, Australia
    Posts
    3,499
    Thanks
    3
    Thanked 139 Times in 132 Posts
    BigMac56

    I am pretty sure the setting used to be there. Perhaps it was removed in one of the service pack updates for Word 2010. I'm using version 14.0.6123.5001 (32 bit) and the Modify Styles dialog doesn't display the automatically update setting on the Normal style.

    However we can still toggle the setting via VBA despite this example of Microsoft trying to stop us running with scissors

    ActiveDocument.Styles("Normal").AutomaticallyUpdat e = Not ActiveDocument.Styles("Normal").AutomaticallyUpdat e
    Andrew Lockton, Chrysalis Design, Melbourne Australia

  7. The Following User Says Thank You to Andrew Lockton For This Useful Post:

    damnlimey (2012-09-17)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •