Results 1 to 7 of 7
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Location
    Pueblo, Colorado, USA
    Posts
    14
    Thanks
    2
    Thanked 0 Times in 0 Posts

    COM add-ins not working: Library not registered error

    Office 2010, and Outlook, were working well. I installed the 2013 preview. It worked fine, but decided to uninstall it and keep using 2010. Then my google calendar sync would not work and I found the 2010 version had lost the registration and would not accept the key code. I uninstalled and re-installed and it fixed all problems, except for the google calendar sync and any other program that interacts with Outlook. I uninstalled and re-installed google sync to no avail. The Google Sync error is "Could not connect to Microsoft Outlook: error -2147319779". That error is apparently just a generic error with no mention on the MS website. Here is the error I captured from GO Contact Sync:

    [9/11/2012 3:22:16 PM | Warning] Error getting available Outlook folders: Unable to cast COM object of type 'Microsoft.Office.Interop.Outlook.ApplicationClass ' to interface type 'Microsoft.Office.Interop.Outlook._Application'. This operation failed because the QueryInterface call on the COM component for the interface with IID '{00063001-0000-0000-C000-000000000046}' failed due to the following error: Library not registered. (Exception from HRESULT: 0x8002801D (TYPE_E_LIBNOTREGISTERED)).

    I went to the COM Add-ins and enabled everything. No change. Anyone know how to register the library?

  2. #2
    New Lounger
    Join Date
    Dec 2009
    Location
    Pueblo, Colorado, USA
    Posts
    14
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Anybody?

  3. #3
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    20,656
    Thanks
    2
    Thanked 635 Times in 568 Posts
    Have you tried repairing Office 2010?

    Joe

  4. #4
    New Lounger
    Join Date
    Dec 2009
    Location
    Pueblo, Colorado, USA
    Posts
    14
    Thanks
    2
    Thanked 0 Times in 0 Posts
    several times now. no change.

  5. #5
    Super Moderator jwitalka's Avatar
    Join Date
    Dec 2009
    Location
    Minnesota
    Posts
    5,004
    Thanks
    71
    Thanked 574 Times in 520 Posts
    Does it fail in Outlook safe mode?
    http://www.outlook-tips.net/beginner...-in-safe-mode/

    If not, disable Com ad ins one at a time.

    Jerry

  6. #6
    Super Moderator
    Join Date
    Jun 2011
    Location
    New England
    Posts
    2,915
    Thanks
    91
    Thanked 356 Times in 320 Posts
    A probable solution would seem to be this, related to a different but similar product which produces an identical error message in this situation:

    If you recently previewed Outlook 2013 and then uninstalled and reinstalled a prior version of Outlook you may encounter the following error message when syncing ...

    Bruce

  7. The Following User Says Thank You to BruceR For This Useful Post:

    aprayzr (2012-09-20)

  8. #7
    New Lounger
    Join Date
    Dec 2009
    Location
    Pueblo, Colorado, USA
    Posts
    14
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Jerry: Yes, it fails in safe mode.

    Bruce: You ROCK! The key in step 2 needed to be deleted. Works fine now and is syncing over 2700 events!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •