Results 1 to 2 of 2
  1. #1
    Lounger
    Join Date
    Jan 2010
    Location
    Middleton, WI
    Posts
    37
    Thanks
    14
    Thanked 0 Times in 0 Posts

    Attached USB Device has stopped working

    I have recently begun to get notifications something to the effect: USB Device Not Recognized. One of the USB devices attached to this computer has malfunctioned, and windows does not recognize it. For assistance in solving this problem, click the message.

    In Device Mngr, the yellow "alert" indicates "unknown device". Further, "Windows has stopped this device because it has reported problems (Code 43)".

    =============

    The pc (HP Pavillion) is my pro audio machine dedicated to recording & mixing audio. Win 7 Home Edition (64 bit). It is used exclusively for pro audio.

    I have 4 USB ports in the back and 2 in the front. Connected to the back are two separate keyboards and a pro sound card (USB audio interface), all working properly. Today was a scheduled bakup, and I connected an external USB drive to the 4th port and it worked as usual.

    Thus, I suspected the possible problem is with the front ports. I very recently bought a new flashdrive (8GB SanDisk Cruzer Facet) on sale at Best Buy which I used to successfully transfer pics between 2 other pcs. That same day, I plugged this flash drive into my audio pc just to check it out with the intention of possibly moving some older, large audio projects in at a later date. I used the safely eject to remove the drive. All was well.

    I noted windows appeared to install drivers for the flash drive when 1st inserted.

    =======================

    ***So today. to check the front USB ports, I again plugged the SanDisk into the right port and now it is not recognized in My computer nor in Safely Eject. I then plugged an older, smaller (2GB) flash drive in to the same port and it is recognized and operational.

    I then took the SanDisk to another Win 7 pc (which received the pictures via the SanDisk) and this same flash drive does work there.

    ***Edit per RK, 647PM Cen: I again plugged the sandisk into my audio pc front port with the intention of uninstalling, but the flash drive now is working, perhaps I didn't get the little guy far enough in the 1st time today Thus I do not know what the unknown device is and what USB port in not functioning
    ========================

    So I suspect the issue is with the right front USB hub and / or the SanDisk. In Device Mngr for the unknown device, I clicked check for new driver button (checked automatically) and it says the driver is up to date. However, clicking on the "Driver Details" button brings up a dialog box which says no driver files required or have been loaded for the device.

    Any help is much appreciated. My pc has been running wonderfully and with all my ongoing audio projects, I am worried about doing too much uninstalling all the drivers, etc since all my devices (except this flash drive on the front port) are working perfectly.

    ***Further RK edit, 651PM: If I uninstall all the USB hubs as i see commonly recommended, will that affect my devices (keyboards, audio interface, external HD) in any way? I, of course, have very specific drivers for the audio devices and would not want Windows to just install any old driver. As well, my external HD is not normally connected and one of my keyboards is not powered up normally. Will that affect the uninstall stack, I believe it was called? Thanks again!

    Thanks much!

    Robby K
    Last edited by robbyk; 2012-09-17 at 19:56.

  2. #2
    Lounger
    Join Date
    Jan 2010
    Location
    Middleton, WI
    Posts
    37
    Thanks
    14
    Thanked 0 Times in 0 Posts
    My 1st restart this afternoon did not resolve the issue. I just shut down completely (including the power strip) and now I have no pop up nor triangle in the device mngr. Hopefully all is cured although I'm a bit worried if the error will return when coming out of hibernation.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •