Results 1 to 4 of 4
  1. #1
    New Lounger
    Join Date
    Sep 2012
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts

    CSS not displaying properly in Firefox or Chrome

    Hey Everyone,

    I'm a newly registered user, but have been on here a few times looking around. I hope there is someone here who can help me with my problem.


    My client has coded his own site and made a bit of a mess i've fixed it up to the point of making it work on IE. While it was completely garbled in firefox and chrome, so I ran the css file through WC3 Validator and it fixed 90% of the problems (I hope). The problem now is the top nav bar is floating in the middle of the screen instead of being in a fixed position at the top like in IE.

    Heres the link http://www.expandingchildcare.com/

    The link to the CSS file http://www.expandingchildcare.com/style/style.css

    No major rush on this as he only needs it to work in IE for his buisness meeting tomorrow.

    Thank you very much for any help in advance

  2. Get our unique weekly Newsletter with tips and techniques, how to's and critical updates on Windows 7, Windows 8, Windows XP, Firefox, Internet Explorer, Google, etc. Join our 480,000 subscribers!

    Excel 2013: The Missing Manual

    + Get this BONUS — free!

    Get the most of Excel! Learn about new features, basics of creating a new spreadsheet and using the infamous Ribbon in the first chapter of Excel 2013: The Missing Manual - Subscribe and download Chapter 1 for free!

  3. #2
    Administrator
    Join Date
    Jun 2010
    Location
    Portugal
    Posts
    10,308
    Thanks
    130
    Thanked 1,159 Times in 1,067 Posts
    Remove the position:fixed attribute for class head2. This will fix it for Chrome and Firefox. Not sure how IE will handle it, though.



    P.S.: Tested it in IE 9, both in IE 7 mode and IE 9 mode and the fix also works.

  4. #3
    New Lounger
    Join Date
    Sep 2012
    Posts
    2
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Wow very fast response ! Thank you for the fix. Now I have to mess around with image sizing and everything should work.

  5. #4
    Administrator
    Join Date
    Jun 2010
    Location
    Portugal
    Posts
    10,308
    Thanks
    130
    Thanked 1,159 Times in 1,067 Posts
    You're welcome.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •