Results 1 to 6 of 6
  1. #1
    3 Star Lounger
    Join Date
    Feb 2009
    Posts
    308
    Thanks
    0
    Thanked 1 Time in 1 Post

    Need help: creating a Table of Contents without figure or table listings

    Hey folks,

    I'm using Office 2010. In our reports we have a separate listing for tables, and a separate listing for figures, so I want to create a table of contents for sections that doesn't list figures or tables.

    Can someone explain how I can accomplish this?

    PS- There is already a List of Figures and List of Tables entry in the report, so I don't need to create one...I just need to remove the figures and tables from the ToC.


    Also, the default ToC (Built-In automatic table 1) is displaying bullet style and note style text (both of which are Body Text in the Outline Level: in Paragraph>Indents and Spacing), even though the print and web preview windows in Table of Contents dialog display Appendix 1, Heading 1, Appendix 2, Heading 2, Appendix 3, Heading 3, and nothing else.

    I tried clicking on the Note and Bullet heading styles to see if I could assign an "exclude from Table of Contents" status, but notice that in the References>Table of Contents>Add Text>Do Not Show in Table of Contents is already checked. Not sure what to do.

    As it is, the ToC in this report is some 20+ pages long b/c it's displaying way too many levels it seems.

    Thanks!
    Last edited by ben000; 2012-11-13 at 18:02.

  2. #2
    WS Lounge VIP
    Join Date
    Mar 2006
    Location
    Maryland, USA
    Posts
    690
    Thanks
    17
    Thanked 66 Times in 56 Posts
    Has your file been opened in an older version of Word by someone who used the Document Map? That feature changes paragraph outline levels as direct formatting. If you also see these spurious headings in the navigation pane, that is very likely what has happened.

    A quick fix is to remove the \u from the TOC code. Click the on the Home tab of the ribbon to turn on formatting marks. Select the TOC and the empty paragraph mark after it. Right click, then left click Toggle field codes. You should see something like this {TOC \o "1-3" \h \z \u}. Delete the \u. then Select and toggle the field codes again.

    For other options see http://word.mvps.org/faqs/general/DocumentMap.htm


    P
    am
    Last edited by PamCaswell; 2012-11-14 at 09:51. Reason: To replace xxxx with name of the feature, which I had momentarily forgotten.

  3. #3
    Super Moderator
    Join Date
    Jan 2001
    Location
    Melbourne, Victoria, Australia
    Posts
    3,853
    Thanks
    4
    Thanked 259 Times in 239 Posts
    Do as Pam suggests to toggle the field code. This will reveal the styles and/or outline levels used to build the TOC.

    Also, find out what style is applied to the captions on the figures and tables. By default this will be called "Caption" but it may be something else.

    If you can report back on both the TOC field code and what style is on the captions then we can tell you how to remove the caption entries from it.
    Andrew Lockton, Chrysalis Design, Melbourne Australia

  4. #4
    3 Star Lounger
    Join Date
    Feb 2009
    Posts
    308
    Thanks
    0
    Thanked 1 Time in 1 Post
    Thanks, Pam. I followed your advice and saw exactly what you described. I deleted \u and now have {TOC \o "1-3" \h \z}
    That didn't fix the problem however...still the same issue with figures, tables, and bullet points appearing in ToC

    Andrew- Figures are given Figure Style, captions are given Caption Style, and notes are given Note style within the Word headings styles. When I look at the ToC settings I don't see any indication that the ToC is including any of these styles.

  5. #5
    WS Lounge VIP
    Join Date
    Mar 2006
    Location
    Maryland, USA
    Posts
    690
    Thanks
    17
    Thanked 66 Times in 56 Posts
    Since my suggestion didn't help and since you say the styles in question have the body text paragraph outline level and the TOC is the standard one (except, now, for \u), I think we need to see a sanitized and short version of your document.

  6. #6
    Super Moderator
    Join Date
    Jan 2001
    Location
    Melbourne, Victoria, Australia
    Posts
    3,853
    Thanks
    4
    Thanked 259 Times in 239 Posts
    If the toc with the field code {TOC \o "1-3" \h \z} is showing the caption style entries then you need to edit the Caption style and change its outline level to 'Body Text'

    Get to the the Modify Style dialog for the Caption style. Click on Format > Paragraph then change the Outline Level to 'Body Text'. Once that is done, refresh the TOC
    Andrew Lockton, Chrysalis Design, Melbourne Australia

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •