Results 1 to 2 of 2
  1. #1
    Join Date
    Sep 2011
    Thanked 0 Times in 0 Posts

    MiTraveler Tablet WiFi connection problem

    Am trying to connect a Tivax MiTraveler-10C2 device (Android 4.0.4 & built-in WiFi) to an existing Belkin Router. Router works fine with existing XP Notebook using both DSL & WiFi connections.
    The tablet recognises the 'Home' network (as well as another one -neighbors?) & allows entry of PSK - have carefully entered this 5-6 times. Then shows Status = Authenticating... ; Signal Strength = Excellent ; Security = WPA/WPA2 PSK, in the pop-up window, but does not complete the 'connection' step. Also shows the 'Authenticating' message in the Network list, replaced with "Saved, secured with WPA/WPA2" every 15 seconds or so.
    Router Security Mode = WPA/WPA2 - Personal (PSK) ; Authentication = WPA-PSK+WPA2-PSK. Have tried resetting Authentication to WPA-PSK & WPA2-PSK options.

    Possible causes:
    1. Faulty tablet device - will obtain replacement asap to test this.
    2. WiFi incompatibility between devices. Belkin tell me the Router they supplied to me in Oct. 2010 (replacement for a 12 month old purchase that 'died' at that time) is no longer under its 'Life-Time Warranty' - since May 2012, and will only provide chargeable support, or a discounted replacement. Don't want either until I know whetherthe Router is at fault in this instance. No Firmware update available either.
    Certainly not too impressed with that change of policy!

    Apart from this 'minor glich', I'm quite impressed with the device from the fairly limited use of it so far.

    Update: Overnight brain-wave! Set the Router Security Mode to Disabled. Good News: Tablet now connects to the Internet. Bad News: Doesn't appear to allow for any data Security/Encryption - unless there are some Security settings I haven't found yet. The Manual is next to useless, and Supplier Support non-existent.

    Is this the same for all Tablets??
    Last edited by johnrfnz; 2012-11-23 at 11:02. Reason: Update

  2. #2
    Super Moderator jwitalka's Avatar
    Join Date
    Dec 2009
    Thanked 791 Times in 713 Posts
    Did you follow these instructions from the manual at:

    Wireless Network:
    1. Switch to ‘ON’ the Wi-Fi switch on top of the device to enabled Wi-Fi function;
    2. Tap the Settings icon on the shortcut bar;
    3. Tap the Wireless & Networks on the setting menu;
    4. Check box next to Wi-Fi to turn on Wi-Fi function; **To save power, Wi-Fi will be off if Wi-Fi box is not checked even Wi-Fi function was enable**
    5. Tap Wi-Fi Settings to scan Wi-Fi network;
    6. All available wireless network near the unit will be listed after scan. Tap the network name that you want to connect.
    7. If the wireless network was connected successfully once before, network information was stored. Choose “Connect” on the popup menu to connect network or choosing “Forget” to erase network information.
    8. Connect non-Secured network, choose “Connect” on the popup menu to connect ;
    9. Connect Secured network, input the network keys or password on the popup menu then choose “Connect” to connect;
    10. After the network is connected, a Wireless connection icon will be shown on the top status bar.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts