Page 1 of 2 12 LastLast
Results 1 to 15 of 19
  1. #1
    Star Lounger
    Join Date
    Feb 2011
    Posts
    97
    Thanks
    27
    Thanked 2 Times in 2 Posts

    Dictionary changing language

    Does any one know how to stop the dictionary in Word 2000 changing from English (UK) to English (US)

    I know that if you highlight all the text then change the language and save it stops that way for that document, but I want to stop it changing, unless I change it.

  2. Subscribe to our Windows Secrets Newsletter - It's Free!

    Get our unique weekly Newsletter with tips and techniques, how to's and critical updates on Windows 7, Windows 8, Windows XP, Firefox, Internet Explorer, Google, etc. Join our 480,000 subscribers!

    Excel 2013: The Missing Manual

    + Get this BONUS — free!

    Get the most of Excel! Learn about new features, basics of creating a new spreadsheet and using the infamous Ribbon in the first chapter of Excel 2013: The Missing Manual - Subscribe and download Chapter 1 for free!

  3. #2
    Super Moderator
    Join Date
    Jun 2011
    Location
    New England
    Posts
    2,719
    Thanks
    78
    Thanked 335 Times in 303 Posts
    If you're clicking the default button when you change the language, but it doesn't retain the change when you restart Word, try these steps to make a permanent selection:

    Changes to default language settings are not retained in Word

    Bruce
    Last edited by BruceR; 2012-11-30 at 06:53.

  4. #3
    Star Lounger
    Join Date
    Feb 2011
    Posts
    97
    Thanks
    27
    Thanked 2 Times in 2 Posts
    Hi Bruce

    Thanks for getting back to me

    The short cuts only works on Word 2003 and above, I have Word 2000.

    If I go to start / settings / control panel / keyboard / keyboard properties / The rest of the short cut text is not there.

    All I get is start / settings / control panel / keyboard / keyboard properties / which shows
    Repeat Delay, Repeat Rate, Cursor Blink Rate, if I go into Hardware then properties I get
    No Problems with the device.

    This made me think, I went to start / settings / control panel / language / and deleted US language keyboard then rebooted then tried to edit and again it still went to English (US) but when I tried to go back to start / settings / control panel / Language as not there.

    I do edit documents from USA [ Sometimes the top language English (UK) other times it’s the second language] I think the only way is to delete the US dictionary as detect language automatically is not selected

    Even though the documents I edit are copy and paste on to a normal.dot, which is set at English (UK)

  5. #4
    Super Moderator
    Join Date
    Jun 2011
    Location
    New England
    Posts
    2,719
    Thanks
    78
    Thanked 335 Times in 303 Posts
    I thought the Control Panel options should be the same whatever version of Office was installed. Do you have a Text Services icon in Control Panel? (as in More Info at the link)

    Bruce

  6. #5
    Star Lounger
    Join Date
    Feb 2011
    Posts
    97
    Thanks
    27
    Thanked 2 Times in 2 Posts
    Thanks for getting back to me

    Sorry no Text Services icon

  7. #6
    Super Moderator
    Join Date
    Jun 2011
    Location
    New England
    Posts
    2,719
    Thanks
    78
    Thanked 335 Times in 303 Posts
    Are you clicking the Default button? (Step 5 here; How do I Change the Dictionary Language in Microsoft Word 2000?)

    Bruce

  8. #7
    Star Lounger
    Join Date
    Feb 2011
    Posts
    97
    Thanks
    27
    Thanked 2 Times in 2 Posts
    Thanks for getting back to me

    “Are you clicking the Default button? (Step 5 here”

    Yes I have tried it both using the Default button and not using the default button it made no difference.

  9. #8
    WS Lounge VIP
    Join Date
    Mar 2006
    Location
    Maryland, USA
    Posts
    677
    Thanks
    17
    Thanked 57 Times in 50 Posts
    If your concern is mainly about proofing advice, note that, in the Language dialog, you can clear the box before Detect language automatically.

    Pam

  10. #9
    Star Lounger
    Join Date
    Feb 2011
    Posts
    97
    Thanks
    27
    Thanked 2 Times in 2 Posts
    Thanks for getting back to me Pam

    Detect language automatically is not ticked

    It would appear that both English UK and US language dictionary are in use, I have looked in the Program file Office to see if I could delete the US Dictionary but I can not find it.

  11. #10
    Super Moderator
    Join Date
    Jan 2001
    Location
    Melbourne, Victoria, Australia
    Posts
    3,506
    Thanks
    3
    Thanked 141 Times in 134 Posts
    The language setting can be applied on a paragraph by paragraph basis. If your spelling language keeps changing then it is likely that your style definitions include US spelling. You can use a macro like the following to change all the styles to the same language and also get the existing text to the same language (in case it was locally formatted).
    Code:
    Sub SetLanguage()
      Dim astyle As Style
      For Each astyle In ActiveDocument.Styles
        If astyle.Type = wdStyleTypeParagraph Then
          astyle.LanguageID = wdEnglishUK
        End If
      Next astyle
      ActiveDocument.Range.LanguageID = wdEnglishUK
    End Sub
    Andrew Lockton, Chrysalis Design, Melbourne Australia

  12. #11
    Star Lounger
    Join Date
    Feb 2011
    Posts
    97
    Thanks
    27
    Thanked 2 Times in 2 Posts
    Thanks for getting back to me.

    I used the macro set in normal.dot

    I opened a new document and typed in favor and it changed it to favour.

    When I get the next US document I will let you know how I got on

  13. #12
    Star Lounger
    Join Date
    Feb 2011
    Posts
    97
    Thanks
    27
    Thanked 2 Times in 2 Posts
    Thanks for getting back to me Andrew

    I added the Macro it said it would be stored in Normal.dot.

    After closing Word and re-opening it I typed in favor and it changed it to favour.

    I closed word and re-opened it again cut and paste some new English (US) text and the first word I noticed with a red line under it was favour saying the spelling was wrong?

    It just does not make sense

  14. #13
    Star Lounger
    Join Date
    May 2007
    Location
    Gloucester, Gloucestershire
    Posts
    60
    Thanks
    1
    Thanked 0 Times in 0 Posts
    Have you checked the language setting of your Normal style in the Normal.dot template? If that's set to English (US) and you have "Automatically update document styles" switched on for the template, it could be overriding the British English setting within your document. (That's assuming the document styles are based on the Normal style, of course.)

  15. #14
    Star Lounger
    Join Date
    Feb 2011
    Posts
    97
    Thanks
    27
    Thanked 2 Times in 2 Posts
    Thanks for getting back to me. Annie

    I open Word go to Tools / Language /set Language / both England (US) and English (UK) are the top two and both have a tick against them, but English (UK) is high lighted [at the minute] so I would think that is the one set in Normal.dot

    I think if I could find a way of un-ticking English (US) that would cure it?

  16. #15
    Silver Lounger mrjimphelps's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    2,137
    Thanks
    202
    Thanked 206 Times in 198 Posts
    What is the default language in Windows? Windows may be set to American English, which may be triggering Word to default to American English.

    In Windows 7, go to Control Panel / Region and Language.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •