Results 1 to 5 of 5
  1. #1
    New Lounger
    Join Date
    Nov 2012
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Crazy mouse clicks

    Sometimes, when I click on something, the computer does something I donít expect. For instance, just now I opened the Control panel and double clicked ďInternet OptionsĒ. Nothing happened. Sometimes when I'm trying to log out of gmail (with Chrome, IE or Firefox), a new window will open instead. And then there are the times I try to open a program by double clicking its icon, and the Properties box will open. Iíve found a work around. By tapping the Shift, Ctrl, Start and Alt keys two or three times each, sequentially, the problems goes away, but I know it will come back. Iím using Windows XP SP2 on a very old computer with a Logitech Cordless LX 500 keyboard with a Logitech Cordless Click! Mouse. Iím using the latest software. Iíve tried changing the batteries, but that has no effect. Can anybody help?

  2. #2
    Silver Lounger Banyarola's Avatar
    Join Date
    Dec 2009
    Location
    Big Indian, New York
    Posts
    1,900
    Thanks
    19
    Thanked 65 Times in 54 Posts
    It could be interference ..

    If you have a portable phone near the computer or mouse receiver try moving further away and also try using a different usb port to lug in the mouse receiver.

    If you have another mouse try that..

    Sometimes the left click goes bad and will give you erratic mouse behavior..
    "If You Are Reading This In English, Thank A VET"

  3. #3
    Gold Lounger Roderunner's Avatar
    Join Date
    Dec 2009
    Location
    Scotland.
    Posts
    3,462
    Thanks
    16
    Thanked 216 Times in 183 Posts
    Hi spikejones, right click the arrowed items in my image (keyboard first) and select 'Uninstall'. Press the Power button to shut down your pc. Before restarting, change the port your USB is in. The drivers will be reinstalled on start-up.

    RR.jpg
    O wad some Power the giftie gie us, to see oursels as ithers see us!

  4. #4
    Super Moderator
    Join Date
    Jun 2011
    Location
    New England
    Posts
    4,746
    Thanks
    171
    Thanked 649 Times in 572 Posts
    Check at Control Panel, Accessibility Options, Keyboard whether StickyKeys is turned on (or the option to turn StickyKeys on by pressing the shift key five times).

    Bruce

  5. #5
    New Lounger
    Join Date
    Nov 2012
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Thanks,
    I'm trying another Logitech cordless mouse - MX 600

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •