Results 1 to 8 of 8
  1. #1
    New Lounger
    Join Date
    May 2012
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Windows 7 Loses Mapped Drive After Sleep

    PROBLEM: Windows 7 SP1, fresh installation -- enters sleep mode, on awakening mapped drives are lost. Only happens on desktop PC's (Dell Vostro 1100s)

    SETUP: Small LAN setup in a "Workgroup": (5) Desktops, (5) Laptops, (2) iPads, (5) iPhones, (1) Drobo FS 'beyond RAID' RAID-type NAS w/ 3-2TB HDDs, (1) Canon laser printer, (1) Linksys 2400 switch in a wiring closet, and (1) Linksys E4200 router directly connected on one side to an SMC Comcast Business Cable modem and on the other side to the LAN. This is all on Cat 5. WiFi is good at 300Mbps, LAN & NICs are all matched at 100Mbps. Existing NICs & modem all top out at Fast ethernet (100 Mbps) but the Drobo, switch & router can do Gigabit. Router provides hardware firewall, Windows systems all run stock software firewall, and MSE.

    BACKGROUND: I've recently begun upgrading our SOHO LAN to Windows 7 Home Premium 32 bit. I bought a 3-seat package and have thus far installed 2-seats on desktops. The other 3 desktops are on XP-SP3. Three of the laptops are Win 7 64b, the other two are XP-SP3. The i-stuff is on i-blah. All data is stored on the Drobo NAS. User files are obviosly on the individual devices. Prior to installing the two seats on the desktops, all systems were reliably mapped and reconnected every time, all the time, to the NAS, including the 3-laptops running Win 7 64b. The new Windows 7 SP1 installs are running the default "Balanced Power" setting. The other devices continue to function reliably and as-expected, properly mapping. The NAS is hot-swap capable and off-site backup is to iDrive cloud service.

    Upon doing clean installs on the 2-Dells (not upgrades - full, formatted, clean installs) and setting up everything I mapped the usual folder on the NAS (G) to the desktops as (G) and ticked 'Reconnect at logon'. I soon noticed that when Windows 7 enters sleep, it disconnects the mapped drives and upon waking does not reconnect the mapped drives.

    I checked online assuming this must be a known-fixed issue by now, 2012. Yes, I found out it was known since at least 2009, but I haven't found a real fix.

    • MS has a Mr. Fixit that automates writing an entry in the registry parameters for LanmanServer changing the autodisconnect time.
    • They also refer to a manual fix that adds a KeepConn value in the LanmanWorkstation parameters, and
    • two command line efforts: one for net use which tells the system to reconnect the map and is fine if 'G' is connected on shut down or reboot, and
    • another for net config which has to be written under admin priviledges and is fine to keep the mapped connection from disconnecting which the machine is awake.
    • I've also tried adjusting the NIC power management settings.
      • The NIC was set to: [x] Allow computer to turn off / [x] Allow computer to wake / [x] Only allow a magic packet to wake.
      • At first I tried changing them to disallow the computer from turning off the NIC, then
      • Allow / Allow / don't require a magic packet.


    This seems to keep the box from losing the map haphazardly while it's awake, but all bets are off if it goes to sleep.

    There are a variety of reasons why this is an issue and the sleep cycle is wanted for several reasons as well -- so just skipping sleep mode or instructing users to re-map drives every time they logon won't fly.

  2. #2
    Super Moderator
    Join Date
    Jun 2011
    Location
    New England
    Posts
    4,756
    Thanks
    171
    Thanked 653 Times in 576 Posts
    You tried net use with /PERSISTENT:YES?

    Bruce

  3. #3
    New Lounger
    Join Date
    May 2012
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Cool Yes...

    Bruce, Thanks for the reply. Yes, I tried:
    • net use \\server\g /persistent:yes
    • net config server /autodisconnect:-1

    "/persistent" only works if the drive is mapped when Windows shuts down (power off). If the drive is not mapped at that time, there is no 'G:\' to persist and it does not hold it over for the next session. "/autodisconnect" had to be run using admin priviledges at the command line. It, too, was ineffectual at curing the problem.

    I've been chasing this issue down for about a 1-wks now b/c of its importance in our setup. I think I may have stumbled on the fix, but I don't truly understand why it works nor if all the various things are truly necessary. When I started this adventure my user was having issues of losing the mapped drive haphazardly during live sessions, then losing all network connections. I got those issues fixed which eventually led me to the end of the puzzle, losing the mapped drive entering sleep mode.

    Here is what I found:

    In normal operations once the PC is connected to the LAN and I can see an available network drive, I expect to be able to right click on that drive, map it, mark [X] the option to Reconnect at logon, and have that mapped drive available to that PC anytime it's live on the LAN, whether in session, awakening from sleep or hibernation, or rebooting. This worked reliably as expected in Windows XP. All indications are it stopped working reliably in Vista and continued having issues in Windows 7.

    During my troubleshooting I took note of the link at the bottom of the Map Network Drive that reads Connect to a Web site that you can use to store your documents and pictures. I mapped the G drive as usual then went back and clicked through the link which brought up the Add Network Location Wizard. I followed the steps in the wizard to set a new Network Location, \\Server\G. Then I induced sleep (start > sleep).

    Lo and behold, the Network Location survived sleep -- but the mapped drive died off, same as usual. I was about to throw in the towel at this point figuring I could rewrite most of our software linkage to \\Server\G, and I might have to punt for software that would not manage that sort of linkage (non-LAN-aware) and demanded a mapped drive instead. Then I had an idea...

    I deleted the Network Location (the mapped drive was already MIA). Then first I hooked onto the Network location through the Network Location Wizard, then second came back to the hooked Network Location and mapped the drive to G.

    That worked! I have no clue why.

    Something about the NLA is awry. I did find during induced sleep mode that I had to recheck [X] the NIC's property to require a magic packet to awaken the NIC, otherwise sleep lasted only a few seconds at most. But after that, it all works as expected.

    I am now backtracking to see if any of my registry changes or ommand line changes can be removed and still have a successful resolution to the issue. If so, I can at least fix it with the minimum of intrusion into power-saving, defaults, etc.

    If anybody knows (or can reasonably postulate) why it's necessary to establish a new "network location" then map the drive in order for things to work properly, I'd love to know.

    BTW, the NIC(s) are Intel PRO/100 VE Network Connection(s), bulit-in to the motherboard(s). The systems are from Dec 2005. They carry 2GB RAM and have been outfitted with old 'standard PCI' dual-monitor nVIDIA GeForce FX 5200 video cards. The BIOS(s) do not support hardware VM and the onboard video does not support Aero, but the nVIDIA cards do, although to use these I had to grab Vista drivers as nVIDIA didn't write 7 drivers for these cards. The systems run Pentium 4(s) at 2.80GHz and all-in-all Windows 7 is sweet and runs better than XP did.

    Yes, Virginia, you can run Windows 7 x86 on a 2005 system, but be prepared for some extra work getting it up to speed.

  4. #4
    New Lounger
    Join Date
    May 2012
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I lied. It failed reboot. Ugh!

    At least I can get it to hold over sleep, and with our systems being rebooted every week or two it may not be a huge issue to put it in a batch file for start up. What a PIA!

    Still looking for an answer

  5. #5
    Super Moderator BATcher's Avatar
    Join Date
    Feb 2008
    Location
    A cultural area in SW England
    Posts
    3,421
    Thanks
    33
    Thanked 195 Times in 175 Posts
    I put all drive mappings by user, and printer assignments by PC location, into the Logon Script.
    But currently we are all XP, but staggering feebly towards Windows 7!
    BATcher

    Time prevents everything happening all at once...

  6. #6
    New Lounger
    Join Date
    May 2012
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts
    Yeah, I had -0- issues with XP. Everything worked "ad advertised", as they say.

    I only moved to 7 due to the prospect of software killing access to my data. I had that happen once and it really left me scrambling. I had to go out and find a package that had been discontinued 3-yrs earlier, and pay a premium for it, so we could open the data and re-save it so the new version could open it. I didn't want to get caught in that trap again. I figured 7 has been out so long, and all recommendations are that it's super-stable, that moving might be timely. But I even put that off until I'd played with it (albeit 64b on an ultrabook) and toyed with 8. On top of that, I tested it on my desktop, which I also use as a mule, and it seemed fine. It wasn't until I made the final decision to deploy that I noticed this issue -- and realized I'd encountered it on my desktop (but never on the 64b laptop) but ignored it and just re-mapped out of habit -- fine for me, not for my users.

    I have noticed the NLA holds tight for \\Server\G, just not the mapping and only in x86. My systems looks to be mostly OK there I just have to re-code some stuff. But two packages are toast and one is super-important.

    We use iDrive for cloud backup. It's worked fine for a couple of years and allows me to backup multiple systems at very reasonable prices. Their package includes backing up mapped drives, which has worked really well to do off-site for the Drobo NAS BeyondRAID box mentioned in my opening post -- until now. That box runs Apache and I am in no way, dream, nor imagination a Unix Wonk, nor have I ever played one on TV. With that, the mapping has become a really major issue.

  7. #7
    New Lounger
    Join Date
    May 2012
    Posts
    6
    Thanks
    0
    Thanked 0 Times in 0 Posts

    I Found It!

    SOLUTION:
    • net use G: \\server\g /persistent:yes
    • net config server /autodisconnect:-1


    In a batch file, reached by a shorcut, run with admin privileges, placed in the startup folder. I missed the assign-to drive letter [G:] between "use" and "\\server". Now 7 maps when it boots and maintains mapping when it resumes. This works in a WORKGROUP. I doubt that it would help in a Homegroup as 7 doesn't support mapped drives in Homegroups.


  8. #8
    Super Moderator
    Join Date
    Jun 2011
    Location
    New England
    Posts
    4,756
    Thanks
    171
    Thanked 653 Times in 576 Posts
    Aha! Well done for being persistent:yes!

    Bruce

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •