Results 1 to 5 of 5
  1. #1
    New Lounger
    Join Date
    Nov 2009
    Posts
    13
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Win XP Pro - programs open on 2nd monitor when it is not there

    Hello all,
    persistent and mildly annoying problem concerning laptop and 2nd monitor use.
    I usually use my laptop while connected to a second monitor so that I can use the real estate to spread out applications and often work with information on two screens simultaneously.
    Problems arise when I use the laptop in stand alone mode. Some applications seem to open in the second monitor which at that point, is no longer there.
    Any suggestions on how to indicate to Windows that the 2nd monitor is not there. I try display settings but that doesn't seem to work. In fact, windows shows that there is only one monitor selected.
    ???
    Thanks

  2. #2
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    9,434
    Thanks
    372
    Thanked 1,457 Times in 1,326 Posts
    Garvey,

    Try using the keyboard to move the application back to the available monitor.
    WinKey+Shift+[Right | Left] Arrow ...which ever is appropriate based on relative positions when 2nd monitor is connected.
    May the Forces of good computing be with you!

    RG

    PowerShell & VBA Rule!

    My Systems: Desktop Specs
    Laptop Specs

  3. #3
    WS Lounge VIP mrjimphelps's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    3,396
    Thanks
    445
    Thanked 404 Times in 376 Posts
    Some programs aren't going to follow the Windows settings. For example, our tape backup program (EMC Networker). I had a habit of always running it in the right monitor. Then when I was on a computer with only one monitor, and I opened up a window in Networker, I couldn't find the window.

    With XP, I could maximize it, and it would then fill up the current screen. But with Windows 7, I didn't have the maximize option. Problem is, we are moving away from XP and to Windows 7, so my options were disappearing.

    I finally figured it out when I loaded Networker on my wife's computer. She has a very wide screen, and far to the right, I could see the left edge of the Networker window I had just opened. Enough of the window was visible so that I could drag it to the left side of the screen.

    Solution: I ALWAYS run Networker in the left screen, and I never maximize the windows. Since following that plan, I have never had a problem running Networker.

  4. #4
    WS Lounge VIP mrjimphelps's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    3,396
    Thanks
    445
    Thanked 404 Times in 376 Posts
    Quote Originally Posted by RetiredGeek View Post
    Garvey,

    Try using the keyboard to move the application back to the available monitor.
    WinKey+Shift+[Right | Left] Arrow ...which ever is appropriate based on relative positions when 2nd monitor is connected.
    Geek! This would have instantly solved the problem I was having with EMC Networker (see my other post)!

  5. #5
    New Lounger Wisewiz's Avatar
    Join Date
    Apr 2011
    Location
    The Great White North
    Posts
    6
    Thanks
    3
    Thanked 0 Times in 0 Posts

    Old tricks for new monitor configurations

    Once upon a time, in W95, W98, and WXP, when we wanted the OS to remember where we had put a non-maximized window, we tried holding down Ctrl when we clicked the X. It even worked, sometimes.

    Now that multi-monitor configurations are fairly common, the problem of apps opening on the wrong monitor has become fairly common, too. One easy trick that seems to work (sometimes) is as follows: Open the app that opens on the wrong monitor (with the monitor on, of course, so that you can see the app window), move the window that's on the wrong monitor to the desired monitor, un-maximize it (or if it's already in the "normal" state, max it, then "restore" it) and close the program while the un-maxed window is on the desired monitor. Now open the app again, and it should open on the desired monitor. If you want to use it maxed, max it, then close and re-open it. It should still open on the desired monitor. If it doesn't, you may have one of those cantankerous programs that doesn't respond well to window-location setting with maximized windows, so try to use it always in a non-maximized size you're happy with.

    Wisewiz
    To those with no knowledge of computing, those with even a little knowledge seem like wizards.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •