Results 1 to 11 of 11
  1. #1
    4 Star Lounger
    Join Date
    Jan 2001
    Location
    Tacoma, Washington, USA
    Posts
    407
    Thanks
    0
    Thanked 1 Time in 1 Post

    Mystery gap at top of pages in some browsers

    I'm having trouble controlling my web pages top margin.

    http://www.cyberala.org

    The site is run by Wordpress 3.4.2. I setup the template to try and match the navigation bars to the vBulletin forum on the same site.

    At work, the top margin is okay when viewed with IE and Firefox but has a large space, gap at the top when viewed with Chrome. At home the page views okay in Firefox but has the gap at the top when viewed with IE and Chrome. Worse, I could swear the pages viewed okay initially in Chrome at home last night but at some point the gap appeared. I didn't make any changes to the style.

    One guess is there's something about the vBulletin on the website that is confusing the browser. There's a nav bar at the top margin in vBulletin that's about the height of that gap. Maybe when I changed from vBulletin to the home page it created the conflict. My other guess is something to do with collapsing margins but I can't figure it out where I might have gone wrong. Is there someone where who would take a look? Or is there somewhere else I can get some help on this? It would sure make my day to see it gone.
    Attached Images Attached Images
    Last edited by ailios; 2012-12-30 at 11:42. Reason: to add screenshot
    Daisy

  2. #2
    Super Moderator satrow's Avatar
    Join Date
    Dec 2009
    Location
    Cardiff, UK
    Posts
    2,138
    Thanks
    102
    Thanked 208 Times in 181 Posts
    Hi Daisy,

    The top of that page looks fine for me in Pale Moon, Firefox, SRWare Iron (like Chrome) and IE10 on W7x64

  3. #3
    4 Star Lounger
    Join Date
    Jan 2001
    Location
    Tacoma, Washington, USA
    Posts
    407
    Thanks
    0
    Thanked 1 Time in 1 Post
    Quote Originally Posted by satrow View Post
    Hi Daisy,

    The top of that page looks fine for me in Pale Moon, Firefox, SRWare Iron (like Chrome) and IE10 on W7x64
    Did you try going to the Forum then back to Home?

    I just added a screenshot to my first post so you can see what I see. Same amount of gap in IE9 and Chrome. Not seeing it in Firefox 17.01.
    Last edited by ailios; 2012-12-30 at 11:44.
    Daisy

  4. #4
    4 Star Lounger
    Join Date
    Jan 2001
    Location
    Tacoma, Washington, USA
    Posts
    407
    Thanks
    0
    Thanked 1 Time in 1 Post
    Well, I'll be ghoul dern. I was testing the login and logout of the forum in Firefox where the pages were displaying properly. After logging out and back into the forum now when I go the other Wordpress pages that stupid gap is back. Grrrr.
    Daisy

  5. #5
    Super Moderator satrow's Avatar
    Join Date
    Dec 2009
    Location
    Cardiff, UK
    Posts
    2,138
    Thanks
    102
    Thanked 208 Times in 181 Posts
    Your screenshot looks like the gap is waiting to be filled by a drop-down that never drops to tell you you need a plugin or something, weird!

    I've tried switching in and out of various sections and I still don't see 'your' gap.

    I can't think of anything helpful to add, I only read web pages, I don't create/troubleshoot them, sorry.

  6. #6
    Administrator
    Join Date
    Jun 2010
    Location
    Portugal
    Posts
    10,285
    Thanks
    130
    Thanked 1,153 Times in 1,062 Posts
    I tried IE (10), FF and Chrome, all latest versions and couldn't see a gap anywhere.

  7. #7
    Gold Lounger Roderunner's Avatar
    Join Date
    Dec 2009
    Location
    Scotland.
    Posts
    3,426
    Thanks
    16
    Thanked 212 Times in 180 Posts
    Hi Daisy, clicking the x in your image should close it. What happens when you click the icon next to it ?

    RR.JPG
    George's PC Specs. / Laptop. Desktop.

  8. #8
    4 Star Lounger
    Join Date
    Jan 2001
    Location
    Tacoma, Washington, USA
    Posts
    407
    Thanks
    0
    Thanked 1 Time in 1 Post
    Solved it. It was caused by Wordpress. In my user profile I had the box checked for "Show Toolbar when viewing site". My site uses custom pages, not posts, which may be the reason I saw the cap but not the Wordpress toolbar. I unchecked that box and the top margin works normally now.
    Daisy

  9. #9
    Lounge VIP bobprimak's Avatar
    Join Date
    Feb 2009
    Location
    Hinsdale, IL, USA
    Posts
    2,306
    Thanks
    138
    Thanked 113 Times in 97 Posts
    So the issue was that you were not viewing the pages as an outside access (ordinary user) would see them, but in some sort of Preview Mode, where a Toolbar was supposed to fill that gap? If so, this is why when editing Web Pages, I then log out entirely, clear all browser cookies, then try to see the page as an outside visitor (not logged in to the service). Or at least as close to that as is possible at the particular site where I have posted. Blog pages in particular (at several sites) seem not always to display in WYSIWYG formats I'm when editing them.
    -- Bob Primak --

  10. #10
    New Lounger
    Join Date
    Jun 2011
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts

    Looks good in Opera

    Looks good in Opera, with either 'fit-to-width'.

  11. #11
    New Lounger gabfree407's Avatar
    Join Date
    Jul 2012
    Location
    United Kingdom
    Posts
    3
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I tried to look that in my three browser i.e., Firefox, IE and chrome and it looks fine now.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •