Page 1 of 2 12 LastLast
Results 1 to 15 of 24
  1. #1
    3 Star Lounger
    Join Date
    Aug 2011
    Location
    South Africa
    Posts
    243
    Thanks
    47
    Thanked 0 Times in 0 Posts

    Seeing Task Host Window message and slowed shutdown

    On shut down receive the following message,"Task host window.Task host is executing shutdown tasks, and stopping tasks that are already running."
    This is causing a delay on shutting down.
    This problem has suddenly started.
    Regards
    Dave

  2. #2
    Plutonium Lounger Medico's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    12,625
    Thanks
    161
    Thanked 932 Times in 853 Posts
    Any chance you could do a System Restore to before the problem started?

    Have you made any changes just prior to the problem Starting?
    BACKUP...BACKUP...BACKUP
    Have a Great Day! Ted


    Sony Vaio Laptop, 2.53 GHz Duo Core Intel CPU, 8 GB RAM, 320 GB HD
    Win 8 Pro (64 Bit), IE 10 (64 Bit)


    Complete PC Specs: By Speccy

  3. #3
    3 Star Lounger
    Join Date
    Aug 2011
    Location
    South Africa
    Posts
    243
    Thanks
    47
    Thanked 0 Times in 0 Posts
    Hi Ted
    Have done a system restore to yesterday at 11:58, and receive the following message.
    The next restore point goes back to December last year.
    I did use Revo uninstaller to uninstall a programme, otherwise nothing esle.

    system restore.png

  4. #4
    Plutonium Lounger Medico's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    12,625
    Thanks
    161
    Thanked 932 Times in 853 Posts
    You could try to open an Administrative Command Prompt and type: sfc /scannow
    BACKUP...BACKUP...BACKUP
    Have a Great Day! Ted


    Sony Vaio Laptop, 2.53 GHz Duo Core Intel CPU, 8 GB RAM, 320 GB HD
    Win 8 Pro (64 Bit), IE 10 (64 Bit)


    Complete PC Specs: By Speccy

  5. #5
    3 Star Lounger
    Join Date
    Aug 2011
    Location
    South Africa
    Posts
    243
    Thanks
    47
    Thanked 0 Times in 0 Posts
    Have run the sfc/scannow, no violations found.

    Untitled.png

  6. #6
    Plutonium Lounger Medico's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    12,625
    Thanks
    161
    Thanked 932 Times in 853 Posts
    Before starting the shutdown sequence, try going to Task Manager and see what seems to be running. See if something unexpected is running.

    Also, try using What's In Startup or Autoruns to see what is starting with Windows. Is anything unexpected starting?
    BACKUP...BACKUP...BACKUP
    Have a Great Day! Ted


    Sony Vaio Laptop, 2.53 GHz Duo Core Intel CPU, 8 GB RAM, 320 GB HD
    Win 8 Pro (64 Bit), IE 10 (64 Bit)


    Complete PC Specs: By Speccy

  7. #7
    3 Star Lounger
    Join Date
    Aug 2011
    Location
    South Africa
    Posts
    243
    Thanks
    47
    Thanked 0 Times in 0 Posts
    Would any of the the tasks shown be something unexpected?
    I am asking as I do not have great idea what should be or should'nt be running.

    Task Manager.png

  8. #8
    Super Moderator
    Join Date
    Jun 2011
    Location
    New England
    Posts
    2,839
    Thanks
    88
    Thanked 347 Times in 312 Posts
    There's a hotfix available which may be relevant: There is a delay when you shut down, restart, or log off a computer that is running Windows 7

    I had to uninstall GreenPrint on Windows 7 because it caused delays.

    Bruce
    Last edited by BruceR; 2013-01-17 at 08:09.

  9. The Following 2 Users Say Thank You to BruceR For This Useful Post:

    DaveBRenn (2013-01-17),Dick-Y (2013-01-17)

  10. #9
    3 Star Lounger
    Join Date
    Aug 2011
    Location
    South Africa
    Posts
    243
    Thanks
    47
    Thanked 0 Times in 0 Posts
    Have not run the hotfix yet. Have now uninstalled the GreenPrint, then did a shutdown, no message!
    Maybe that was the problem, although I have been running GreenPrint for quite awhile.
    May I just ask what are the correct settings in 'msconfig' for the tabs in Windows 7?
    Regards
    Dave

  11. #10
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    20,616
    Thanks
    2
    Thanked 625 Times in 558 Posts
    In general, the default settings are fine. Please be more specific in your question about Msconfig.

    Joe

  12. #11
    3 Star Lounger
    Join Date
    Aug 2011
    Location
    South Africa
    Posts
    243
    Thanks
    47
    Thanked 0 Times in 0 Posts
    I was just wondering if there was something wrong on the settings as shown attached.

    Config.png

  13. #12
    Plutonium Lounger Medico's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    12,625
    Thanks
    161
    Thanked 932 Times in 853 Posts
    That is exactly what mine looks like as well.
    BACKUP...BACKUP...BACKUP
    Have a Great Day! Ted


    Sony Vaio Laptop, 2.53 GHz Duo Core Intel CPU, 8 GB RAM, 320 GB HD
    Win 8 Pro (64 Bit), IE 10 (64 Bit)


    Complete PC Specs: By Speccy

  14. #13
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    20,616
    Thanks
    2
    Thanked 625 Times in 558 Posts
    Quote Originally Posted by DaveBRenn View Post
    I was just wondering if there was something wrong on the settings as shown attached.

    Config.png
    Changing from "Normal Startup" in general is used to troubleshoot only. There is not a good reason to run "Selective startup" as the norm.

    Joe

  15. #14
    3 Star Lounger
    Join Date
    Aug 2011
    Location
    South Africa
    Posts
    243
    Thanks
    47
    Thanked 0 Times in 0 Posts
    Thanks Ted,
    Regards
    Dave

  16. #15
    New Lounger
    Join Date
    Jan 2013
    Posts
    1
    Thanks
    0
    Thanked 0 Times in 0 Posts
    I had this issue pop up recently. However, since my Windows 7 does shut down after a few seconds delay, I decided not to bother with the hot fix given in BruceR's reply.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •