Results 1 to 4 of 4
  1. #1
    Lounger
    Join Date
    Feb 2010
    Location
    Essex, UK
    Posts
    40
    Thanks
    1
    Thanked 0 Times in 0 Posts

    Unhappy FTP server problem

    Hi - anyone got any bright ideas how to resolve an FTP problem?

    We are moving server farms, and have migrated our (quite old) Serv-U FTP server from the old site, where it worked perfectly, to the new one. As far as we can see, it is configured correctly.

    However, only some clients will connect. Or, rather, they connect but then log out.

    Windows own FTP service and FileZilla, that I have tried, both connect perfectly and I can use the site. However, WS_FTP and Firefox's built in FTP service do not. I haven't attempted to diagnose the FF connection, but with WS_FTP I can connect and log in, and execute the FEAT command. But as soon as it gets the "203 OK to proceed message" and sends a CLNT command, Serv-U logs it out (at least, I think that it is at that end).

    So why would it work for some clients but not others? Turning passive FTP on or off in the client end doesn't seem to make any difference.

    Thanks.
    Stuart

  2. Subscribe to our Windows Secrets Newsletter - It's Free!

    Get our unique weekly Newsletter with tips and techniques, how to's and critical updates on Windows 7, Windows 8, Windows XP, Firefox, Internet Explorer, Google, etc. Join our 480,000 subscribers!

    Excel 2013: The Missing Manual

    + Get this BONUS — free!

    Get the most of Excel! Learn about new features, basics of creating a new spreadsheet and using the infamous Ribbon in the first chapter of Excel 2013: The Missing Manual - Subscribe and download Chapter 1 for free!

  3. #2
    Platinum Lounger
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    3,551
    Thanks
    7
    Thanked 225 Times in 213 Posts
    As you have not changed the server I would be checking the firewall for issues. You should be able to view a log of the FTP connections on the firewall.

    cheers, Paul

  4. #3
    Lounger
    Join Date
    Feb 2010
    Location
    Essex, UK
    Posts
    40
    Thanks
    1
    Thanked 0 Times in 0 Posts
    We did try that, but what I might now do is to look at the connections when using one of the clients that connects correctly and then compare it with connections with one of the clients that logs in and then quits, to see if we can spot what is going on.

  5. #4
    Lounger
    Join Date
    Feb 2010
    Location
    Essex, UK
    Posts
    40
    Thanks
    1
    Thanked 0 Times in 0 Posts
    OK, here's a solution!
    It was hanging at the CLNT command. So for now, I have turned off the FEAT command in the client, and the connections are coming through OK.
    But that isn't terribly ideal, and I have also discovered someone else having a similar problem with this (very old) version of Serv-U, so I am going to upgrade that as well and see what happens.

    Now on to the other FTP problems on the server...*sigh*

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •