Results 1 to 4 of 4
  1. #1
    New Lounger
    Join Date
    Dec 2009
    Location
    Seven Hills, Ohio, USA
    Posts
    13
    Thanks
    1
    Thanked 0 Times in 0 Posts

    XP not recognizing added Sata drive

    Just install a new Seagate 1TB drive in my Dell Dimension 9100. The BIOS recognizes the drive, and the Windows Device Manager indicated it is there. However, XP Windows Explorer fails to note its existence with a drive letter. I am aware there is a 4 "Device" limit, but I only have three others (primary Sata, CD Player and CDWR Drive). I assume partitions do not count in the "device" limit. Correct?

    Suggestions appreciated.

    Tom

  2. #2
    Super Moderator RetiredGeek's Avatar
    Join Date
    Mar 2004
    Location
    Manning, South Carolina
    Posts
    9,436
    Thanks
    372
    Thanked 1,457 Times in 1,326 Posts
    Tom,

    Does the device have a partition? Has it been Formatted?
    May the Forces of good computing be with you!

    RG

    PowerShell & VBA Rule!

    My Systems: Desktop Specs
    Laptop Specs

  3. #3
    New Lounger
    Join Date
    Dec 2009
    Location
    Seven Hills, Ohio, USA
    Posts
    13
    Thanks
    1
    Thanked 0 Times in 0 Posts
    From a comment in the Windows 7 forum, I was pointed to XP Disk Manager. That utility fixed the the problem.

  4. #4
    Silver Lounger
    Join Date
    Oct 2012
    Posts
    2,335
    Thanks
    13
    Thanked 267 Times in 260 Posts
    Good! There is no 4 device limit though. Perhaps you are confusing that with the 4 Primary partitions per MBR type hard drive limit?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •