Results 1 to 10 of 10

Thread: Firefox slow

  1. #1
    Star Lounger
    Join Date
    Mar 2009
    Posts
    62
    Thanks
    10
    Thanked 1 Time in 1 Post

    Firefox slow

    Hi Im running windows 7 home premium 4 gig of RAM and when Firefox updated to release 18.0 I noticed web pages would not load as fast as they used to. Ive used the Firefox tweak in the Windows 7 For Dummies which worked fine up until they went to 18.0. Is there a problem with Firefox 18 ? Any help is greatly appreciated

  2. #2
    Gold Lounger Roderunner's Avatar
    Join Date
    Dec 2009
    Location
    Scotland.
    Posts
    3,462
    Thanks
    16
    Thanked 216 Times in 183 Posts
    Hi schonman,
    if I have trouble after updating FF, I download the latest version and re install it with my firewall disabled. It will do an upgrade install so you won't lose your settings.
    Installing.pdf
    O wad some Power the giftie gie us, to see oursels as ithers see us!

  3. #3
    Super Moderator jwitalka's Avatar
    Join Date
    Dec 2009
    Location
    Minnesota
    Posts
    6,798
    Thanks
    117
    Thanked 799 Times in 720 Posts
    Try disabling all your plugins. If your speed returns, enable them a few at a time until you find the culprit.

    Jerry

  4. #4
    Silver Lounger
    Join Date
    Oct 2012
    Posts
    2,335
    Thanks
    13
    Thanked 267 Times in 260 Posts
    I would say the extensions idea is a good one. I'm using 18.0.1 without issue. In fact its the only browser of the big three that doesn't seem to have issues with Windows 8 so FF scored a new convert with me when I'm using W8 at least.

  5. #5
    3 Star Lounger
    Join Date
    Apr 2010
    Posts
    332
    Thanks
    15
    Thanked 16 Times in 16 Posts
    Having same issue, will try the disabling method.

    Turned everything off and that made no change.
    Last edited by ldb; 2013-03-05 at 11:44. Reason: ran the tests

  6. #6
    3 Star Lounger
    Join Date
    Apr 2010
    Posts
    332
    Thanks
    15
    Thanked 16 Times in 16 Posts
    Went back to Firefox 18.0.0 and installed ad block plus and still no joy. I guess having slow internet is better than none.

  7. #7
    Super Moderator jwitalka's Avatar
    Join Date
    Dec 2009
    Location
    Minnesota
    Posts
    6,798
    Thanks
    117
    Thanked 799 Times in 720 Posts
    Is it just Firefox? If IE is also slow, you may have network problems and/or malware. If you are using a wireless connection, try a different channel. To be on the safe side, download and run Malwarebytes. (www.malwarebytes.org)

    Jerry

  8. #8
    3 Star Lounger
    Join Date
    Apr 2010
    Posts
    332
    Thanks
    15
    Thanked 16 Times in 16 Posts
    I tried IE and it seemed faster. I have already scanned with 3 malware scanners as described in another post by me the same day. I ave a lot of customizations with Firefox that I am reluctant to give up. Thanks for the reply.

  9. #9
    3 Star Lounger
    Join Date
    Apr 2010
    Posts
    332
    Thanks
    15
    Thanked 16 Times in 16 Posts
    It used to be that I could delete my internet cache every time before I shut down the PC and not have to worry about lengthy page loads. I have now started not deleting the cache and Firefox is running much faster. Perhaps they designed it so it is more cache dependent. I guess now I recommend keeping your cache files when using Firefox and only deleting them when necessary.

  10. #10
    Silver Lounger
    Join Date
    Oct 2012
    Posts
    2,335
    Thanks
    13
    Thanked 267 Times in 260 Posts
    Pages have become a lot "heavier" over time with graphics and animations also. When someone surfs a well-established facebook page now, its coming by the megabyte instead of the old connection-conscious conservation. Unless turned off, scroll down on a wall page and it just keep loading and loading and loading...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •