Results 1 to 9 of 9
  1. #1
    4 Star Lounger
    Join Date
    Mar 2002
    Location
    Sacramento, California, USA
    Posts
    411
    Thanks
    3
    Thanked 1 Time in 1 Post

    Setting user permissions: each computer lists only itself in "Locations"

    I'm trying to set up a workgroup with two computers: my desktop (Windows 7) and a laptop (Windows XP). What's happening does not make sense to me.

    The workgroup is set up and I'm trying to share one drive (my data drive) with read-only privileges in each direction. That is, the account I use on the desktop should have read-only access to the laptop's data drive, and the account I use on the laptop should have read-only access to the desktop's data drive.

    On the desktop I opened the data drive's Properties dialog and selected the Sharing tab. The tab said that the drive was not shared, and the Share button was disabled. I clicked the Advanced Sharing button, opening the Advanced Sharing dialog.

    On the Advanced Sharing dialog I checked the Share this folder box, enabling the other fields and buttons. I let the share name default to the drive name, reduced the number of simultaneous users from 20 to 4, and clicked the Permissions button, opening the Permissions dialog.

    Permissions initially shows that Everyone has Read access only. I clicked Add, opening the Select Users or Groups dialog. My intention was to add my laptop username to the share permissions, then delete Everyone. In Select Users or Groups, Object Type defaulted to Users, Groups, or Built-in security principals. That was correct, so I left it alone. I clicked the Locations button to change From this location from the desktop to the laptop and got a list that contained only the desktop. Thus I could not proceed.

    This seems to indicate that the desktop does not recognize the laptop's presence in the workgroup, but that does not seem to be so. The navigation pane in Windows Explorer lists both computers under Network -- twice each!

    On the laptop I disabled simple file sharing, then went through the same procedure as on the desktop, and got the same result (the Locations dialog lists only the local computer, in this case the laptop). Again, Windows Explorer lists both computers under Network, although here it shows each only once.

    At this point I should have password-protected read-only access to each computer's data drive from the other, since Everyone still has read-only permission. But it isn't working that way.

    When I try to access the desktop's data drive from the laptop, Windows Explorer lets me access Entire Network > Microsoft Windows Network > Workgroup > computername > Users > username. It requires me to enter a username and password to get to the computername, as it should. Once I'm there, though, I see a list of files and folders that includes My Videos, My Pictures, Downloads, etc., and a few files that are probably configuration files for applications. The data drive is not there.

    When I try to access the laptop's data drive from the desktop, the reverse happens: when I select Network > computername I am not prompted for a username and password, but am simply given access to the "folder." It contains three items: the laptop's data drive, SharedDocs, and Printer.

    What's the trick to making this work right?
    Last edited by jsachs177; 2013-02-21 at 12:05.

  2. Subscribe to our Windows Secrets Newsletter - It's Free!

    Get our unique weekly Newsletter with tips and techniques, how to's and critical updates on Windows 7, Windows 8, Windows XP, Firefox, Internet Explorer, Google, etc. Join our 480,000 subscribers!

    Excel 2013: The Missing Manual

    + Get this BONUS — free!

    Get the most of Excel! Learn about new features, basics of creating a new spreadsheet and using the infamous Ribbon in the first chapter of Excel 2013: The Missing Manual - Subscribe and download Chapter 1 for free!

  3. #2
    Administrator
    Join Date
    Jun 2010
    Location
    Portugal
    Posts
    9,962
    Thanks
    126
    Thanked 1,100 Times in 1,012 Posts
    Use the same username and password on both computers and things should work as you wish. This may mean adding a new account to both computers, since you only want read-only access in the other computer.

    Without a server, each of the computers does not have access to the list of valid user accounts from the other computer, thus the need to use an account with the same username and password in each computer.

  4. #3
    4 Star Lounger
    Join Date
    Mar 2002
    Location
    Sacramento, California, USA
    Posts
    411
    Thanks
    3
    Thanked 1 Time in 1 Post
    Thanks for your advice... I did as you suggested last week, and it worked. This week it no longer works, and I have no idea why. I hope you can help me figure it out.

    I'm trying to access each machine's drive from the other, using a user name that is has administrative privileges on both machines.

    The XP machine's data drive permissions are set to allow everyone full access. (I want to change that, but I want to get the darn thing to work first.) The Win7 machine's data drive permissions are set to give administrative users full access, and "authenticated users" all privileges except "full control" and "special permissions." Both are set to allow sharing.

    When I try to access the Win7 machine's data drive from the XP machine, I have no problems. When I try access the XP machine's data drive from the Win7 machine, I can't. When I try to display XP data drive's privileges from the Win7 machine, I get a message that says "You do not have permission to view or edit the object's permission settings."

    Can you make any sense of this?

  5. #4
    Administrator
    Join Date
    Jun 2010
    Location
    Portugal
    Posts
    9,962
    Thanks
    126
    Thanked 1,100 Times in 1,012 Posts
    Are there firewalls involved? Can you disable them, just to be sure they are not interfering?

  6. #5
    Silver Lounger
    Join Date
    Oct 2012
    Posts
    2,065
    Thanks
    12
    Thanked 234 Times in 227 Posts
    When I try to display XP data drive's privileges from the Win7 machine, I get a message that says "You do not have permission to view or edit the object's permission settings."
    You won't ever be able to do that I don't think unless you have full access to begin with. View and set each from it's own interface.

  7. #6
    4 Star Lounger
    Join Date
    Mar 2002
    Location
    Sacramento, California, USA
    Posts
    411
    Thanks
    3
    Thanked 1 Time in 1 Post
    There are no firewalls involved except the ones built into the respective versions of Windows. I can try disabling those to see what happens, but it doesn't seem like a solution to the problem.

  8. #7
    New Lounger
    Join Date
    Mar 2013
    Location
    New Zealand
    Posts
    4
    Thanks
    0
    Thanked 0 Times in 0 Posts
    When you are using the accounts to authenticate to the shared folder. Make sure you tick the box that says something like "Remember This Password" or something in that line. And that should have cache the credentials of the logon that you are using to access the share. And Make sure you remember to update this if you change any passwords.

  9. #8
    4 Star Lounger
    Join Date
    Mar 2002
    Location
    Sacramento, California, USA
    Posts
    411
    Thanks
    3
    Thanked 1 Time in 1 Post
    I've just solved this problem, and I want to let everyone know how.

    I Googled the error message I got when I tried to access the XP machine's drive, and I examined several different solutions that were presented. This one set me on the right track.

    The problem was that in XP it is not enough to set the share permissions of the drive (in the Properties dialog's Sharing tab). You must set the disk's properties in the Security tab as well.

    Once I added "Everyone" to the list of authorized groups, with read and list access allowed, everything worked.

    I'm left with one comparatively minor puzzle: why can't I set permission for a more restrictive group than "Everyone"? On the XP machine the Properties box shows specific users qualified with the local machine name as "machineName/userName"?

    When I click the Add button I get a dialog with the following controls:

    1. Select this obj4ect type (set to "Users, Groups, or Built-in security principals," with an Object Types button to select a different value.
    2. From this location (shows the local machine's name, with a Locations button to select a different value)
    3. Enter the object name (an empty, enabled field).

    I should be able to click Locations, select the name of the Win7 machine, and enter a user name. But "Locations" lists only the local machine, even when the two computers are accessing each others' drives, making it absolutely useless.

    I've tried a few possible workarounds, without luck. For example, there's an examples link after "Enter the object names to select which suggests that I should be able to enter "workgroup/username." The presumably, the workgroup name will be stripped out and placed in the Location field. When I try this, though, Windows refuses to accept the name.

  10. The Following User Says Thank You to jsachs177 For This Useful Post:

    mrjimphelps (2013-03-25)

  11. #9
    Administrator
    Join Date
    Jun 2010
    Location
    Portugal
    Posts
    9,962
    Thanks
    126
    Thanked 1,100 Times in 1,012 Posts
    Without a domain server (running Windows Server), each machine only knows about its own accounts. There is no way around it.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •