Page 1 of 2 12 LastLast
Results 1 to 15 of 30
  1. #1
    Lounger
    Join Date
    Jan 2010
    Location
    Michigan, USA
    Posts
    41
    Thanks
    2
    Thanked 0 Times in 0 Posts

    IE10 constantly crashes

    I don't normally use IE but for those few sites that just won't work with anything else, I keep it around. Anyway, downloaded and installed IE10. Big Mistake!!! Right from the start it kept giving me messages that it "stopped working" and would have to restart. Tried everything that I could think of to fix it but finally gave up and uninstalled IE10 and reverted to IE9.

    This is just for info but, if anyone has a good fix, I "might" try it again

    Thanks
    John Chinook

  2. #2
    Lounger
    Join Date
    Jan 2010
    Location
    Michigan, USA
    Posts
    41
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Sorry, forgot to say that I'm using Win 7

  3. #3
    Bronze Lounger Drew1903's Avatar
    Join Date
    Mar 2012
    Location
    Calgary
    Posts
    1,476
    Thanks
    0
    Thanked 108 Times in 86 Posts
    Please, don't take offense... are you sure you grabbed IE10 for Windows 7? There's an IE10 and an IE10 for Windows 7.

    The one on the left
    http://ie.microsoft.com/testdrive/In...s/Default.html

    Cheers,
    Drew
    Win8Logo (2013_02_06 10_30_24 UTC).jpg

  4. #4
    Silver Lounger t8ntlikly's Avatar
    Join Date
    Dec 2001
    Location
    Chandler, AZ
    Posts
    2,007
    Thanks
    37
    Thanked 12 Times in 10 Posts
    I too installed I.E.10 for Win7, and am experiencing the same thing. "Script Errors" etc. Pages not rendering correctly even with the compatibility turned on, tabs jumping from one position to another. I tried out an earlier version and got the same results, so I uninstalled it. I thought by this time things would have gotten better, but they haven't. I for one am going back to I.E. 9
    Thanks John
    Teamwork is essential; it gives the enemy other people to shoot at. (Murphy's War Laws #39)

  5. #5
    Administrator
    Join Date
    Jun 2010
    Location
    Portugal
    Posts
    10,363
    Thanks
    130
    Thanked 1,163 Times in 1,070 Posts
    IMO, IE has long been a waste of time. I once never used a browser but IE, but today it is far beyond the competition. Seeing how much MS has tried with IE and how it still lags behind, not really sure what to think about the possibility of IE becoming my default browser again. Doesn't look likely.

  6. #6
    Star Lounger
    Join Date
    Aug 2010
    Location
    Lufkin,TX
    Posts
    61
    Thanks
    32
    Thanked 2 Times in 2 Posts
    Your problems may be related to a faulty update from Microsoft(KB2670838).
    See the post under windows 7 titled internet explorer has stopped working.
    I had some of the same problems but after uninstalling this update they went away.

    I installed the preview version when it came out but eventually uninstalled it due to mostly compatibility issues.
    after installing the final version other than needing to use the compatibility mode a few times I haven't had any of the problems I had with the preview version.
    Barry

  7. #7
    Super Moderator jwitalka's Avatar
    Join Date
    Dec 2009
    Location
    Minnesota
    Posts
    4,879
    Thanks
    68
    Thanked 562 Times in 508 Posts
    Quote Originally Posted by ruirib View Post
    IMO, IE has long been a waste of time. I once never used a browser but IE, but today it is far beyond the competition. Seeing how much MS has tried with IE and how it still lags behind, not really sure what to think about the possibility of IE becoming my default browser again. Doesn't look likely.
    I use IE 10, Firefox, and Chrome interchangeably. Frankly, I no longer see any significant difference between the three with the exception I have to use compatibility mode on a few rare web sites.

    Jerry

  8. #8
    Lounger
    Join Date
    Jan 2010
    Location
    Michigan, USA
    Posts
    41
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Drew 1903: Yup, I'm absolutely, positively sure that I got IE 10 for Win 7.

    BWC: Already had Microsoft(KB2670838) installed when i "upgraded" to IE 10 but, based on your note, I uninstalled it, reinstalled IE 10 (for Win 7) and then reapplied the MS update. Result= absolutely no hoowah, no change from original crashing, etc. So, I'm back to square 1 and IE 9 (for those few occasions that nothing else will work). Thanks for the suggestion, it was worth a try.

    To all other replies. I really wasn't trying to start a war over how good/bad/indifferent IE is or is not in comparison to any other browser. As I noted in my original post "I don't normally use IE but for those few sites that just won't work with anything else, I keep it around" . That is just MY personal preference.

    Thanks
    John Chinook

  9. #9
    Bronze Lounger Drew1903's Avatar
    Join Date
    Mar 2012
    Location
    Calgary
    Posts
    1,476
    Thanks
    0
    Thanked 108 Times in 86 Posts
    John,

    Although, I have no problem w/ IE10 in Windows 8 or Windows 7 and from this vantage point it's hard to say why you are... using 10 may be cool but, not that big a deal... certainly just leave it @ IE9. If it ain't broke don't fix it, as the saying goes.

    Cheers,
    Drew
    Win8Logo (2013_02_06 10_30_24 UTC).jpg

  10. #10
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    20,623
    Thanks
    2
    Thanked 627 Times in 560 Posts
    You said you uninstalled KB2670838 and reinstalled IE10. Did you try IE10 before reinstalling KB2670838? On some systems KB2670838 was the problem not IE10.

    Joe

  11. #11
    Bronze Lounger Drew1903's Avatar
    Join Date
    Mar 2012
    Location
    Calgary
    Posts
    1,476
    Thanks
    0
    Thanked 108 Times in 86 Posts
    John,

    If you want, you could give this a try. Click on download today. I & my company are MS Partners, as part of that I receive certain E-mails; this link was in one today. This is NOT the IE10 for Windows 7 preview... It is IE10.

    http://blogs.technet.com/b/serverand...edia=zOTmediaz

    Cheers,
    Drew
    Win8Logo (2013_02_06 10_30_24 UTC).jpg

  12. #12
    Lounger
    Join Date
    Jan 2010
    Location
    Michigan, USA
    Posts
    41
    Thanks
    2
    Thanked 0 Times in 0 Posts
    Drew, John
    I misspoke above. I uninstalled KB2670838 and then reinstalled IE 10 for Win 7 and it is/was IE10 for Win 7 not IE 10 Preview. But did not reinstall KB2670838. In fact I still haven't reinstalled it based on y'alls comments. Still had the constant IE 10 crash problem. Guess IE 9 will stay on my machine for quite a while longer. It isn't like I use it regularly or even often.
    Thank y'all for all the input. I appreciate the efforts.

    John Chinook

  13. #13
    Bronze Lounger Drew1903's Avatar
    Join Date
    Mar 2012
    Location
    Calgary
    Posts
    1,476
    Thanks
    0
    Thanked 108 Times in 86 Posts
    Mind you, aside from what I tossed in here that I received from TechNet...

    IE10 will be pushed out to Win 7 Users via WU anon.

    Cheers,
    Drew
    Win8Logo (2013_02_06 10_30_24 UTC).jpg

  14. #14
    Lounger JSS3rd's Avatar
    Join Date
    Dec 2009
    Location
    NY
    Posts
    43
    Thanks
    0
    Thanked 1 Time in 1 Post
    I have 64-bit Win 7 Pro SP1 installed. I've installed 64-bit IE 10 a couple of times, both by Windows Update and from the downloaded file. It simply will NOT display images. Uninstalling it automatically reloads IE 9, which behaves properly. I'll stick with 9.
    Jim

  15. #15
    Bronze Lounger Drew1903's Avatar
    Join Date
    Mar 2012
    Location
    Calgary
    Posts
    1,476
    Thanks
    0
    Thanked 108 Times in 86 Posts
    Jim,

    This is most odd. I honestly can't make sense of it why you would have such a condition. I, also, didn't think it was being pushed out via WU, yet. It is going to be but, if it's, already, showing up there, cool. The link I put in above is from TechNet, came to my E-mail as a MS Partner

    From the MS site to which the link points:
    "We will begin auto updating Windows 7 customers to IE10 in the weeks ahead, starting today with customers running the IE10 Release Preview"

    Were you already running the Preview?

    Cheers,
    Drew
    Win8Logo (2013_02_06 10_30_24 UTC).jpg
    Last edited by Drew1903; 2013-03-07 at 03:23.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •