Page 1 of 2 12 LastLast
Results 1 to 15 of 20
  1. #1
    Super Moderator BATcher's Avatar
    Join Date
    Feb 2008
    Location
    A cultural area in SW England
    Posts
    2,829
    Thanks
    19
    Thanked 109 Times in 103 Posts

    Windows 7, Dell Optiplex 320, and Wake-on-LAN

    The charity where I work has a collection of (elderly) Dell Optiplexes, in order of production: 320, 745, 330, 360, 755, 760, which I have recently converted from XP Pro (32-bit, not surprisingly!) to Windows 7 Pro 32-bit.

    All these PCs, when running XP, could be powered up from the shutdown state using Wake-on-LAN.

    Once converted to Windows 7, all the models can be powered up from the shutdown state using Wake-on-LAN - with the exception of the two Optiplex 320s!

    Both Optiplex 320s have a Broadcom 440x 10/100 Integrated Controller, and the latest=final BIOS level 1.1.12.
    There is no NIC driver for Windows 7 on the Dell website or on the Broadcom website, so it is using the appropriate Microsoft v4.60.0.1 2008/10/13 driver, bcm4sbxp.sys.

    I have spent an inordinate amount of time changing the BIOS options and the NIC Power Management options, and there is one, single, method by which I can get WOL reliably to wake up the 320s:
    • power the PC on from the front power button,
    • wait until the BIOS screen with the progress bar shows,
    • then immediately hold in the power button to power it off again

    Using any other (software-induced) method of powering down (Start button then click on Shut Down or SHUTDOWN.EXE -s or PSSHUTDOWN.exe -s) means that a subsequent Wake-on-LAN command fails to power-up the system unit.

    This makes me think that the problem must lie somewhere within the confines of the Windows 7 Power Options settings, but I've been through these and tried a few changes, but to no avail. I've googled extensively, but nothing I've come across will work, or otherwise it doesn't apply to my circumstance.

    Any suggestions about what else I can try? Thanks!
    BATcher

    Dear Diary, today the Hundred Years War started ...

  2. #2
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    20,543
    Thanks
    1
    Thanked 614 Times in 550 Posts
    Did you see this Optiplex GX320 Wake on Lan ?

    Are there Vista drivers available that you could trying installing in compatability mode?

    Joe

  3. #3
    Silver Lounger mrjimphelps's Avatar
    Join Date
    Dec 2009
    Location
    USA
    Posts
    2,158
    Thanks
    204
    Thanked 209 Times in 201 Posts
    Suppose you put them in sleep or hibernate mode. Perhaps WOL would work if you did one of them.

  4. #4
    Super Moderator BATcher's Avatar
    Join Date
    Feb 2008
    Location
    A cultural area in SW England
    Posts
    2,829
    Thanks
    19
    Thanked 109 Times in 103 Posts
    Quote Originally Posted by JoeP517 View Post
    Did you see this Optiplex GX320 Wake on Lan ?

    Are there Vista drivers available that you could trying installing in compatibility mode?

    Joe
    I think I've already tried this Low Power Mode flip-flop, but I'll try it again next time I'm in.
    I tried to install the Vista drivers (same level from Dell and from Broadcom), but kept on being told that the (Microsoft) one which was already installed was newer. (Is there any way to force install an older driver?)


    Quote Originally Posted by mrjimphelps View Post
    Suppose you put them in sleep or hibernate mode. Perhaps WOL would work if you did one of them.
    You are probably right, but it would mean changing the mind-set of the users, who have been programmed both at home and at work to shut down their PCs. It might be easier to get WOL working from shutdown, rather than to change the habits of a lifetime!
    BATcher

    Dear Diary, today the Hundred Years War started ...

  5. #5
    Platinum Lounger
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    3,620
    Thanks
    7
    Thanked 231 Times in 219 Posts
    Seems to me that Windows is disabling WOL in the NIC on shutdown. The only suggestion I have is to check the settings in the driver when Windows is running (obviously).

    cheers, Paul

  6. #6
    Super Moderator BATcher's Avatar
    Join Date
    Feb 2008
    Location
    A cultural area in SW England
    Posts
    2,829
    Thanks
    19
    Thanked 109 Times in 103 Posts
    Quote Originally Posted by Paul T View Post
    Seems to me that Windows is disabling WOL in the NIC on shutdown. The only suggestion I have is to check the settings in the driver when Windows is running (obviously).
    Not sure I quite understand that, Paul!
    The settings in the driver (Power Management) are correct to the best of my knowledge, so are you saying that the NIC itself could have some internal settings changed by Windows 7 during 'normal' shutdown, and kept like this after power-off, which would prevent WOL waking up the PC? How could I ever determine that?
    BATcher

    Dear Diary, today the Hundred Years War started ...

  7. #7
    Super Moderator BATcher's Avatar
    Join Date
    Feb 2008
    Location
    A cultural area in SW England
    Posts
    2,829
    Thanks
    19
    Thanked 109 Times in 103 Posts
    Joe - I've just tried the Low Power Mode flip-flop again, and, no, sadly, this doesn't cause WOL to work subsequently...
    BATcher

    Dear Diary, today the Hundred Years War started ...

  8. #8
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    20,543
    Thanks
    1
    Thanked 614 Times in 550 Posts
    Have you removed the NIC and re-added it? You should have the opportunity to use your own driver.

    Joe

  9. #9
    Super Moderator BATcher's Avatar
    Join Date
    Feb 2008
    Location
    A cultural area in SW England
    Posts
    2,829
    Thanks
    19
    Thanked 109 Times in 103 Posts
    Not until tomorrow!

    ... and installing the back-level Dell Vista 32-bit NIC driver didn't restore the ability to get WOL to work. Grrrh.

    Unless I can find where in Power Options the Magic Setting (to match the Magic Packet!) is located, I will have to try mrjimphelps' suggestion of replacing shotdown/poweroff everywhere with hibernate or sleep (WOL works with hibernate and sleep, but of course the original user is still logged on).
    Last edited by BATcher; 2013-03-08 at 07:02.
    BATcher

    Dear Diary, today the Hundred Years War started ...

  10. #10
    Platinum Lounger
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    3,620
    Thanks
    7
    Thanked 231 Times in 219 Posts
    If you power off the machine while Windows is running does WOL work?

    cheers, Paul

  11. #11
    Super Moderator BATcher's Avatar
    Join Date
    Feb 2008
    Location
    A cultural area in SW England
    Posts
    2,829
    Thanks
    19
    Thanked 109 Times in 103 Posts
    You mean just crash Windows? No, I haven't tried this - since my earliest youth this has not been a good move...!

    Later...
    As a one-off experiment I started up the PC, logged on to Windows 7, and held in the power-off button until it turned off. And, no, Wake-on-LAN wouldn't then power it on/wake it up.
    Last edited by BATcher; 2013-03-26 at 09:50.
    BATcher

    Dear Diary, today the Hundred Years War started ...

  12. #12
    Administrator
    Join Date
    Mar 2001
    Location
    St Louis, Missouri, USA
    Posts
    20,543
    Thanks
    1
    Thanked 614 Times in 550 Posts
    Using Device Manager for my Intel NIC I can enable or disable WOL under Properties | Power Management.

    Joe

  13. #13
    Super Moderator BATcher's Avatar
    Join Date
    Feb 2008
    Location
    A cultural area in SW England
    Posts
    2,829
    Thanks
    19
    Thanked 109 Times in 103 Posts
    Ah, Joe, would that it were that simple! I have been there many and oft...
    BATcher

    Dear Diary, today the Hundred Years War started ...

  14. #14
    Platinum Lounger
    Join Date
    Dec 2009
    Location
    Earth
    Posts
    3,620
    Thanks
    7
    Thanked 231 Times in 219 Posts
    Can you add another NIC and disable the on-board one?

    cheers, Paul

  15. #15
    Super Moderator BATcher's Avatar
    Join Date
    Feb 2008
    Location
    A cultural area in SW England
    Posts
    2,829
    Thanks
    19
    Thanked 109 Times in 103 Posts
    I suppose I could, but the Optiplex motherboard would need to make available a two-pin connection for wires from the NIC which would convey the Wake-on-LAN signal. I've never managed to find such a connector on an Optiplex motherboard!
    BATcher

    Dear Diary, today the Hundred Years War started ...

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •